Last Comment Bug 520707 - [SeaMonkey 2.1] 'Linux comm-central-trunk leak test build' crashes since +/- "2009/10/01 10:45:01"
: [SeaMonkey 2.1] 'Linux comm-central-trunk leak test build' crashes since +/- ...
Status: VERIFIED FIXED
[Fixed by bug 536299]
: crash, regression
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: seamonkey2.1a1
Assigned To: Robert Kaiser (not working on stability any more)
:
Mentors:
Depends on: 493237 521549 536299
Blocks: 542952 CcMcBuildIssues
  Show dependency treegraph
 
Reported: 2009-10-05 20:08 PDT by Serge Gautherie (:sgautherie)
Modified: 2010-01-28 22:02 PST (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Serge Gautherie (:sgautherie) 2009-10-05 20:08:04 PDT
On:
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey&maxdate=1254493981&hours=24

Last green:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1254416596.1254417196.27773.gz&fulltext=1
Linux comm-central-trunk leak test build on 2009/10/01 10:03:16
{
[...]
++DOMWINDOW == 8 (0x98d2be8) [serial = 8] [outer = (nil)]
WARNING: Subdocument container has no frame: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/layout/base/nsDocumentViewer.cpp, line 2340
[...]
}

First orange:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1254422044.1254423525.4558.gz
Linux comm-central-trunk leak test build on 2009/10/01 11:34:04
{
[...]
++DOMWINDOW == 8 (0x9145770) [serial = 8] [outer = (nil)]
Leaked URLs:
  [...]
[...]
TEST-UNEXPECTED-FAIL | automation.py | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:00:07.913050
TEST-UNEXPECTED-FAIL | automation.py | application crashed (minidump found)
program finished with exit code 255
}

***

Regression timeframes:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=513e9fc142e5&tochange=8a43f01f1d64
6 changesets.
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=b951cf498d4f&tochange=a7ee2565bfa6
1 changeset.
Comment 1 Serge Gautherie (:sgautherie) 2009-10-05 20:15:44 PDT
Magnus, could you check whether bug 507392 is the cause or can be ruled out? Thanks.
Comment 2 Serge Gautherie (:sgautherie) 2009-10-08 19:12:40 PDT
It doesn't always crashes after the 8th window, sometimes it's after the 24th.

For example:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1255034717.1255039118.14348.gz&fulltext=1
Linux comm-central-trunk leak test build on 2009/10/08 13:45:17

++DOMWINDOW == 23 (0xa72d658) [serial = 23] [outer = 0xa6b0ae8]
WARNING: If possible, callers of GetURLSpecFromFile should use GetURLSpecFromDir or GetURLSpecFromActualFile instead.: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/netwerk/base/src/nsURLHelper.cpp, line 157
Document http://localhost:8888/bloatcycle.html loaded successfully
WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/netwerk/base/src/nsSimpleURI.cpp, line 224
Document about:blank loaded successfully
++DOMWINDOW == 24 (0xa273908) [serial = 24] [outer = 0xa6b0ae8]
Leaked URLs:
}
Comment 3 Magnus Melin 2009-10-09 09:54:08 PDT
(In reply to comment #1)
> Magnus, could you check whether bug 507392 is the cause or can be ruled out?

Unlikely as the Linux comm-1.9.1 leak test build isn't failing.
Comment 4 Serge Gautherie (:sgautherie) 2009-10-09 18:58:23 PDT
KaiRo, could you try and clobber, before I "CC" the m-c people? Thanks.
Comment 5 Robert Kaiser (not working on stability any more) 2009-10-10 05:30:21 PDT
I'm not doing any real work this weekend, possibly even until Tuesday, with the possible exception of pushing RC1 public. This also will have to wait until I'm back (and hopefully more healthy).
Comment 6 Serge Gautherie (:sgautherie) 2009-10-13 07:32:29 PDT
While there, we should fix new
{
MINIDUMP_STACKWALK not set, can't process dump.
}
Comment 7 Serge Gautherie (:sgautherie) 2009-10-13 08:52:48 PDT
(In reply to comment #6)
> While there, we should fix new
> {
> MINIDUMP_STACKWALK not set, can't process dump.
> }

See bug 493237.

*****

{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1255443002.1255447569.21748.gz&fulltext=1
Linux comm-central-trunk leak test build on 2009/10/13 07:10:02

[kairo@kairo.at - 2009/10/13 07:37:50]
clobbered the objdir on all slaves, maybe this helps

++DOMWINDOW == 24 (0x973e6f0) [serial = 24] [outer = 0x969ef58]
Leaked URLs:
}

Crash still there: cc'ing m-c people.
Comment 8 Serge Gautherie (:sgautherie) 2009-10-19 18:29:15 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > MINIDUMP_STACKWALK not set, can't process dump.
> 
> See bug 493237.

See also TB bug 522115.
Comment 9 Serge Gautherie (:sgautherie) 2009-10-21 20:59:40 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > See bug 493237.
> 
> See also TB bug 522115.

Actually, that latter bug is more related to bug 523773 which I filed.

This bug is related to
http://mxr.mozilla.org/comm-central/source/mozilla/build/leaktest.py.in
which should be covered by former Core bug 493237.
Comment 10 Serge Gautherie (:sgautherie) 2010-01-18 15:57:37 PST
(In reply to comment #7)
> (In reply to comment #6)
> > While there, we should fix new
> > {
> > MINIDUMP_STACKWALK not set, can't process dump.
> > }
> 
> See bug 493237.

KaiRo, do we need to do something to enable/port that bug?
Comment 11 Robert Kaiser (not working on stability any more) 2010-01-19 05:31:55 PST
(In reply to comment #10)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > While there, we should fix new
> > > {
> > > MINIDUMP_STACKWALK not set, can't process dump.
> > > }
> > 
> > See bug 493237.
> 
> KaiRo, do we need to do something to enable/port that bug?

We should not need to do anything to port it, as CCUnittestBuildFactory() has been patched as well, it depends on when it has been checked in though if this is already on the master or not.
Comment 12 Serge Gautherie (:sgautherie) 2010-01-19 10:17:09 PST
(In reply to comment #11)

See bug 493237 comment 7 and 8.
I wondered if you needed to update a SeaMonkey master or the like?
Comment 13 Serge Gautherie (:sgautherie) 2010-01-21 06:49:12 PST
KaiRo updated our master:

before:
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1264006079.1264009115.425.gz
Linux comm-central-trunk leak test build on 2010/01/20 08:47:59

No symbols path given, can't process dump.
MINIDUMP_STACKWALK not set, can't process dump.
}

after
{
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1264014698.1264015053.2511.gz
Linux comm-central-trunk leak test build on 2010/01/20 11:11:38

No symbols path given, can't process dump.
}

Bug 493237 tool part is fixed.
I'm not sure what/where we need to do to get the symbol path.
Comment 14 Serge Gautherie (:sgautherie) 2010-01-28 22:02:11 PST
(In reply to comment #13)

I filed bug 542952.

*****

R.Fixed, by bug 536299.
V.Fixed, per tinderbox after 2010/01/27 19:53:20.

Note You need to log in before you can comment on or make changes to this bug.