hyatt should give ben $50

VERIFIED FIXED in Future

Status

Core Graveyard
Tracking
P1
critical
VERIFIED FIXED
17 years ago
11 months ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: David Hyatt)

Tracking

(6 keywords)

Trunk
Future
x86
Windows 2000
access, helpwanted, meta, modern, pp, testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (Windows NT 5.0; U)
BuildID:    123456789

Currently, I have money, but $50 would sure be nice, especially if I didn't have 
to do anything to get it. 

Reproducible: Always
Steps to Reproduce:
1.open wallet
2.look inside
3.no $50

Actual Results:  No $50							

Expected Results:  $50, from hyatt.
(Assignee)

Comment 1

17 years ago
For fifty bucks, I expect service with a smile.

Comment 2

17 years ago
I'm with you up until step 2, but I can't understand how to reproduce step 3.  
How is `no $50' a step to reproduce?

[btw, hyatt, I'd also like $50, and I'm even willing to smile.  then again, i'm 
a minor by law, so depending on the service you're referring to, it may be 
illegal for me to get involved...

Comment 3

17 years ago
I can't reproduce that reliably here, but it does happen intermittently.
Considering your user agent, perhaps we could pay you to use dogfood?  Oh yeah,
we already do...
Adding newmod, helpwanted keywords, ->future.  Note that, to verify this, jrgm
will need to look in his wallet and see $50 too. 
Keywords: helpwanted, newmod
Target Milestone: --- → Future
I demand that this be escalated! I'm tired of paying the $1.50 service fee at 
the Tech Credit ATM in 22!

Comment 5

17 years ago
hmm. WHO CONFIRMED THIS! When I launch mozilla and open the 
wallet there doesn't seem to be a spot for money :) just credit cards. 
Reporter: Please explan how money goes in the computer (cd drive?)

Comment 6

17 years ago
I can't seem to reproduce this bug. After following steps 1 and 2, there's clearly three polymer-plastic yellow-brown coloured Aussie $50 notes. Maybe this bug is only present on American builds of Wallet...

Comment 7

17 years ago
Well, I guess three Aussie $50 notes are almost worth a US $50... ;-)

Comment 8

17 years ago
Obviously NS aren't paying you enough Ben ??

Comment 9

17 years ago
nah, he just spends it all on donuts ;)
(Assignee)

Comment 10

17 years ago
in your dreams.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
bastard!

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
this is bad. the fact that this was closed as WONTFIX didn't help my fragile 
constitution much. Marking P2, scheduling for M18 pending nervous 
breakdown. 
Status: REOPENED → ASSIGNED
Priority: P3 → P2
Target Milestone: Future → M18
OK, per recommendation, updating summary and reassigning. 
Assignee: hyatt → don
Status: ASSIGNED → NEW
Component: XP Toolkit/Widgets: XBL → XP Apps
Summary: give ben $50 → give ben $500
Summary: give ben $500 → get hyatt to give ben $500
Component: XP Apps → Y2k

Comment 14

17 years ago
Maybe this should go to evangelism for blake to work on evanging hyatt to 
work with mozilla.

Comment 15

17 years ago
I can reproduce the original bug. All I see is $35. Hyatt: if you get a chance, 
please give me $50 (or $500) as well.

Comment 16

17 years ago
sk3: now wait here. If non NS people are going to get money, I should too. 
After all, I confirm and verify bugs :)

Comment 17

17 years ago
zach: I'm not the one dishing out the money, take it to Hyatt!

Comment 18

17 years ago
Cheap-ass commie Linux users won't see the lack
of $50 as a problem.  Adding pp keyword.
Keywords: pp

Comment 19

17 years ago
Updating summary to be more fair
Summary: get hyatt to give ben $500 → get hyatt to give everyone $500

Comment 20

17 years ago
Updating summary to be more fair
Summary: get hyatt to give everyone $500 → get hyatt to give everyone $500, because ben deserves it

Comment 21

17 years ago
Jeez, whyinthehell do I always own these bugs?

Comment 22

17 years ago
moving to browser-general component.  the `Y2k' component is being retired...
Component: Y2k → Browser-General

Comment 23

17 years ago
component to printing. Maybe we can have a print money feature in 
mozilla.
Component: Browser-General → Printing

Comment 24

17 years ago
Marking "Future" because, of course, we do really want to fix this bug at some time.
Target Milestone: M18 → Future

Comment 25

17 years ago
Should this be in the PR3 release notes, the RTM release notes, or both? And, 
could someone provide a non-technical explanation of this bug, please?

Comment 26

17 years ago
nav triage team:
we can ship without this but will accept if we get a patch. adding [RTM NEED
INFO] to request a patch.

reassigning to hamerly who may have to escalate.
Assignee: don → hamerly
Whiteboard: [RTM NEED INFO]

Comment 27

17 years ago
Also changing summary back to $50.  $500 would be over-engineering.
Summary: get hyatt to give everyone $500, because ben deserves it → get hyatt to give everyone $50, because ben deserves it

Comment 28

17 years ago
Some other QA and I agree that Ben should get $50 if he can eat 10 whoppers in 
8 hours.  We are admittedly doubtful, since Ben seems to be just a little bit 
smaller than Claudius...

Comment 29

17 years ago
I've easily reproduced this bug, heck, I've got four kids, two in college/grad
school!  If you can't repro this one, come see me and I'll "help".  I'm willing
to kick in $10 bucks to help Ben out, I'll even buy him some donuts on a
one-time basis. Re-assigning to don, ben's manager cause I'm a bona-fida
pointy-headed manager.
Assignee: hamerly → don

Comment 30

17 years ago
I would agree with Blake: Claudius may in fact be able to eat Ben entirely.

Thanks Jim!  I'm glad that our veep recognizes the seriousness of this bug
report, taking the time to reproduce it himself.

BTW, can someone explain to me why the Hell this is a Win2K platform-only bug
and why it's considered a "pp" (platform parity) problem?  I thought wallets, by
their very nature, were cross platform.  Then again, I have seen some big-ass
wallets on occssion.

Speaking of wallets, shouldn't Steve Morse really own this bug?

Comment 31

17 years ago
Jeez, I can't believe this was "RTM NEED INFO"!

Whiteboard: [RTM NEED INFO]

Comment 32

17 years ago
I18N, L10N: the currency symbol should of course be externalised. I'd like £50.
I managed to come up with a minimised testcase:
   http://www.damowmow.com/mozilla/bugs/52094/

Don: This bug was marked 'pp' because it will not affect Linux users, who, it is
argued, have no need for money. See Adam D. Moss 2000-09-21 04:45 comment.

Moving to "Autofill" component for obvious reasons.
Component: Printing → Autofill
Keywords: testcase
simplifying the summary. if it's going to be too costly, gramps is never going 
to be able to fix this bug. 
Summary: get hyatt to give everyone $50, because ben deserves it → get hyatt to give ben $50
Raising priority to get some traction on this before gramps leaves us.
Priority: P2 → P1
(Assignee)

Comment 36

17 years ago
It will be a cold day in hell before I give you even a penny.
Well that must have been November 15, because people said the same thing about
Netscape 6....
er, Netscape 6 shipping, that is. 
Reassigning to Vishy as don has left. 
Assignee: don → vishy
updating summary to reflect christmas spirit, inflation and a penalty for the
delay in fixing this bug. hyatt now shd give ben $100. 
Status: NEW → ASSIGNED
Summary: get hyatt to give ben $50 → get hyatt to give ben $100
(Assignee)

Comment 41

17 years ago
awwwwww, man....

Comment 42

17 years ago
This is obviously an international affair since it involves a New Zealander 
asking an American for money.  Changing component to Internationalization.

And that will get it off Vishy's radar when he looks for wallet bugs to triage.
Component: Form Manager → Internationalization
Hyatt's plan is becoming clear: if he waits long enough, Ben will have left the
US and so Hyatt will be saved the $100.
Well, I will _visiting_ the US sometime over the next few weeks, so maybe if I 
donated $20 while I was there we could finally mark this one as in-progress!?
Sure; it would probably be best if you dropped it by my cube while you were here
(or post it to me), I can deal with it from there on. Would that be ok?
let's not change the purpose of this bug, please.

David will continue to need to give me $100 no matter which country I am in.
Keywords: nsbeta1
nominating for nsbeta1

Comment 48

17 years ago
Since Hyatt is not doing his part here, I decided to let the rest of the 
community join in the fun. Go to http://www.zachlipton.com/ben and 
donate money (fake money, but who cares :)

Somewhat like the hungersite, you can give money to ben!

Comment 49

17 years ago
Before I donate, I need Ben to put forward a case of why he is worthy for the 
money, and what he is going to use it for.
For why, see bonsai.mozilla.org.
I expect he will put the money towards buying lego.
This is newmod?!? Well, ok, then it's probably nsonly, too...
Keywords: nsonly

Comment 52

17 years ago
is ben a non-profit organization?  how would we treat donations to him on our 
tax forms?
Keywords: newmod → modern

Updated

17 years ago
Blocks: 59921
Pav: I would guess he's a charity case...
Reassigning to pchen, and resetting requested amount to $50 to increase my 
chances of getting it. 
Assignee: vishy → pchen
Status: ASSIGNED → NEW
Summary: get hyatt to give ben $100 → get hyatt to give ben $50

Comment 55

17 years ago
how is this bug changed now that Ben has left the U.S.?
The bug remains the same. David still needs to give me US$50. I will execute a 
currency conversion when the exchange rate suits it. 
Summary: get hyatt to give ben $50 → get hyatt to pay ben's car insurance premiums
The best quote I've got so far is NZ$3285 per annum from the National Auto 
Club. The other quote (from the other org. that'd insure the Silvia) was $3688. 
I'll take the lower of the two. Updating the summary to reflect this change in 
requirements. 
(Assignee)

Comment 58

17 years ago
Updating summary to reflect a new goal.  I'm curious if this is physically
possible.  I would suggest that some burly New Zealander try it and report their
findings to us all in this bug report.

Summary: get hyatt to pay ben's car insurance premiums → shove ben's head up his own ass
will attempt for stated fee. 
Summary: shove ben's head up his own ass → shove ben's head up his own ass for price of annual auto insurance
bah. All this insanity has resulted in reduced emphasis on the original focus of 
this bug report. Changing summary back to what it was originally. 
Summary: shove ben's head up his own ass for price of annual auto insurance → get hyatt to give ben $50

Comment 61

17 years ago
In all fairness, I think 50 rubles are in order for our man Goodger.

Russian dollars are acceptable, right?

And wouldn't this be a topperf bug?  Doesn't Ben need his money for top 
performance?

Comment 62

17 years ago
Banking on Ben not reading his bugmail (why would he start now?)...
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX

Comment 63

17 years ago
... tempting fate ...
Status: RESOLVED → VERIFIED
...well that's that then...
Status: VERIFIED → CLOSED
not so fast
Status: CLOSED → REOPENED
Resolution: WONTFIX → ---
If you leave the bug open, I'll take NZ$50, although that offer is good for 
this week only. 
And if we close it again?
nsbeta1-. 
Keywords: nsbeta1 → nsbeta1-
Resummarizing, changing amount to US$20,000. I need about this much to make up a 
down payment on a house. I'll put in the other $20,000. 
Assignee: pchen → hyatt
Status: REOPENED → NEW
Summary: get hyatt to give ben $50 → hyatt should give ben $20,000

Updated

16 years ago
Component: Internationalization → Tracking
Keywords: meta
Enough is enough. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WONTFIX

Comment 71

16 years ago
verf
Status: RESOLVED → VERIFIED

Comment 72

16 years ago
Oh
My
God

No, not the bug, but the fact that there are still 6 votes!  :)
Depends on: 115341
No longer depends on: 115341

Updated

16 years ago
Blocks: 123456

Updated

16 years ago
No longer blocks: 123456

Updated

16 years ago
No longer blocks: 59921
Gosh, this bug is still active? Adding a few zeros. ;-)
Summary: hyatt should give ben $20,000 → hyatt should give ben $20,000,000
resummarizing. 
Summary: hyatt should give ben $20,000,000 → hyatt should give ben $50
This bug is now featured on the homepage (click on Bugzilla screenshot)!

lol...

so who was it that picked out the bug to use?  Ben?  

Comment 76

14 years ago
Probably... cool bug :)

Comment 77

14 years ago
Of course, if this bug is fixed, then the entire community would have to receive
$50 or else it would have to be reopened.
No, that would be a "give everyone $50" metabug, which this would block.
Too bad they don't have a $50 here http://www.chris.com/ascii/
 _____________________________________________________________________
|                                                                      |
|  =================================================================== |
| |%/^\\%&%&%&%&%&%&%&%&{ Federal Reserve Note }%&%&%&%&%&%&%&%&//^\%| |
| |/inn\)===============------------------------===============(/inn\| |
| |\|UU/              { UNITED STATES OF AMERICA }              \|UU/| |
| |&\-/     ~~~~~~~~   ~~~~~~~~~~=====~~~~~~~~~~~  P8188928246   \-/&| |
| |%//)     ~~~_~~~~~          // ___ \\                         (\\%| |
| |&(/  13    /_\             // /_ _\ \\           ~~~~~~~~  13  \)&| |
| |%\\       // \\           :| |/ ~ \| |:  3.21  /|  /\   /\     //%| |
| |&\\\     ((iR$)> }:P ebp  || |"- -"| ||        || |||| ||||   ///&| |
| |%\\))     \\_//      sge  || (|e,e|? ||        || |||| ||||  ((//%| |
| |&))/       \_/            :| `._^_,' |:        || |||| ||||   \((&| |
| |%//)                       \\ \\=// //         || |||| ||||   (\\%| |
| |&//      R265402524K        \\U/_/ //   series ||  \/   \/     \\&| |
| |%/>  13                     _\\___//_    1932              13  <\%| |
| |&/^\      Treasurer  ______{Franklin}________   Secretary     /^\&| |
| |/inn\                ))--------------------((                /inn\| |
| |)|UU(================/ ONE HUNDERED DOLLARS \================)|UU(| |
| |{===}%&%&%&%&%&%&%&%&%a%a%a%a%a%a%a%a%a%a%a%a%&%&%&%&%&%&%&%&{===}| |
| ==================================================================== |
|______________________________________________________________________|
It's been a couple of years. interest rates and all. $100 now. 

Other folks - do not mess with the summary, I mean business. It's $100. 
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---
Summary: hyatt should give ben $50 → hyatt should give ben $100
Blocks: 215379
(Assignee)

Comment 81

14 years ago
If you keep this up, I will send the Chrome Registry over to your house to break
your kneecaps.  It can do it too.  You've seen its code.

Comment 82

14 years ago
Created attachment 129578 [details]
Testcase for breakage. 

I've come up with a testcase.

It appears that a error in nsCSSFrameConstructor.cpp:1000 is causing prices in
car manufacturer sites to be massively inflated. 

Its back to "telnet mozilla.org 80" for me....


(there is no bug in nsCSSFrameConstructor.cpp except for the fact that its too
big)

Comment 83

14 years ago
Adding access keyword (...making Mozilla accessible to users with ... special
needs).
Flags: blocking1.6a?
Keywords: access
Steffen: Was that accidentally done on the wrong bug?

If not, I don't mean to be a killjoy, but we shouldn't be wasting the time of
drivers. This bug is cute and all, but I don't think they'll appreciate that.
Flags: blocking1.6a?

Comment 85

14 years ago
Hi,
What is this a joke or a surious bug?
I am confused on this one.

Comment 86

14 years ago
Actually, it's a Sirius bug.  The problem apparently stems from planetary and 
star alignment issues. Wait until Capricorn is in full force, and the bug may 
disappear due to a phenomenon known as a 'Christmas Bonus'.

Comment 87

14 years ago
Hi,
Well it makes no scence to me.

Updated

14 years ago
Severity: blocker → critical
It's not so much a Sirius issue as a XM issue. This $100 would go well towards
my XM Satellite receiver.
Wow.

I got hyatt drunk and he gave me fifty bucks, in cash. 

After more than four years, I think I can consider this bug fixed. 
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → FIXED
Summary: hyatt should give ben $100 → hyatt should give ben $50

Comment 90

13 years ago
Depends who bought the drink. If you did, it's hardly a good deal.

Comment 91

13 years ago
Verified, I watched it with my own eyes. But if I recall correctly, it was only $49.

If there are any "hyatt should give ben a lap dance" bugs, those can be resolved
too. What a crazy night it was.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.