Jetpack 0.5+ incompatible with Firebug 1.4.3 and superior

RESOLVED FIXED

Status

Mozilla Labs
Jetpack Prototype
P2
major
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Thomas, Assigned: atul)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.2b1pre) Gecko/20091007 Namoroka/3.6b1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.2b1pre) Gecko/20091007 Namoroka/3.6b1pre

In you have Jetpack 0.5 (or the trunk) with Firebug 1.4.3 (or 1.5alpha), the latter is not recognized and you can't debug your Jetpack anymore.

On about:jetpack page, Firebug will always be disabled and Jetpack will say: "You either don't have the latest version of Firebug installed, ...". 

Therefore, console.log() will display nothing on Firebug panel but, your message will still appear in the console error built-in with Firefox.

Firebug 1.4.2 works well, so the problem came with 1.4.3.

Reproducible: Always

Steps to Reproduce:
1. Update Firebug to version 1.4.3 or more.
2. Try to debug your jetpack.
Actual Results:  
It's not working!

Expected Results:  
console.log() should display a message on Firebug panel.

Anant visually confirmed the bug with me on EU MozCamp 09.
I am seeing this as well.
Assignee: nobody → avarma
Priority: -- → P2
Duplicate of this bug: 527647
The proposed solution how to fix this is here:
https://bugzilla.mozilla.org/show_bug.cgi?id=527647#c0

Honza

Comment 4

9 years ago
Created attachment 412396 [details] [diff] [review]
Patch to fix this

Patch as it said in #527647

Comment 5

9 years ago
I've commited the patch and it appears to work. Thanks, Erik, for fixing the bug!

http://hg.mozilla.org/labs/jetpack/rev/e3fea7d93898
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 529554

Comment 7

8 years ago
I am using Jetpack 0.7 but although I can see that it kind of integrates with the latest versions of Firebug, console.log still does not work as desired. It works fine in the about:jetpack tab but if you switch to another tab to do some ‘real’ debugging, console.log stops doing anything. Even if you switch back to the about:jetpack tab, you need to reload the tab before console.log starts working again.  I get this with any version of Firebug later than 1.4.0.
You need to log in before you can comment on or make changes to this bug.