Alt-Tab in FullScreen video does not exit full screen mode

RESOLVED FIXED in Firefox 3.7a1

Status

()

defect
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: tchung, Assigned: dao)

Tracking

(Blocks 1 bug, {verified1.9.2})

Trunk
Firefox 3.7a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(status1.9.2 beta4-fixed)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
changing applications using ALT-tab in full screen mode will not exit the full screen video.  instead, it will switch to firefox and leave the normal view in pause.   With Flash video, it automatically Escapes full screen mode when ALT-TABbing

See screenshot

Repro:
1) install trunk nightly on windows: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b1pre) Gecko/20091007 Namoroka/3.6b1pre
2) go to a ogg video (eg. see url)
3) Play video, and then right click -> Full Screen
4) When video is in full screen, click ALT-TAB
5) Verify firefox comes to focus, but the FS video is playing in the background, with a frozen normal video in foreground

Actual:
- ALT-TAB a FS video will keep playing in the background behind the application

Expected:
- ALT-TAB a FS video should exit FS mode, just like flash.
(Reporter)

Comment 1

10 years ago
(Assignee)

Updated

10 years ago
Depends on: 511503
(Assignee)

Updated

10 years ago
Blocks: 453063
No longer depends on: 453063
(Assignee)

Comment 2

10 years ago
Posted patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #409571 - Flags: review?(dolske)
To be honest, I prefer the current behaviour over Flash's.  Having dual monitors, it has always bothered me that I can't watch flash video fullscreen on one monitor while interacting with applications on the other monitor.  Even in the single monitor case, I would prefer that the video continued playing fullscreen when I control-tab to another application.  

Why do we think that it is a good thing to copy flash?  I have heard others complain about how flash handles this and doing a google search (http://www.google.com/search?q=flash+fullscreen+dual+monitor) shows many results of people complaining about this and hacks to fix it (including using a HEX editor on the flash dll on Windows)
(Assignee)

Comment 4

10 years ago
I guess we could add a hidden pref, but we should optimize this for single-monitor setups first and foremost.
(Assignee)

Comment 5

10 years ago
(In reply to comment #4)
> I guess we could add a hidden pref

Or detect if there are multiple monitors, but I don't know if there's a reliable way to do that. I think looking at screen.left would work if the video played on the right monitor.
Comment on attachment 409571 [details] [diff] [review]
patch

Yeah, a followup on having a pref or (better yet) automagically handling multiple monitors would be the way to go. We should at least take this to fix the single-monitor issue in comment 0.
Attachment #409571 - Flags: review?(dolske) → review+
(Assignee)

Comment 7

10 years ago
Filed bug 527298.
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 8

10 years ago
http://hg.mozilla.org/mozilla-central/rev/8450cda7477f
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
(Assignee)

Updated

10 years ago
Attachment #409571 - Flags: approval1.9.2?
Attachment #409571 - Flags: approval1.9.2? → approval1.9.2+
This may have caused a regression, see bug 530654. Also, no test?
(Assignee)

Updated

10 years ago
Depends on: 530654
Flags: in-testsuite?
(Assignee)

Updated

10 years ago
Blocks: 530661
(Assignee)

Updated

10 years ago
Duplicate of this bug: 530173
(Assignee)

Updated

10 years ago
Duplicate of this bug: 530114
Verified fixed on 1.9.2 with builds on all platforms like Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b5pre) Gecko/20091126 Namoroka/3.6b5pre ID:20091126033851
Keywords: verified1.9.2
You need to log in before you can comment on or make changes to this bug.