If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Moz-Image-Region Cannot be used on Feed Icon in Bookmarks Menu on Mac OS X

RESOLVED DUPLICATE of bug 416136

Status

SeaMonkey
Themes
RESOLVED DUPLICATE of bug 416136
8 years ago
8 years ago

People

(Reporter: Ben Frisch, Assigned: Ben Frisch)

Tracking

({modern})

Trunk
seamonkey2.0
x86
Mac OS X
modern
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 405417 [details] [diff] [review]
Use feedIcon16.png in the Bookmarks Menu

As mentioned in bug 418774 -moz-image-region does not work with Mac OS X menu items.  The attached patch sets modern to use feedIcon16.png in the bookmarks menu like the Classic Mac theme does, expect it does so on all OSes.
Attachment #405417 - Flags: review?(neil)
Attachment #405417 - Flags: approval-seamonkey2.0?
Flags: wanted-seamonkey2.0?
Flags: blocking-seamonkey2.0?

Comment 1

8 years ago
See bug 416136

Comment 2

8 years ago
Comment on attachment 405417 [details] [diff] [review]
Use feedIcon16.png in the Bookmarks Menu

> #feedsMenu[disabled="true"] {
>   -moz-image-region: rect(32px 16px 48px 0px);
> }
> 
> #feedsMenu[open="true"] {
>   -moz-image-region: rect(48px 16px 64px 0px);
> }
> 
>+/* ::::: feeds ::::: */
>+
>+#feedsMenu {
>+  list-style-image: url("chrome://communicator/skin/icons/feedIcon16.png") !important;
>+}
Instead of using !important, why didn't you remove the rules above?
Also, a comment on why we can't use feeds.png would be good.
Attachment #405417 - Flags: review?(neil) → review-

Comment 3

8 years ago
A graphical glitch is neither critical nor blocking the release, but would be nice to be fixed. In this case, it's a duplicate of bug 416136, though, please go for that one to resolve it.
Severity: critical → normal
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: wanted-seamonkey2.0?
Flags: blocking-seamonkey2.0?
Resolution: --- → DUPLICATE
Duplicate of bug: 416136

Updated

8 years ago
Attachment #405417 - Flags: approval-seamonkey2.0?
You need to log in before you can comment on or make changes to this bug.