Archiving a message is too easy to do accidentally

RESOLVED DUPLICATE of bug 476590

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 476590
9 years ago
9 years ago

People

(Reporter: jercox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

The archive feature has a single keystroke shortcut with no confirmation. Typing 'a' results in the selected message being archived with no warning or indication. This results in users thinking their mail has been deleted.

Keyboard shortcuts should not be based on a single keystroke. It is far to easy to miss the search box, and when you start typing a search string containing the letter a, have the selected message disappear. Especially for people who keep much of their mail in the inbox, this is extremely confusing and frustrating.

Confirmed in Thunderbird 3.0b3 and 3.0b4, on an x86 windows machine and PowerPC and Intel Mac OS X machines.

Reproducible: Always

Steps to Reproduce:
1. Select a message.
2. Type "a"
3.
Actual Results:  
The message dissappeared from my inbox.

Expected Results:  
None.

The only other shortcuts that are single keystrokes are for navigation only, and even those pop up a warning if you are going to navigate between folders. This moves messages with no warnings, and is not easy to disable. Not acceptable behavior in a product that handles messages that people value. Especially when the message is not found in the trash, the message appears to be gone, and people get worried enough to call me for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476590
You need to log in before you can comment on or make changes to this bug.