Closed Bug 521644 Opened 10 years ago Closed 9 years ago

<textbox type="number"> sends input event too early on first keystroke

Categories

(Toolkit :: XUL Widgets, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 506069

People

(Reporter: Fallen, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(1 file)

772 bytes, application/vnd.mozilla.xul+xml
Details
Attached file Testcase
When using a textbox with type number and listening to oninput, the first time it fires, the event is fired too early, causing event.target.value and to have the original value. Testcase attached.
Keywords: testcase
Duplicate of this bug: 469742
This seems in some way also be true for the timepicker - which is also a kind of textbox.
The onchange event always delivers one value before.

I don't know if this is dependant on the textbox or should go into another bug.
Duping.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506069
Status: RESOLVED → VERIFIED
No longer blocks: 653637
You need to log in before you can comment on or make changes to this bug.