[fr] Choose search plug-ins for Fennec in French

RESOLVED FIXED

Status

defect
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: stas, Assigned: bugzilla.fr)

Tracking

({productization})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bootstrapped][twitter][ebay.fr][yahoo.fr])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

10 years ago
You've indicated an interest in participating in the localization of mobile Firefox (aka Fennec). We want to ship Fennec with a good list of search engines for French. As the technical details of implementation are being worked on, we'd like to start the discussion about the choice of search engines. This bug is about agreeing on a set of search engines, and will not tackle the implementation (at least not yet).

First, the localization team and Staś will look at the market for the locale and come up with a good set of search providers. The guidelines for making recommendations are on https://wiki.mozilla.org/L10n:Mobile/Productization. You're welcome to suggest engines already shipped in desktop Firefox for French, if they fit well in the categories outlined on the wiki.

For en-US, we currently use the following set, which may serve as an inspiration:
Google, Wikipedia, Amazon, Yahoo, Twitter.

Note that according to the guidelines, for some categories it may be better to leave them empty than to ship with en engine that's irrelevant or unavailable in your region.

After we decided on a particular search engine, we will need to test it in Fennec. You can test on a mobile device and on the desktop (download the builds from <http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/>). Staś will help with testing on a device, too. If the service works fine, Staś will contact the owner and ask for permission, and for specifics like proper search flags. $name, we'll likely need your help to at least get the contact information if we don't have them already.

We don't know the implementation details yet, so for now, please don't create patches nor land anything. We will keep you posted as we figure out the how's and when's.

Thanks.
Assignee

Comment 1

10 years ago
Based on the en-US search engine proposition, we can use the french version of Google, Wikipedia, Amazon and Yahoo (as in firefox).
For twitter, there is no French version of the website, but I don't know any other similar service in French.

Comment 2

10 years ago
Twitter will soon be localized, but no firm date right now : http://www.zdnet.fr/actualites/internet/0,39020774,39709106,00.htm
Reporter

Updated

10 years ago
Duplicate of this bug: 526854

Comment 4

10 years ago
Twitter is now localized in French.
Reporter

Comment 5

10 years ago
(In reply to comment #4)
> Twitter is now localized in French.

It seems that Twitter's interface language is a user setting available in Twitter's settings. It is detected based on Accept Language header and as such the URL doesn't change depending on the locale. So we should be good using the default en-US plugin.

Comment 6

10 years ago
(In reply to comment #5)
I agree with you Staś for Twitter.
For the other searchplugins (comment #1) that need to be localized, should we do something ourselves, or do you take care of this?
Reporter

Comment 7

10 years ago
Cédric: if you could copy the engines from desktop Firefox, modify list.txt accordingly and attach the patch here, that would be a huge help for me :)

Also, please read <https://wiki.mozilla.org/L10n:Integrated_Search_Instructions> to see how to deal with <Description/> fields in the plug-ins. You'll either have to adapt them slightly to the new wording, or remove them completely. Please don't land plug-ins with unchanged <Descriptions/>.

Thanks!

Comment 8

10 years ago
Posted patch Diff for Fennec searchplugins (obsolete) — Splinter Review
I took the searchplugins from the French Firefox.
I removed amazon and cnrtl to have 5 searchplugins.
I added "Recherche intégrée" (Integrated search) for:

google-fr.xml
yahoo-france.xml
wikipedia-fr.xml
eBay-france.xml

I copied the Twitter searchplugin as is from en-US
Attachment #414534 - Flags: review?
Reporter

Comment 9

10 years ago
Hi Cédric,

Thanks for the patch. It looks good, although you shouldn't copy the en-US plug-ins if they're identical. They will be copied in the build process. Copying the Google plug-in is especially not advised: the plug-in is capable of auto-updating, so we're better off using the one from en-US.

I allowed myself to create a new patch for French (I wrote a script today to semi-automate this for other locales). Things that I changed:

- google and twitter are in list.txt, but no xml files are present
- added "Recherche intégrée" to Wikipedia, Yahoo! France and eBay France
- changed Wikipedia's and Yahoo's icon from 16x16px to 32x32px
- added exclamation mark in "Yahoo!" in their plug-in

I don't have a better icon for eBay, if I manage to get one, I'll file a new bug to change it.

Please check the patch and if it's OK, land it.

Thanks.
Attachment #414534 - Attachment is obsolete: true
Attachment #414672 - Flags: review?(cedric.corazza)
Attachment #414534 - Flags: review?
Assignee

Comment 10

10 years ago
Comment on attachment 414672 [details] [diff] [review]
Google, Wikipedia (fr), Yahoo! France, eBay France, Twitter

Seems ok for me.

Comment 11

10 years ago
Comment on attachment 414672 [details] [diff] [review]
Google, Wikipedia (fr), Yahoo! France, eBay France, Twitter

Fine to me too.
Attachment #414672 - Flags: review?(cedric.corazza) → review+
Reporter

Updated

10 years ago
Whiteboard: [bootstrapped][twitter][ebay.fr][yahoo.fr]
You need to log in before you can comment on or make changes to this bug.