Last Comment Bug 522065 - PCA complains when installer is cancelled
: PCA complains when installer is cancelled
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: NSIS Installer (show other bugs)
: unspecified
: x86 Windows 7
: P2 normal with 1 vote (vote)
: ---
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
Mentors:
: 531388 (view as bug list)
Depends on: 569058
Blocks: win7support
  Show dependency treegraph
 
Reported: 2009-10-13 10:33 PDT by Masatoshi Kimura [:emk]
Modified: 2010-06-24 14:22 PDT (History)
19 users (show)
shaver: blocking1.9.2-
shaver: wanted1.9.2+
robert.strong.bugs: in‑testsuite-
robert.strong.bugs: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.7-fixed
.11-fixed


Attachments
win32 installer complains to PCA (51.07 KB, image/png)
2009-10-19 21:56 PDT, [not reading bugmail]
no flags Details
patch to update the manifest of the 7zSD.sfx (80.11 KB, patch)
2010-06-01 23:42 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
ted: review+
christian: approval1.9.2.7+
christian: approval1.9.1.11+
Details | Diff | Review
New 7-zip stub (119.50 KB, application/octet-stream)
2010-06-01 23:44 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
no flags Details

Description Masatoshi Kimura [:emk] 2009-10-13 10:33:52 PDT
Steps to reproduce:
1. Run installer on Windows 7.
2. Cancel the installer.
Actual result:
Program Compatibility Assistant will pop up.
Expected result:
PCA should not pop up.

We need to update manifest to Windows 7 format to satisfy PCA.
http://forums.winamp.com/showthread.php?postid=2525010
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2009-10-13 10:47:51 PDT
Jim, Vlad, and Rob... just a heads up that firefox.exe might need this added as well.

http://code.msdn.microsoft.com/Windows7AppQuality
download the current release available towards the top on the right
 
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
  <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
    <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
      <application>
        <!—- The ID below indicates application support for Windows Vista -->
          <supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"/>
        <!—- The ID below indicates application support for Windows 7 -->
          <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
      </application>
    </compatibility>
  </assembly>
Comment 2 Rob Arnold [:robarnold] 2009-10-13 10:52:36 PDT
I don't recall seeing this when I've installed Firefox or Minefield. What do we need to do to trigger this dialog?
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2009-10-13 10:54:01 PDT
I don't know... the first I heard of this happening was last night via a blog entry.
Comment 4 James Ross 2009-10-13 18:26:54 PDT
I believe it only happens if the executable looks like an installer ("setup" in the name, etc.) and exits *without* adding a Programs and Features entry (may also count updating). A successful install won't trigger it. AFAIK it just suggests re-launching elevated, guessing that the install most likely failed because it didn't elevate.

As long as Firefox's setup elevates by itself (either at the start due to manifest or during the process) when installing for all users, it can be marked compatible with Windows 7 to avoid the PCA. However, if no elevation occurs w/o the user explicitly requesting it (e.g. via Explorer's context menu) then I'd strongly suggest against marking it compatible, since the PCA will be helping people get Firefox installed in that case.

I don't believe Firefox itself would benefit from being marked compatible given the list of things that affects, but that can be infestigated seperately.
Comment 5 Masatoshi Kimura [:emk] 2009-10-13 18:38:09 PDT
Firefox installer asks elevation by itself. We should not rely on the compatibility feature which can be turned off.
Moreover, users can cancel the setup at their own will (as I showed in STR). PCA dialog will confuse them in that case.
Comment 6 James Ross 2009-10-13 18:42:17 PDT
Only your first point actually matters. :P
Comment 7 [not reading bugmail] 2009-10-19 21:56:33 PDT
Created attachment 407223 [details]
win32 installer complains to PCA

Rob, here the screen of the PCA on W7 trying to install hourly win32.installer.exe files.

I get the PCA error even after setup.exe launches Minefield (firefox.exe) just fine.  I close Minefield, then the PCA pops up just for the installer.exe (no mention of the setup.exe or firefox.exe)
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2009-10-26 12:10:14 PDT
Blocking for investigation; rs, I'll leave it up to you to decide if this is a common issue or not. I don't see what the reporter says is happening, but I also don't cancel installs ;)
Comment 9 Mike Shaver (:shaver -- probably not reading bugmail closely) 2009-10-29 09:03:34 PDT
Cancelling installs for many installers pops up that dialog, for the reasons that Silver outlines.  It's confusing, but it's not really our UI, and I don't think we would hold the release for it.  Even "wanted" seems like a stretch given our schedule and load at this point, but I'm in a stretchy mood.
Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2009-11-27 14:19:29 PST
*** Bug 531388 has been marked as a duplicate of this bug. ***
Comment 11 Masatoshi Kimura [:emk] 2010-05-22 04:26:02 PDT
*** Bug 567497 has been marked as a duplicate of this bug. ***
Comment 12 Masatoshi Kimura [:emk] 2010-05-22 04:27:16 PDT
This bug will occur even if I didn't cancel the installer (see the duplicate bug for details).
Comment 13 [not reading bugmail] 2010-05-27 21:48:58 PDT
(In reply to comment #12)
> This bug will occur even if I didn't cancel the installer (see the duplicate
> bug for details).

Confirming, as I was seeing a similar experience.  Though I haven't seen it much since my first comment 7.  Using Win7 32bit.
Comment 14 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-01 23:42:45 PDT
Created attachment 448695 [details] [diff] [review]
patch to update the manifest of the 7zSD.sfx

This will take care of the installer portion... we'll still want to fix bug 569058.

This changes the manifest resource to

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<assemblyIdentity version="1.0.0.0" processorArchitecture="X86" name="7zS.sfx.exe" type="win32"/>
<description>7-Zip Self-extracting Archive v4.42</description>
<dependency>
<dependentAssembly>
<assemblyIdentity type="win32" name="Microsoft.Windows.Common-Controls" version="6.0.0.0" processorArchitecture="X86" publicKeyToken="6595b64144ccf1df" language="*"/>
</dependentAssembly>
</dependency>
<trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
<security>
<requestedPrivileges><requestedExecutionLevel level="asInvoker" uiAccess="false"/>
</requestedPrivileges>
</security>
</trustInfo>
<compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
<application>
<supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
<supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"/>
</application>
</compatibility>
</assembly>
Comment 15 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-01 23:44:55 PDT
Created attachment 448696 [details]
New 7-zip stub
Comment 16 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-02 12:51:23 PDT
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/6a40f493664d

Bug 569058 along with Bug 569534 will fix this for the uninstaller.
Comment 17 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-02 13:02:19 PDT
Comment on attachment 448695 [details] [diff] [review]
patch to update the manifest of the 7zSD.sfx

Drivers, this updates the 7-zip stub manifest for Windows 7 and we should take it on the branches
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-02 13:05:28 PDT
cc'ing a few people from SeaMonkey and Thunderbird... you'll want to do this for your 7zSD.sfx files in other-licenses.
Comment 19 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-02 22:21:49 PDT
Filed bug 569791 for SeaMonkey and attached a patch

Filed Bug 569789 for Thunderbird and attached a patch
Comment 20 Dan Mosedale (:dmose) 2010-06-08 12:29:14 PDT
Thanks, Rob!
Comment 21 christian 2010-06-14 14:40:56 PDT
We store the manifest resource in binary in the tree?
Comment 22 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-14 14:48:05 PDT
It is a resource in the 7-zip self extracting archive itself and we update it when necessary using reshack.exe since we don't compile it at build time. Examples

http://hg.mozilla.org/mozilla-central/log/7e685b61a291/other-licenses/7zstub/firefox/7zSD.sfx

http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/other-licenses/7zstub/firefox/7zSD.sfx&rev=HEAD&mark=1.5
Comment 23 christian 2010-06-24 13:45:12 PDT
Comment on attachment 448695 [details] [diff] [review]
patch to update the manifest of the 7zSD.sfx

a=LegNeato for 1.9.2.6 and 1.9.1.11. Please land this on mozilla-1.9.2 default and mozilla-1.9.1 default.

Code freeze is this Friday @ 11:59 pm PST.
Comment 24 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-24 14:22:01 PDT
Pushed to mozilla-1.9.1
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/c233c2334bf5

Pushed to mozilla-1.9.2
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/23386e833e53

For posterity I accidentally landed on GECKO1924_20100413_RELBRANCH and backed it out
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/90340fd7a2e6
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/a7c7a3ac2112

Note You need to log in before you can comment on or make changes to this bug.