Wishlist: Language list in Preferences -> Languages

VERIFIED DUPLICATE of bug 62578

Status

()

P3
enhancement
VERIFIED DUPLICATE of bug 62578
18 years ago
7 years ago

People

(Reporter: rch, Assigned: nhottanscp)

Tracking

({intl})

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It would be good to have Lithuanian [lt], Latvian [lv], Estonian [ee] in
 language list as there are encodings specific to these languages in supported
encodings.

Mozilla/5.0 (X11; U; FreeBSD 4.1-STABLE i386; en-US; m18) Gecko/20000911

	Thank you.
(Assignee)

Comment 1

18 years ago
cc tao, momoi, ftang.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Is that true that Estonian should be et but not ee ?
see http://www.ics.uci.edu/pub/ietf/http/related/iso639.txt

Comment 3

18 years ago
It should be easy
go to intl/locale/src/language.properties and change the false to true for these 
languages.

Comment 4

18 years ago
I keep on saying this but this is why we need a review of that
list before it goes RTM. My suggestion is to change "false"
to "true" for all the combinations we already support in terms
of charsets. Hopefully we can do this for RTM.
Since all the UI definitions are stored in another file,
changing this file should be possible without affecting
L10n later.
(Reporter)

Comment 5

18 years ago
Probably it is "et" for estonian language; I actually don't speak estonian.
Sorry for the confusion.
(Assignee)

Comment 6

18 years ago
Reassign to tao.
Assignee: nhotta → tao

Comment 7

18 years ago
It is too late for us to change it now. richard, if you really want to see it 
fix for NEtscape6, submit the patch to waterson for approval. It should be easy, 
simply change lt, lv and es from false to 
true in intl/locale/src/language.properties

Comment 8

18 years ago
Hi, Frank:


Mind owning this bug? I am swamped with PR langpack bundling.


Thx
Assignee: tao → ftang

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Keywords: intl

Comment 9

18 years ago
easy stuff. nhotta- can you help?
Assignee: ftang → nhotta
Status: ASSIGNED → NEW
(Assignee)

Comment 10

18 years ago

*** This bug has been marked as a duplicate of 62578 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.