Thunderbird 3 mail lost from folder view until .msf is reindexed

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
critical
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: Michael Baffoni, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 406740 [details]
Show message list where body view doesn't match.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091016 Shredder/3.0pre

I haven't been able to find a consistent testcase but, intermittently the message viewed in the preview pane (or full page tab) of the viewed message is not matching the selected message in the mail view list.  The body of the message is always an old message.  It might be the first message in the folder, but I can't find it in the list anywhere.  The message that is selected and views the old message appears to be random, and can occur on any message within the mail reader window, more than one message at a time can have this problem, but not all, and not consistently.  Sorting by date, the message that appears in the body is not viewable in the message list.  This problem is persistent across mail client restarts and updates.

Marking dataloss because you can't manage the "hidden message" and you can't view the contents of the selected message.

There is a workaround; if you reindex the folder, the association goes away, but it pops up again in a few days.  I don't recall seeing the hidden email after reindexing.  I'm leaving my folder in this state in case there are other things I can try to troubleshoot this before I change the state.
Severity: major → critical
Does this still happen?  This sounds like msf corruption.  Is this an IMAP account or a POP account?  If IMAP, did you use the IMAP deletion model?  If POP, do you compact a lot?
(Reporter)

Comment 2

8 years ago
IMAP account, deletion is move to trash.
(Reporter)

Comment 3

8 years ago
This doesn't happen all that often anymore, but I did have a user run into this problem (or something very similar) last week, and a reindex fixed it.  Now if only we could reindex without redownloading all of the email, it would help me with a user that has 12K+ emails using over 5.5GB.

Comment 4

8 years ago
this is likely a duplicate
Summary: Thunderbird 3 mail indexing becomes flawed, hides a message and views unexpectedly → Thunderbird 3 mail lost from folder view until .msf is reindexed
Whiteboard: dupme

Comment 5

6 years ago
Michael, are you still seeing this? And, do any of these ** match up to your issue?

** https://bugzilla.mozilla.org/buglist.cgi?list_id=1023397&short_desc=msf%20index&field0-0-0=longdesc&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&resolution=---&query_format=advanced&short_desc_type=anywordssubstr&longdesc=corrupt%20miss&type0-0-0=anywordssubstr&value0-0-0=msf&longdesc_type=anywordssubstr&product=MailNews%20Core&product=Thunderbird
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Whiteboard: dupme → dupeme
(Reporter)

Comment 6

6 years ago
I'm not seeing this anymore, none of those issues look relevent.  Marking MFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.