Closed Bug 522875 Opened 11 years ago Closed 11 years ago

[Migration Assistant] "Use original toolbar" over-populates toolbar

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: JoeS1, Assigned: bwinton)

References

Details

(Keywords: polish, Whiteboard: [223 Migration])

Attachments

(2 files)

Noticed while testing 223 migration.
TB2 profile and running current TB3 nightly.

STR:
Select the "use original toolbar" option.
On a display resolution of 1024x768 the vertical scrollbar disappears.
This lack of vertical scrollbar persists in the threadpane.

Backing one toolbar item out with customization restores the toolbar.
This is not very discoverable for the average user, so marking major sev.
This seems to happen only with "icons beside text" which is the default.
All other customization options work fine.
Managed to get DOMI running.
The computed syle of messengerWindow has a width of 1199px
Hence a good chunk of the screen is out of site in 1024x768 res.
Screenshot of the problem
It looks like changing the "icon above text" default to "icon beside text" is pushing everything to the right out of the window. Maybe retaining the selected icon/text mode when opting for the old toolbar would be advised to avoid that?
Flags: blocking-thunderbird3?
Keywords: polish
Whiteboard: [223 Migration]
Blake, your patch about the toolbar will fix this, right?
Attached image 1024 original toolbar
Yup, it seems to.
Assignee: nobody → bwinton
Status: NEW → ASSIGNED
Joe, could you check that tonight's nightly has fixed this problem, and mark it confirmed if it has?

(Or if you feel like getting latest from trunk and building it yourself to test, that would work too.  ;)

Thanks,
Blake.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.