Certain numbers of hyphens in HTML comments force the comments to be displayed

VERIFIED DUPLICATE of bug 102127

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 102127
8 years ago
8 years ago

People

(Reporter: Roman R., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4 (.NET CLR 3.5.30729)

If I have 2 hyphens together within HTML comments, the comments get displayed on the web page. However, if I have 1, 4, 8 (and I assume this goes on) hyphens together, the comments don't get displayed. Firefox seems to be only browser with this problem. This makes code comments cumbersome to write.

Reproducible: Always

Steps to Reproduce:
Here's a sample code:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>

<head>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
<title>Problem with comments in Firefox</title>
</head>

<body>
<!-- blahblahblah -- blah -->
<div>some test text</div>
</body>

</html>


Expected Results:  
Nothing within comment markers should be displayed.on a page.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102127

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.