Closed Bug 523086 Opened 10 years ago Closed 10 years ago

maxVersion of Chatzilla langpack should be updated

Categories

(Other Applications :: ChatZilla, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: rginda)

References

Details

Seamonkey 2 Branch has cut and please update maxVersion.

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla%2Fextensions%2Firc%2Flocales%2Fgeneric%2Finstall.rdf&rev=&cvsroot=%2Fcvsroot
     <!-- target: SeaMonkey, version 1.0 to 2.0 -->
     <em:targetApplication>
       <Description>
         <em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
         <em:minVersion>1.0</em:minVersion>
-        <em:maxVersion>2.0</em:maxVersion>
+        <em:maxVersion>2.0+</em:maxVersion>
       </Description>
     </em:targetApplication>
oops, not only Seamonkey but maxVersion for Firefox, Sunbird etc also should be updated.
Summary: maxVersion of Chatzilla langpack for Seamonkey now should be 2.0.* or 2.0+ → maxVersion of Chatzilla langpack now should be 2.0.* or 2.0+
I've pushed Firefox to 3.7.* and SeaMonkey to 2.1.* in both the main and the generic locale install.rdf files. Flock and Songbird are unchanged because I've not tested them.
Depends on: 504229
Thanks. I confirmed maxVersion of langpack (and chatzilla itself) for Firefox and Seamonkey is now correctly updated.
 -> RSOLVED FIXED

memo: diff of install.rdf files
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=install.rdf&branch=&root=/cvsroot&subdir=mozilla/extensions/irc/locales/generic&command=DIFF_FRAMESET&rev1=1.7&rev2=1.8
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=install.rdf&branch=&root=/cvsroot&subdir=mozilla/extensions/irc/xpi/resources&command=DIFF_FRAMESET&rev1=1.22&rev2=1.23

As for Flock and Songbird, I've also not tested them yet and don't know which version should be set. I'll close this bug since chatzilla now have correct maxVersions. As for Flock and Songbird, maxVersion should be updated when chatzilla on them are actually tested.

If someone already tested with newer Songbird/Flock, please reopen or file another bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Summary: maxVersion of Chatzilla langpack now should be 2.0.* or 2.0+ → maxVersion of Chatzilla langpack should be updated
Depends on: 540842
You need to log in before you can comment on or make changes to this bug.