Last Comment Bug 540842 - Langpack incompatible with SM version > 2.0
: Langpack incompatible with SM version > 2.0
Status: RESOLVED FIXED
: fixed-seamonkey2.0.4
Product: Other Applications
Classification: Client Software
Component: ChatZilla (show other bugs)
: 1.9.1 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Robert Ginda
:
Mentors:
Depends on:
Blocks: 523086
  Show dependency treegraph
 
Reported: 2010-01-20 08:13 PST by Giacomo Magnini
Modified: 2010-02-09 09:46 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Giacomo Magnini 2010-01-20 08:13:49 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); it; rv:1.9.1.8pre) Gecko/20100120 SeaMonkey/2.0.3pre
Build Identifier: SM 2.0.3pre (Italian) + CZ 0.9.85 (as shipped with SM 2.0.x)

The install.rdf file has maxVersion for SM set to 2.0 instead of 2.0.*, so the langpack for CZ (just recently added to SM in Italian) is marked as incompatible and deactivated.

Reproducible: Always
Comment 1 Giacomo Magnini 2010-01-20 08:14:31 PST
I've locally modified the install.rdf file and the LP now works fine.
Comment 2 :Gijs Kruitbosch (Gone July 28 - Aug 11) 2010-01-20 08:33:58 PST
Isn't this a problem with the italian l10n files, not with ChatZilla itself?
Comment 3 :Gijs Kruitbosch (Gone July 28 - Aug 11) 2010-01-20 08:37:41 PST
(In reply to comment #2)
> Isn't this a problem with the italian l10n files, not with ChatZilla itself?

Eh, scratch that - forgot the build system uses defines for the relevant per-locale contributor bits, and takes the install.rdf from our code. Fix in a bit.
Comment 4 :Gijs Kruitbosch (Gone July 28 - Aug 11) 2010-01-20 08:52:41 PST
(In reply to comment #3)
> (In reply to comment #2)
> > Isn't this a problem with the italian l10n files, not with ChatZilla itself?
> 
> Eh, scratch that - forgot the build system uses defines for the relevant
> per-locale contributor bits, and takes the install.rdf from our code. Fix in a
> bit.

Actually, scratch *that* - you're (hopefully?) using http://mxr.mozilla.org/comm-central/source/mozilla/extensions/irc/locales/generic/install.rdf (or the equivalent directly from the CZ repo, doesn't matter much), which has maxVersion 2.1.*. So there shouldn't be any problem at all. Whyever there *is* a problem, it's not us...
Comment 5 Robert Kaiser 2010-01-20 09:06:00 PST
Oh, looks like we have the problem: locales/generic/install.rdf on the MOZILLA_1_9_1_BRANCH of ChatZilla doesn't have the updates from http://hg.mozilla.org/chatzilla/rev/f3d332d30973 - we probably should just apply those on this named branch as well.
Comment 6 :Gijs Kruitbosch (Gone July 28 - Aug 11) 2010-02-07 04:12:06 PST
(In reply to comment #5)
> Oh, looks like we have the problem: locales/generic/install.rdf on the
> MOZILLA_1_9_1_BRANCH of ChatZilla doesn't have the updates from
> http://hg.mozilla.org/chatzilla/rev/f3d332d30973 - we probably should just
> apply those on this named branch as well.

No. You have a much bigger problem. Why do those branch tags even exist in the CZ repo? We certainly haven't added them. We never commit to them. You (SM) should just use tip. This also explains why non-en-US SM users complain about ChatZilla being updated and no longer being localized - the localizers are translating whatever's on 1.9.2 (probably some weird thing that calls itself 0.9.85 or .84 but has some extra fixes). I'm not sure how this story's *supposed* to work but I'm unconvinced that having us start pushing to an effectively unused branch is useful in any way.
Comment 7 Robert Kaiser 2010-02-08 08:53:47 PST
We needed to introduce that branch as we cannot accept *any* L10n changes on a stable release series like SeaMonkey 2.0.x or all localization would be completely broken whenever ChatZilla changes anything.
We enforce no L10n changes on our own code, we need to do that on any code we ship.
Comment 8 Masahiko Imanaka [:marsf] 2010-02-09 06:04:54 PST
I agree with Gijs.  However, when it is done, the tinderbox for SeaMonkey-l10n will be burn on current build systems.  Because, ChatZilla's locales for SeaMonkey are pulled from each locale's repository, not from ChatZilla's repository. 

Robert:
If you can, you should renew the tag to rev/f3d332d30973. This rev is just next to COMM_1_9_1_BASE tag and it will be safe.

http://hg.mozilla.org/chatzilla/graph/1272?revcount=50
Comment 9 Robert Kaiser 2010-02-09 08:02:09 PST
Can't update/move a branch to a different base revision, but I pushed http://hg.mozilla.org/chatzilla/rev/f5fd1b073bf8 to the COMM_1_9_1_BRANCH, which should fix this in 2.0.4pre nightlies and the future 2.0.4 release.

Note You need to log in before you can comment on or make changes to this bug.