Confusion with account settings in the UIs: "server settings" / "outgoing server"

RESOLVED DUPLICATE of bug 422814

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 422814
9 years ago
9 years ago

People

(Reporter: Joe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: version 2.0.0.23 (20090812)

Purpose: Request to change/clarify the layout of the "account settings" UI section of TB.

Reason: In setting up TB for the first time, I found the layout/location of the "account settings" UI section of TB confusing.

Details: Confusion setting up the incoming and outgoing mail servers on TB. 

Clicking on "View settings for this account" takes you to a UI where you see "account settings". You then click on "server settings" which appears in a UI titled  "server settings" and shows below this "POP server settings". This UI only accepts 1 set of server settings. This is confusing for 3 reasons:

1) It does not specify which server settings it for and/or that it is the incoming mail server setting. Alternately, it does not tell where to find the settings area for the outgoing mail sever settings. 

2) There are some servers that do not use "POP" in the incoming server mail address (example: "mail.example.com" versus "pop.gmail.com"). Having the wording as "Server type: POP mail server" can lead an inexperienced user to reverse the incoming and outgoing server details in an attempt to get email working, and/or cause them to email the mail host to try to obtain their "POP" address (pop.example.com) which the host does not use and cannot supply.

3) In the "Server settings" UI, the outgoing mail server settings location - Outgoing Server (SMTP) - is farther down in the UI below the "Local folders". This UI is titled "Outgoing Server (SMTP) Settings". As in the incoming server setting discussion above, the host's naming system may not include "smtp" as part of their outgoing sever address (example: "mail.example.com" versus "smtp.gmail.com"). As discussed above, this could lead an inexperienced user to reverse the incoming and outgoing server details in an attempt to get email working, and/or cause them to email the mail host to try to obtain their "smtp" address (smtp.example.com) which the host does not use and cannot supply.



Reproducible: Always

Steps to Reproduce:
1. Mail account > Inbox > Account Settings
2. View the box titled "Account settings <(name of account)>
3.
Actual Results:  
Please refer to "Details".

Expected Results:  
A single UI/box with fill-ins for all incoming and outgoing server settings, port settings, etc.

Suggested format of a revised UI/box for each, seperate, email account on TB:

=================================
Incoming mail server:
Server name:____________
User name:_____________
Port:__________   Default: 110

Use name and password ( )

Security settings:
(# no revsions - use the UI format currently being used)

Outgoing mail server:
Server name:____________
User name:_____________
Port:__________   Default: 465

Use name and password ( )

Security settings:
(# no revsions - use the UI format currently being used)

===========================================================

In other words, put all incoming and outgoing mail server details/settings/variables in a single UI/box and clearly label each server's details area as either the incoming or outgoing server. In addition, either discontinue the use of wording the UI/box "POP" and "SMTP" or clairify that the mail server address may not contain those terms.
This has changed a lot since 2.X. THe account setup is completely different in TB3. Have a look and file a new bugs on issues you might find with say Thunderbird 3.0b4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422814

Comment 2

9 years ago
Yes and no... the account settings are still the same, and this is what the initial description refers to. Keeping the SMTP settings separate from accounts has been justified in bug 411666, but they still have identical labels.
You need to log in before you can comment on or make changes to this bug.