default symbols path busted for mochitest/reftest

RESOLVED FIXED

Status

defect
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When I landed a fix for bug 519194, I fixed the packaged tests case and broke the in-tree case. I guess that was an ok tradeoff at the time because we're not running in-tree tests on tinderbox anymore (but still not good!)

The problem is that SYMBOLS_PATH as preprocessed into automation.py is a path relative to the script directory (where automation.py winds up), but we resolve it relative to the cwd (because we want to handle paths passed to --symbols-path, which would be relative to the cwd).

I think I might fix this by just removing SYMBOLS_PATH, and having the "mochitest/reftest" makefile targets pass --symbols-path in.
This makes SYMBOLS_PATH no longer a hardcoded symbol from the preprocessor, instead forcing everyone to pass --symbols-path in explicitly. It also makes all the mochitest-*, reftest etc targets pass that argument in. The only negative impact here is that people who want to run the python scripts directly and want crash stacks will have to explicitly pass the argument, but I don't think that's a big deal. We should be discouraging running the python scripts directly anyway, in favor of the makefile targets.
Attachment #407508 - Flags: review?(benjamin)
Attachment #407508 - Flags: review?(benjamin) → review+
This patch works great for me in bug 483111, for the in-tree case.
Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/cd03dd745df8
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 524125
You need to log in before you can comment on or make changes to this bug.