Closed Bug 523492 Opened 12 years ago Closed 2 months ago

Ogg video playback in Full screen is very choppy

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tchung, Unassigned)

References

()

Details

(Keywords: perf)

I'm aware that bug 510057 is tracking opengl acceleration work.   That said, this bug is to note that FS ogg playback is very choppy.  This is consistent across linux, windows 7/Vista/XP, and mac.

Repro:
1) install a trunk or 1.9.2 nightly.  eg. Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b2pre) Gecko/20091020 Namoroka/3.6b2pre
2) go to an ogg site (url)
3) play any ogg file.  notice it plays in a normal playback
4) right click > Full screen
5) Verify the video playback is choppy and slow

Expected:
- Smooth playback in FS

Actual:
- Choppy, slow, unwatchable in FS
I get choppy picture with Full Screen on every computer I have tried
Two of the computers I have tried:
1)AMD 64bit 1.6ghz
   1gb RAM
    256MB ATI video card
    Takes 100% of the CPU processing 
2) Centrino CORE 2 DUO 2.26ghz
     1gb RAM
     Takes 30-70% of CPU processing and still a choppy pictured

note: videos play normally and without any problems when they are in their original size  

I'm using FIREFOX 3.6 "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4"

This needs to be improved, Youtube plays HD videos on full screen and only takes 20-30% of the CPU with  the video playing smoothly.

It is always reproducible with the steps provided above
the fullscreen video is far from being smooth on a Phenom II X2 545 on windows 7 64-bit with amd 785g chipset. in contrast to that, flash videos in HD work smooth. This is something mozilla should get escalated before releasing firefox 3.6. Also, seeking does not really work for me (it is buffering the whole video before playing it) but that's another issue.

On linux it is not better but there firefox could be based onto gstreamer to enable smooth video playback.
I get choppy video as well as audio playback in fullscreen:

Windows Vista SP2 32-bit
Firefox 3.6 RC1
Intel Core II Duo 1.96 Ghz
Intel GM965 Graphics 
4 GB RAM

The audio choppiness is dependent on the quality. For example:

http://www.spreadfirefox.com/5years/en-US/

has a lot of audio distortion while

http://tinyvid.tv/show/bb7qiezbbnl8

does not.
> The audio choppiness is dependent on the quality. For example:

Actually, I can't confirm that it's dependent on the quality, rather I should have said that it's not consistent on every video.
(In reply to comment #3)
> I get choppy video as well as audio playback in fullscreen:
> 
> Windows Vista SP2 32-bit
> Firefox 3.6 RC1
> Intel Core II Duo 1.96 Ghz
> Intel GM965 Graphics 
> 4 GB RAM
> 
> The audio choppiness is dependent on the quality. For example:
> 
> http://www.spreadfirefox.com/5years/en-US/
> 
> has a lot of audio distortion while
> 
> http://tinyvid.tv/show/bb7qiezbbnl8
> 
> does not.

Those files play Ok on a win7 64 bit + Firefox 3.5.7, but many from wikipedia don't play well. they are very choppy, like this:

http://upload.wikimedia.org/wikipedia/en/8/88/De_Musica_Ligera_sampled_in_Self_Esteem.ogg
looks like a too small buffer.
Same bug, or related bug than 531279
I've tested with this page here:
http://layersapp.com/

The video is OK when in normal size. In Full Screen the audio stays OK but the video frame rate seems to drop to about 1 or 2 frames per second. A lot of frames are dropped.

Firefox plays the video with 46% CPU in normal size, in Full screen 95% most of the time, 120% in the trasitions where framedrops ocour.

Firefox 3.6 Final, OS X 10.6.2, Core 2 Duo 2.4Ghz, 4Gb Ram, GeForce 8600M GT 256 VRAM, 1920x1200 screen.
I only get fullscreen choppiness on Windows 7. In Kubuntu 9.10, it plays back very smoothly in fullscreen.

I have a Core 2 Duo 2.53 Ghz btw.
No longer blocks: 510057
Depends on: 510057
Depends on: 555839, 556063, 556065
Keywords: perf
I also get choppiness using full screen video when watching this video:
http://blog.mozilla.com/faaborg/2010/06/24/why-tabs-are-on-top-in-firefox-4/

I'm running Firefox 3.6.4 on a machine with a Core 2 Quad @ 3.06GHz on Windows 7 Ultimate 64-bit. Audio was normal and did not skip.
It also happens in normal screen by activating compositing on linux.
I Filled https://bugzilla.mozilla.org/show_bug.cgi?id=597141
It seems that this https://bugzilla.mozilla.org/show_bug.cgi?id=602659 fixed the bug.
I can confirm that this bug no longer occurs.
Tony: can you verify that this is fixed as well, since you filed the bug originally?
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.