Closed Bug 555839 Opened 11 years ago Closed 11 years ago

Turn on OpenGL LayerManager for fullscreen video widget

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bas.schouten, Assigned: bas.schouten)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

Widgets need to get a new creation flag or something like that that will turn on the LayerManagerOGL once it lands (bug 546517).

When we have this creation flag we will need to make sure the fullscreen video widget takes advantage of the OpenGL layer manager so we get hardware accelerated scaling and YUV->RGB conversion where available.
Bug 453063 implemented the full screen video, but it's literally just a full-screen window with a big <video> element. So, I think the first step here is figuring out how to make the video backend know when to do this, and how this interacts with plans for an API to allow making any DOM element be displayed fullscreen. Seems like this platform piece will need to be done before the frontend can make use of it.
Assignee: dolske → nobody
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Version: unspecified → Trunk
Status: ASSIGNED → NEW
Depends on: 556027
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Attachment #436102 - Flags: review?(dolske)
Component: Video/Audio → General
OS: Windows 7 → All
Product: Core → Firefox
QA Contact: video.audio → general
Hardware: x86 → All
Comment on attachment 436102 [details] [diff] [review]
Turn on acceleration for fullscreen video

Ha, nice. :)
Attachment #436102 - Flags: review?(dolske) → review+
Comment on attachment 436102 [details] [diff] [review]
Turn on acceleration for fullscreen video

I know this makes me a big lame-head, but I could live without the joke :)
Attachment #436102 - Flags: review+
Done like dinner!
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Does this patch actually work? This isn't a XUL document.
Blocks: 523492
(In reply to comment #7)
> Does this patch actually work? This isn't a XUL document.

It does, Roc told me to try this, and it worked :) I don't know enough about XUL or any of that to tell you why.
CPU usage for fullscreen video doesn't seem to have gone down with today's nightly, tested with a Radeon X1200 and a GMA 945 on wikimedia commons.
Depends on: 556288
I'm not seeing any improvement in the CPU usage or the quality of playback of large videos in fullscreen mode. See http://videos.mozilla.org/serv/marketing/sfx_edutoolkit/asa_historymozilla.ogv for an awesome testcase ;-)
(In reply to comment #10)
> I'm not seeing any improvement in the CPU usage or the quality of playback of
> large videos in fullscreen mode. See
> http://videos.mozilla.org/serv/marketing/sfx_edutoolkit/asa_historymozilla.ogv
> for an awesome testcase ;-)

True! We are working on investigating.
Depends on: 556356
Depends on: 556540
Duplicate of this bug: 510057
OpenGL LayerManager for fullscreen video widget seems disabled on Linux for about two months, I have to set layers.accelerate-all true to see it. Perhaps it has been turned off for https://bugzilla.mozilla.org/show_bug.cgi?id=523492? Because it seems fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=602659.

Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101030 Firefox/4.0b8pre
You need to log in before you can comment on or make changes to this bug.