Last Comment Bug 523663 - Firefox crashes [@imgRequest::NotifyProxyListener(imgRequestProxy*) ]
: Firefox crashes [@imgRequest::NotifyProxyListener(imgRequestProxy*) ]
Status: RESOLVED FIXED
: coverity, crash
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: 1.9.1 Branch
: x86 Windows Vista
: -- critical (vote)
: mozilla6
Assigned To: timeless
:
: Milan Sreckovic [:milan]
Mentors:
: 575634 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-21 11:12 PDT by Madison
Modified: 2011-06-09 14:58 PDT (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
handle CreateNewProxyForRequest consistently (1.81 KB, patch)
2010-04-13 00:32 PDT, timeless
joe: review+
Details | Diff | Splinter Review
current patch from http://hg.mozilla.org/users/timeless_mozdev.org/mozilla-central-mq/file/1209c033bfba/523663-imgLoader-CreateNewProxyForRequest (2.25 KB, patch)
2011-04-26 22:56 PDT, timeless
timeless: review+
Details | Diff | Splinter Review

Description Madison 2009-10-21 11:12:42 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

I have been having problems that last couple of weeks with the browser crashing. It has sent many reports after but it seems to happen a couple times a day. Today after it crashed, it took me about 30 minutes before it ever came back up, even after rebooting. 

Reproducible: Sometimes

Steps to Reproduce:
1.It just crashes, the window shuts down with no warning. 
2.
3.


Expected Results:  
I would like for it to stop crashing daily. Please?
Comment 1 Ria Klaassen (not reading all bugmail) 2009-10-21 11:48:46 PDT
Please post a crash ID, see: https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Comment 2 Madison 2009-10-21 15:16:18 PDT
(In reply to comment #1)
> Please post a crash ID, see:
> https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

I have been doing this for weeks now. I have not heard anything back. I have even been including my email address with the report. Thanks
Comment 3 Matthias Versen [:Matti] 2009-10-21 16:01:45 PDT
please read the link again, post a crash id
Comment 4 Madison 2009-10-21 22:00:05 PDT
(In reply to comment #3)
> please read the link again, post a crash id

I don't have a crash id. It automatically sends the report.
Comment 5 Tyler Downer [:Tyler] 2009-10-21 22:14:01 PDT
If you read that link, it says to go to about:crashes, and copy the id.
Comment 6 Madison 2009-10-21 22:23:53 PDT
(In reply to comment #5)
> If you read that link, it says to go to about:crashes, and copy the id.


Submitted Crash Reports


  

    
      
        Report ID
        	Date Submitted
      

    
    
    17a4676b-f5f3-4c9a-bde9-b1b152091021	10/21/2009	12:41 PM
74d8e955-94fa-48e5-a1eb-00ddc2091016	10/16/2009	4:54 AM
40f04989-ad9b-4003-9544-392452091015	10/15/2009	9:52 PM
3f753b2d-2a2a-4b6c-bb25-bd33e2091015	10/15/2009	9:47 PM
009b293f-1c42-48fd-b6e3-effa52091015	10/15/2009	9:24 PM
3458d5a0-dd88-4649-bc8a-bac962091015	10/15/2009	9:12 PM
3d953f64-3d83-49c3-b20a-ff8d32091011	10/11/2009	9:28 PM
09598ab2-f5c0-4d9f-ad3e-3b3682091010	10/10/2009	9:18 PM
5483ddbc-b753-4af3-b2a5-1b6172091010	10/10/2009	6:52 PM
4f1f32da-1173-4226-83d5-fa9da2091001	10/1/2009	6:21 AM
Comment 7 Matthias Versen [:Matti] 2009-10-22 01:49:37 PDT
0  	 	@0x20  	
1 	xul.dll 	imgRequest::NotifyProxyListener 	modules/libpr0n/src/imgRequest.cpp:256
2 	mozcrt19.dll 	arena_dalloc_small 	obj-firefox/memory/jemalloc/src/jemalloc.c:4504
3 	nspr4.dll 	_PR_MD_UNLOCK 	nsprpub/pr/src/md/windows/w95cv.c:344
4 	xul.dll 	nsHttpChannel::HandleAsyncNotModified 	netwerk/protocol/http/src/nsHttpChannel.cpp:493
5 	xul.dll 	nsRunnableMethod<nsHTMLLinkElement>::Run 	obj-firefox/dist/include/xpcom/nsThreadUtils.h:264
6 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
7 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:227
8 	xul.dll 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:465
9 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
10 	xul.dll 	nsProxyObjectCallInfo::Run 	xpcom/proxy/src/nsProxyEvent.cpp:181
11 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
12 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:227
13 	xul.dll 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:465
14 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
15 	xul.dll 	nsProxyObjectCallInfo::Run 	xpcom/proxy/src/nsProxyEvent.cpp:181
16 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
17 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:227
18 	xul.dll 	nsThread::Shutdown 	xpcom/threads/nsThread.cpp:465
19 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101

Do you get this crashes if you run Firefox in the Firefox safemode (as requested by https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report  ?

To which software belongs Engine.dll and IGeared_tavgp_xputils35.dll on your system ?
Comment 8 Joe Drew (not getting mail) 2009-10-22 09:14:00 PDT
These crashes' backtraces are all over the place, and I don't trust them at all. I'd highly, highly suspect antivirus or other plugins that haven't been updated for 3.5 yet.
Comment 9 Madison 2009-10-22 16:57:05 PDT
(In reply to comment #7)
> 0           @0x20      
> 1     xul.dll     imgRequest::NotifyProxyListener    
> modules/libpr0n/src/imgRequest.cpp:256
> 2     mozcrt19.dll     arena_dalloc_small    
> obj-firefox/memory/jemalloc/src/jemalloc.c:4504
> 3     nspr4.dll     _PR_MD_UNLOCK     nsprpub/pr/src/md/windows/w95cv.c:344
> 4     xul.dll     nsHttpChannel::HandleAsyncNotModified    
> netwerk/protocol/http/src/nsHttpChannel.cpp:493
> 5     xul.dll     nsRunnableMethod<nsHTMLLinkElement>::Run    
> obj-firefox/dist/include/xpcom/nsThreadUtils.h:264
> 6     xul.dll     nsThread::ProcessNextEvent     xpcom/threads/nsThread.cpp:510
> 7     xul.dll     NS_ProcessNextEvent_P    
> obj-firefox/xpcom/build/nsThreadUtils.cpp:227
> 8     xul.dll     nsThread::Shutdown     xpcom/threads/nsThread.cpp:465
> 9     xul.dll     NS_InvokeByIndex_P    
> xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
> 10     xul.dll     nsProxyObjectCallInfo::Run    
> xpcom/proxy/src/nsProxyEvent.cpp:181
> 11     xul.dll     nsThread::ProcessNextEvent    
> xpcom/threads/nsThread.cpp:510
> 12     xul.dll     NS_ProcessNextEvent_P    
> obj-firefox/xpcom/build/nsThreadUtils.cpp:227
> 13     xul.dll     nsThread::Shutdown     xpcom/threads/nsThread.cpp:465
> 14     xul.dll     NS_InvokeByIndex_P    
> xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
> 15     xul.dll     nsProxyObjectCallInfo::Run    
> xpcom/proxy/src/nsProxyEvent.cpp:181
> 16     xul.dll     nsThread::ProcessNextEvent    
> xpcom/threads/nsThread.cpp:510
> 17     xul.dll     NS_ProcessNextEvent_P    
> obj-firefox/xpcom/build/nsThreadUtils.cpp:227
> 18     xul.dll     nsThread::Shutdown     xpcom/threads/nsThread.cpp:465
> 19     xul.dll     NS_InvokeByIndex_P    
> xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
> 
> Do you get this crashes if you run Firefox in the Firefox safemode (as
> requested by
> https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report  ?
> 
> To which software belongs Engine.dll and IGeared_tavgp_xputils35.dll on your
> system ?

I have no clue what they are. How can I find out? Thanks for your help.
Comment 10 Madison 2009-10-22 16:58:09 PDT
(In reply to comment #8)
> These crashes' backtraces are all over the place, and I don't trust them at
> all. I'd highly, highly suspect antivirus or other plugins that haven't been
> updated for 3.5 yet.

I have had updates on firefox since it was changed to 3.5 or I have them removed if they can't be updated. My antivirus is new. I just bought it at the end of September. Thanks
Comment 11 Tyler Downer [:Tyler] 2009-10-22 17:37:54 PDT
just because you have anti-virus does not mean you don't have a virus. Believe me, I work as a repair technician in my day job, and we get some many people with fully functioning anti-virus, and a ton of viruses. Run some stuff like malwarebytes anti-malware, super antispyware, and other stuff like that.
Comment 12 Madison 2009-10-22 18:38:39 PDT
(In reply to comment #11)
> just because you have anti-virus does not mean you don't have a virus. Believe
> me, I work as a repair technician in my day job, and we get some many people
> with fully functioning anti-virus, and a ton of viruses. Run some stuff like
> malwarebytes anti-malware, super antispyware, and other stuff like that.

I have malwarebytes and run it daily. I also run the full version of AVG daily. I clean my cookies out also which AVG detects every time it runs. I have no idea what else to do. It is running better since I got rid of the add ons though. Sorry if I am being a pain. I love firefox, totally hate IE. I do get viruses when I use that browser so I don't want to go back to that. Thanks for the help..
Comment 13 Madison 2009-10-23 01:01:09 PDT
(In reply to comment #12)
> (In reply to comment #11)
> > just because you have anti-virus does not mean you don't have a virus. Believe
> > me, I work as a repair technician in my day job, and we get some many people
> > with fully functioning anti-virus, and a ton of viruses. Run some stuff like
> > malwarebytes anti-malware, super antispyware, and other stuff like that.
> 
> I have malwarebytes and run it daily. I also run the full version of AVG daily.
> I clean my cookies out also which AVG detects every time it runs. I have no
> idea what else to do. It is running better since I got rid of the add ons
> though. Sorry if I am being a pain. I love firefox, totally hate IE. I do get
> viruses when I use that browser so I don't want to go back to that. Thanks for
> the help..


It just crashed on me again. I went to about:crashes to get the id and it is not showing there. It is showing the last one to be 102109. I was not doing anything when it happened. I had set my laptop down and came back to the crash window showing saying it crashed. Thanks
Comment 14 Madison 2009-10-23 01:55:05 PDT
(In reply to comment #13)
> (In reply to comment #12)
> > (In reply to comment #11)
> > > just because you have anti-virus does not mean you don't have a virus. Believe
> > > me, I work as a repair technician in my day job, and we get some many people
> > > with fully functioning anti-virus, and a ton of viruses. Run some stuff like
> > > malwarebytes anti-malware, super antispyware, and other stuff like that.
> > 
> > I have malwarebytes and run it daily. I also run the full version of AVG daily.
> > I clean my cookies out also which AVG detects every time it runs. I have no
> > idea what else to do. It is running better since I got rid of the add ons
> > though. Sorry if I am being a pain. I love firefox, totally hate IE. I do get
> > viruses when I use that browser so I don't want to go back to that. Thanks for
> > the help..
> 
> 
> It just crashed on me again. I went to about:crashes to get the id and it is
> not showing there. It is showing the last one to be 102109. I was not doing
> anything when it happened. I had set my laptop down and came back to the crash
> window showing saying it crashed. Thanks



This is the malwarebytes report I just ran:

Malwarebytes' Anti-Malware 1.41
Database version: 2868
Windows 6.0.6002 Service Pack 2

10/23/2009 3:52:12 AM
mbam-log-2009-10-23 (03-52-12).txt

Scan type: Quick Scan
Objects scanned: 87722
Time elapsed: 10 minute(s), 48 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 0
Folders Infected: 0
Files Infected: 0

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
(No malicious items detected)

Folders Infected:
(No malicious items detected)

Files Infected:
(No malicious items detected)
Comment 15 Matthias Versen [:Matti] 2009-10-23 03:08:55 PDT
Please just as first step Firefox in the Firefox safemode and test if you still crash. how do you do that ? Just follow the safemode link in the URL that is posted in comment #1
Comment 16 Madison 2009-10-23 03:14:16 PDT
Run in safe mode all the time? I did run it in safe mode for a while. I guess I am not understanding what you want me to do. Thanks
Comment 17 Matthias Versen [:Matti] 2009-10-23 14:21:27 PDT
Run Firefox in the safemode long enough to be sure that it either helps or until you get the crash.
Comment 18 Madison 2009-10-23 21:09:49 PDT
(In reply to comment #17)
> Run Firefox in the safemode long enough to be sure that it either helps or
> until you get the crash.

Hello, It has not crashed on me but it has froze up. Is that the same thing? It will just sit there for a few minutes not doing anything. The mouse has a double arrow. I love this browser and really wish I could figure out what is going on with it. I have gotten rid of all the themes and am just using the default one. Thanks for all the help, I appreciate it.
Comment 19 Madison 2009-10-23 22:04:22 PDT
(In reply to comment #18)
> (In reply to comment #17)
> > Run Firefox in the safemode long enough to be sure that it either helps or
> > until you get the crash.
> 
> Hello, It has not crashed on me but it has froze up. Is that the same thing? It
> will just sit there for a few minutes not doing anything. The mouse has a
> double arrow. I love this browser and really wish I could figure out what is
> going on with it. I have gotten rid of all the themes and am just using the
> default one. Thanks for all the help, I appreciate it.


Well, it just crashed on me using it in safemode. Here is the report: 

8cdf476b-fc4f-4f57-b2a9-509892091023	10/23/2009	11:59 PM  Thanks
Comment 20 Matthias Versen [:Matti] 2009-10-24 07:06:35 PDT
0  	xul.dll  	nsScriptLoader::StartLoad  	 content/base/src/nsScriptLoader.cpp:264
1 	xul.dll 	nsScriptLoader::PreloadURI 	content/base/src/nsScriptLoader.cpp:1066
2 	xul.dll 	nsPreloadURIs::PreloadURIs 	parser/htmlparser/src/nsParser.cpp:383
3 	xul.dll 	nsPreloadURIs::Run 	parser/htmlparser/src/nsParser.cpp:336
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
5 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
6 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:193
7 	nspr4.dll 	PR_GetEnv 	
8 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
9 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/src/crtexe.c:591
10 	kernel32.dll 	BaseThreadInitThunk 	
11 	ntdll.dll 	__RtlUserThreadStart 	
12 	ntdll.dll 	_RtlUserThreadStart 	

That is bug 519886.
You are crashing everywhere and the developers in bug 519886 don't know how this crash is happening. Only the skype extension is known to cause such a crash.
Are you sure that you entered the safemode ?
Do you got the safemode startup dialog ?
Comment 21 Madison 2009-10-24 10:04:04 PDT
(In reply to comment #20)
> 0      xul.dll      nsScriptLoader::StartLoad      
> content/base/src/nsScriptLoader.cpp:264
> 1     xul.dll     nsScriptLoader::PreloadURI    
> content/base/src/nsScriptLoader.cpp:1066
> 2     xul.dll     nsPreloadURIs::PreloadURIs    
> parser/htmlparser/src/nsParser.cpp:383
> 3     xul.dll     nsPreloadURIs::Run     parser/htmlparser/src/nsParser.cpp:336
> 4     xul.dll     nsThread::ProcessNextEvent     xpcom/threads/nsThread.cpp:510
> 5     xul.dll     nsBaseAppShell::Run    
> widget/src/xpwidgets/nsBaseAppShell.cpp:170
> 6     xul.dll     nsAppStartup::Run    
> toolkit/components/startup/src/nsAppStartup.cpp:193
> 7     nspr4.dll     PR_GetEnv     
> 8     firefox.exe     wmain     toolkit/xre/nsWindowsWMain.cpp:110
> 9     firefox.exe     __tmainCRTStartup    
> obj-firefox/memory/jemalloc/src/crtexe.c:591
> 10     kernel32.dll     BaseThreadInitThunk     
> 11     ntdll.dll     __RtlUserThreadStart     
> 12     ntdll.dll     _RtlUserThreadStart     
> 
> That is bug 519886.
> You are crashing everywhere and the developers in bug 519886 don't know how
> this crash is happening. Only the skype extension is known to cause such a
> crash.
> Are you sure that you entered the safemode ?
> Do you got the safemode startup dialog ?


Yes, I am in safemode, still in safemode. When I go to start up Firefox, I go to start, open the Mozilla Firefox folder and click on Mozilla Firefox (safemode). Are you referring to skype, the program to talk on? I don't even have that on my computer if so. This is what I click on when I go into safemode. It is the properities: "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode. Thank you for your time. Please fix me as I love your browser. I had never had this problem till a few weeks ago.
Comment 22 Madison 2009-10-26 20:17:33 PDT
(In reply to comment #21)
> (In reply to comment #20)
> > 0      xul.dll      nsScriptLoader::StartLoad      
> > content/base/src/nsScriptLoader.cpp:264
> > 1     xul.dll     nsScriptLoader::PreloadURI    
> > content/base/src/nsScriptLoader.cpp:1066
> > 2     xul.dll     nsPreloadURIs::PreloadURIs    
> > parser/htmlparser/src/nsParser.cpp:383
> > 3     xul.dll     nsPreloadURIs::Run     parser/htmlparser/src/nsParser.cpp:336
> > 4     xul.dll     nsThread::ProcessNextEvent     xpcom/threads/nsThread.cpp:510
> > 5     xul.dll     nsBaseAppShell::Run    
> > widget/src/xpwidgets/nsBaseAppShell.cpp:170
> > 6     xul.dll     nsAppStartup::Run    
> > toolkit/components/startup/src/nsAppStartup.cpp:193
> > 7     nspr4.dll     PR_GetEnv     
> > 8     firefox.exe     wmain     toolkit/xre/nsWindowsWMain.cpp:110
> > 9     firefox.exe     __tmainCRTStartup    
> > obj-firefox/memory/jemalloc/src/crtexe.c:591
> > 10     kernel32.dll     BaseThreadInitThunk     
> > 11     ntdll.dll     __RtlUserThreadStart     
> > 12     ntdll.dll     _RtlUserThreadStart     
> > 
> > That is bug 519886.
> > You are crashing everywhere and the developers in bug 519886 don't know how
> > this crash is happening. Only the skype extension is known to cause such a
> > crash.
> > Are you sure that you entered the safemode ?
> > Do you got the safemode startup dialog ?
> 
> 
> Yes, I am in safemode, still in safemode. When I go to start up Firefox, I go
> to start, open the Mozilla Firefox folder and click on Mozilla Firefox
> (safemode). Are you referring to skype, the program to talk on? I don't even
> have that on my computer if so. This is what I click on when I go into
> safemode. It is the properities: "C:\Program Files\Mozilla Firefox\firefox.exe"
> -safe-mode. Thank you for your time. Please fix me as I love your browser. I
> had never had this problem till a few weeks ago.


It crashed again. Here is the report ID. 
15361125-0844-4fdb-a91b-6835d2091026	10/26/2009	10:14 PM

Thanks for all your help.
Comment 23 Madison 2009-10-26 22:08:43 PDT
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > 0      xul.dll      nsScriptLoader::StartLoad      
> > > content/base/src/nsScriptLoader.cpp:264
> > > 1     xul.dll     nsScriptLoader::PreloadURI    
> > > content/base/src/nsScriptLoader.cpp:1066
> > > 2     xul.dll     nsPreloadURIs::PreloadURIs    
> > > parser/htmlparser/src/nsParser.cpp:383
> > > 3     xul.dll     nsPreloadURIs::Run     parser/htmlparser/src/nsParser.cpp:336
> > > 4     xul.dll     nsThread::ProcessNextEvent     xpcom/threads/nsThread.cpp:510
> > > 5     xul.dll     nsBaseAppShell::Run    
> > > widget/src/xpwidgets/nsBaseAppShell.cpp:170
> > > 6     xul.dll     nsAppStartup::Run    
> > > toolkit/components/startup/src/nsAppStartup.cpp:193
> > > 7     nspr4.dll     PR_GetEnv     
> > > 8     firefox.exe     wmain     toolkit/xre/nsWindowsWMain.cpp:110
> > > 9     firefox.exe     __tmainCRTStartup    
> > > obj-firefox/memory/jemalloc/src/crtexe.c:591
> > > 10     kernel32.dll     BaseThreadInitThunk     
> > > 11     ntdll.dll     __RtlUserThreadStart     
> > > 12     ntdll.dll     _RtlUserThreadStart     
> > > 
> > > That is bug 519886.
> > > You are crashing everywhere and the developers in bug 519886 don't know how
> > > this crash is happening. Only the skype extension is known to cause such a
> > > crash.
> > > Are you sure that you entered the safemode ?
> > > Do you got the safemode startup dialog ?
> > 
> > 
> > Yes, I am in safemode, still in safemode. When I go to start up Firefox, I go
> > to start, open the Mozilla Firefox folder and click on Mozilla Firefox
> > (safemode). Are you referring to skype, the program to talk on? I don't even
> > have that on my computer if so. This is what I click on when I go into
> > safemode. It is the properities: "C:\Program Files\Mozilla Firefox\firefox.exe"
> > -safe-mode. Thank you for your time. Please fix me as I love your browser. I
> > had never had this problem till a few weeks ago.
> 
> 
> It crashed again. Here is the report ID. 
> 15361125-0844-4fdb-a91b-6835d2091026    10/26/2009    10:14 PM
> 
> Thanks for all your help.

Crashed again.  

fc26a05e-7e06-42e4-b8fc-b376a2091026	10/26/2009	11:41 PM

Thanks
Comment 24 Joe Drew (not getting mail) 2009-10-27 09:00:07 PDT
Both of those crashes are not part of this bug; checking them (just click the link) before reporting them would help. :)
Comment 25 Madison 2009-10-27 10:28:06 PDT
(In reply to comment #24)
> Both of those crashes are not part of this bug; checking them (just click the
> link) before reporting them would help. :)

How am I supposed to know what crash belongs to what? I don't know your system! I am just reporting them. This is getting very frustrating and I don't appreciate your comment. I am about ready to just get rid of Firefox and let my friends know about all the trouble I am having with it. I have no idea how to tell what is what with your system!
Comment 26 Joe Drew (not getting mail) 2009-10-27 11:23:31 PDT
Madison, when you click on the about:crashes crash report, the page that (eventually) comes up will list where the crash happened. If it doesn't match the focus of this bug - a crash at imgRequest::NotifyProxyListener(imgRequestProxy*) - it is a separate issue, and should be filed as  such.

But if you're seeing this many crashes, something is obviously very wrong with Firefox on your computer. This isn't normal. I suggest going to http://support.mozilla.org and talking to some of the live chat volunteers, who will help you fix your problems.
Comment 27 Madison 2009-10-27 11:33:41 PDT
(In reply to comment #26)
> Madison, when you click on the about:crashes crash report, the page that
> (eventually) comes up will list where the crash happened. If it doesn't match
> the focus of this bug - a crash at
> imgRequest::NotifyProxyListener(imgRequestProxy*) - it is a separate issue, and
> should be filed as  such.
> 
> But if you're seeing this many crashes, something is obviously very wrong with
> Firefox on your computer. This isn't normal. I suggest going to
> http://support.mozilla.org and talking to some of the live chat volunteers, who
> will help you fix your problems.

On this report, where does it show where the crash happened? I don't see it.

Signature	imgRequest::NotifyProxyListener(imgRequestProxy*)
UUID	3f753b2d-2a2a-4b6c-bb25-bd33e2091015
Time 	2009-10-15 19:47:26.910102
Uptime	1372
Last Crash	1376 seconds before submission
Product	Firefox
Version	3.5.3
Build ID	20090824101458
Branch	1.9.1
OS	Windows NT
OS Version	6.0.6002 Service Pack 2
CPU	x86
CPU Info	AuthenticAMD family 17 model 3 stepping 1
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x20
User Comments	
Processor Notes 	
Related Bugs
Comment 28 Joe Drew (not getting mail) 2009-10-27 11:37:27 PDT
The "Signature" part is what you're looking for.
Comment 29 timeless 2010-04-12 03:40:59 PDT
1323 /* imgIRequest loadImageWithChannel(in nsIChannel channel, in imgIDecoderObserver 
1430   rv = CreateNewProxyForRequest(request, loadGroup, aObserver,
1431                                 requestFlags, nsnull, _retval);
1432   request->NotifyProxyListener(static_cast<imgRequestProxy*>(*_retval));

there's a failure check missing before 1432.

a friend is currently playing with stress, so he hit a similar crash in this function, but i think his is different.
Comment 30 timeless 2010-04-13 00:32:06 PDT
Created attachment 438689 [details] [diff] [review]
handle CreateNewProxyForRequest consistently
Comment 31 timeless 2010-06-30 16:44:27 PDT
*** Bug 575634 has been marked as a duplicate of this bug. ***
Comment 32 Joe Drew (not getting mail) 2011-04-19 09:27:16 PDT
Comment on attachment 438689 [details] [diff] [review]
handle CreateNewProxyForRequest consistently

Christian doesn't review imagelib very much, I think :) This is almost certainly bitrotten, but I'll take a look at it at some point.
Comment 33 Joe Drew (not getting mail) 2011-04-26 15:36:08 PDT
Comment on attachment 438689 [details] [diff] [review]
handle CreateNewProxyForRequest consistently

Yeah, this is really bitrotten, but I approve of it 100% in principle. If someone wants to update this patch for check-in, please do!
Comment 35 Dão Gottwald [:dao] 2011-04-27 01:00:14 PDT
http://hg.mozilla.org/mozilla-central/rev/34e2ee09cbc8

Note You need to log in before you can comment on or make changes to this bug.