Last Comment Bug 524149 - make -jN frequently hangs in MozillaBuild 1.4
: make -jN frequently hangs in MozillaBuild 1.4
Status: RESOLVED WONTFIX
:
Product: mozilla.org
Classification: Other
Component: MozillaBuild (show other bugs)
: other
: x86 Windows XP
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-23 10:27 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-09-10 12:20 PDT (History)
25 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ted Mielczarek [:ted.mielczarek] 2009-10-23 10:27:31 PDT
I've seen personally (and heard numerous reports) that parallel make hangs in MozillaBuild 1.4. We did take a MSYS update to fix Windows x64 compat, so it's possible that's the root cause.

I've built with 1.3 -j4 on my Windows XP, Core 2 Duo system numerous times without problems, so I know it's possible in some setups.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2009-10-23 10:28:37 PDT
http://hg.mozilla.org/mozilla-build/pushloghtml?fromchange=MOZILLABUILD_1_3_RELEASE&tochange=MOZILLABUILD_1_4_RELEASE

is the set of changes from 1.3 to 1.4.
Comment 2 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-10-23 10:39:15 PDT
If we use -j>1, the build seems to progress fine, and then at some (random?) time during the build will hang in the make process. We're hitting this with *every* attempt on a loaner BL460 + 2x72GB 15k HDD. As far as we can tell, there's no error messages in build logs.

If we use -j1, then the same build works fine.

Note: this is with MozillaBuild1.4, *and* also with MozillaBuild1.3.
Comment 3 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-10-23 10:42:03 PDT
fyi: we use MozillaBuild1.4 with -j4 on our single-core VMs without any problems. This physical machine is a mulit-core machine.
Comment 4 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2010-01-07 01:08:54 PST
ted: any progress on this? jhford is hitting this consistently on a new 1u physical box we are trying out. Note: we are running Win2k3, while you are running WinXP.

jhford: can you try with "-j1" to see if those builds at least complete?
Comment 5 Ted Mielczarek [:ted.mielczarek] 2010-01-07 03:29:32 PST
I haven't done any testing to try to make this work. If we're going to need parallel builds for the new boxes I'll just finish the few remaining PyMake bugs. I don't think trying to debug msys/gnu make is a good use of anyone's time.
Comment 6 John Ford [:jhford] 2010-01-07 14:14:27 PST
if -j1 is the same as no -j flag, then yes the machines are building fine.  When I tried -j4 i was getting a bunch of hung make processes
Comment 7 Wan-Teh Chang 2010-02-06 12:10:42 PST
The Simple Firefox build instructions at
https://developer.mozilla.org/En/Simple_Firefox_build#Building_Firefox
tell people to create a mozconfig file that passes -j4 to make.
Until this bug is fixed, the build instructions should note that
-j4 should not be used on Windows.
Comment 8 Jeff Walden [:Waldo] (remove +bmo to email) 2010-02-08 14:45:50 PST
I updated the instructions.

Wan-Teh, you could have done that too, you know, the page isn't locked down or anything.  :-)  (I assume you already have an MDC login, would be surprised if you'd never needed one for modifying NSPR docs or something.)
Comment 10 Justin Wood (:Callek) 2010-05-14 21:45:33 PDT
(In reply to comment #5)
> I haven't done any testing to try to make this work. If we're going to need
> parallel builds for the new boxes I'll just finish the few remaining PyMake
> bugs. I don't think trying to debug msys/gnu make is a good use of anyone's
> time.

Ted, is it fair to say this is WONTFIX as far as our end of it goes; but if it is fixed upstream in some way, we'd be happy to take the upgrade (if it doesn't break anything more important).
Comment 11 Jim Mathies [:jimm] 2010-05-15 07:51:43 PDT
FWIW, Win7, 4 core dell, w/-j4, no major issues. Once in a blue moon make will hang randomly during a build, but I've been experiencing that for ages.
Comment 12 :Ehsan Akhgari (away Aug 1-5) 2010-05-16 20:54:32 PDT
FWIW, I got this nearly constantly on David Bolter's Win7 machine.  CCing him to see if he can provide more info.
Comment 13 Ted Mielczarek [:ted.mielczarek] 2010-05-17 05:36:47 PDT
(In reply to comment #10)
> Ted, is it fair to say this is WONTFIX as far as our end of it goes; but if it
> is fixed upstream in some way, we'd be happy to take the upgrade (if it doesn't
> break anything more important).

I have no intention of spending any time debugging msys or GNU make.
Comment 14 David Bolter [:davidb] 2010-05-17 05:56:44 PDT
(In reply to comment #12)
> FWIW, I got this nearly constantly on David Bolter's Win7 machine.  CCing him
> to see if he can provide more info.

Parallel builds worked fine on this machine in the past.
Comment 15 Edward Lam 2010-08-24 11:33:13 PDT
FWIW, I'd try using gmake 3.82 now that it is out.
Comment 16 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-09-09 20:00:54 PDT
I think this is WONTFIX in favor of moving to pymake by default on Windows (Bug 593585)
Comment 17 versuemer 2012-06-20 05:39:19 PDT
I still have a problem with compiling comm_central. I am completly new in mozilla. My mozconfig lokks like that:
# My first mozilla config
mk_add_options MOZ_OBJDIR=C/thunderbird_src/objects
mk_add_options MOZ_MAKE_FLAGS="-j1"
ac_add_options --enable-calendar
ac_add_options --enable-application=mail

Even if i have -j1 the build process hangs here and there.

If i try pymake it always hangs at the same line in the beginning of the build process:
checking host system type...

I have a win32 xp sp3 system with 3GB (actually 2 then, i think) and an intel core2 duo cpu.
Comment 18 Ryan VanderMeulen [:RyanVM] 2012-09-10 12:12:39 PDT
Do we care about this now that pymake is the default for Windows?
Comment 19 Ted Mielczarek [:ted.mielczarek] 2012-09-10 12:20:14 PDT
It's been WONTFIX for a while, I never intended to do anything about this. We don't technically require Pymake on Windows yet, but we ought to.

Note You need to log in before you can comment on or make changes to this bug.