Russian bad list messages, incorrect display/coding of subject characters, when emails headers doesn't contain proper encoding.

UNCONFIRMED
Unassigned

Status

Thunderbird
Folder and Message Lists
UNCONFIRMED
8 years ago
2 years ago

People

(Reporter: adminnu, Unassigned)

Tracking

({testcase})

Trunk
testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 WebMoney Advisor
Build Identifier: Rus bag list messages

RUS:
При отображении списка писем заголовки, от и т.д. превращаются в кракозябры, в при ответе на письмо, отображаетс все верно. В верной кодировке.
В списке: http://s40.radikal.ru/i090/0910/09/8a5af932c45c.jpg
В ответе: http://s61.radikal.ru/i174/0910/37/d4c5e11b187b.jpg
ENG:
At display of the list of letters headings, from etc. turn to words in the incorrect coding, in at the answer to the letter, all is displayed truly. In the true coding.

List: http://s40.radikal.ru/i090/0910/09/8a5af932c45c.jpg
To: http://s61.radikal.ru/i174/0910/37/d4c5e11b187b.jpg


Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
What verion of TB?

pop3 or imap?

Could attach here an email example using above "Add an attachment" link?
(Reporter)

Comment 2

8 years ago
1) Version Thunderbird 3.0pre (Shredder).
2) The screenshot on the report imap, on pop3 did not look.
3) Points has closed the confidential information, the given problem appears with very considerable quantity of letters, letters come from server Comunnigate.
------------------
Attach:
------------------

X-Real-To: .............
Return-Path: <.........>
Received: from monitor.corbina.net ([85.21.78.25] verified)
  by corbina.ru (CommuniGate Pro SMTP 5.1.14)
  with ESMTP id 81022706 for .............; Sun, 25 Oct 2009 17:42:39 +0300
Received: by monitor.corbina.net (Postfix, from userid 80)
	id 3FCDD1159730; Sun, 25 Oct 2009 17:42:39 +0300 (MSK)
X-Original-To: support@monitor.corbina.net
Delivered-To: support@monitor.corbina.net
Received: from contrabass.post.ru (contrabass.post.ru [85.21.78.5])
	by monitor.corbina.net (Postfix) with ESMTP id 4D27A11583D1
	for <............>; Sun, 25 Oct 2009 15:49:13 +0300 (MSK)
Received: from corbina.ru (mail.post.ru [195.14.50.16])
	by contrabass.post.ru (Postfix) with ESMTP id 47D87AA134
	for <............>; Sun, 25 Oct 2009 15:49:13 +0300 (MSK)
X-Virus-Scanned: by cgpav Uf39PSi9pFi9oFi9
Received: from bayan.corbina.net ([85.21.78.7] verified)
  by corbina.ru (CommuniGate Pro SMTP 5.1.14)
  with ESMTPS id 80971648 for ..........; Sun, 25 Oct 2009 15:49:12 +0300
Received: from localhost (localhost [127.0.0.1])
	by ........... (Postfix) with ESMTP id 468B934D950
	for <.............>; Sun, 25 Oct 2009 15:49:12 +0300 (MSK)
X-Spam-Ystatus: hits=-0.3  __R79
  R5676
  R1718
  R4397
  R1492
  R1385
  __R46
  R4998
  R5133
  __R1411
  R2225
  R159
  R2112
  R2331
  __R5433
X-Spam-Flag: NO
X-Spam-Yversion: Spamooborona-2.3
Received: from mailc.rambler.ru (mailc.rambler.ru [81.19.66.27])
	by bayan.corbina.net (Postfix) with ESMTP id 1041C34D940
	for <...........>; Sun, 25 Oct 2009 15:49:02 +0300 (MSK)
Received: from dnapc (unknown [95.25.7.251])
	(Authenticated sender: ............)
	by mailc.rambler.ru (Postfix) with ESMTP id A06FD621C3C
	for <...............>; Sun, 25 Oct 2009 15:49:01 +0300 (MSK)
Message-ID: <9BB0935DD68B4029B9868A8CE13764FD@dnapc>
From: Павел  <...............> <- Words which are displayed incorrectly
To: <.........>
Subject: [SUPPORT-1352553] Проблемма со скоростью <- Words which are displayed incorrectly
Date: Sun, 25 Oct 2009 15:49:03 +0300
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_000_0007_01CA558A.AD296720"
X-Priority: 3
X-Msmail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2900.5512
X-Mimeole: Produced By Microsoft MimeOLE V6.00.2900.5579
X-Virus-Scanned: ClamAV
X-Original-Reply-To: 
X-Original-From: Павел <............> <- Words which are displayed incorrectly
Errors-To: ....................
Reply-To: Павел  <............> <- Words which are displayed incorrectly

This is a multi-part message in MIME format.

------=_NextPart_000_0007_01CA558A.AD296720
Content-Type: text/plain;
	charset="koi8-r"
Content-Transfer-Encoding: quoted-printable

....................

------=_NextPart_000_0007_01CA558A.AD296720

Content-Type: text/html;
	charset="koi8-r"
Content-Transfer-Encoding: quoted-printable

...................

------=_NextPart_000_0007_01CA558A.AD296720--
(Reporter)

Comment 3

8 years ago
Problem probably связанна that the text coding does not coincide with the coding specified in headings of letters.
It seems partial similar to bug #519699 + wrong subject decode.

Comment 5

8 years ago
There are lots dupes I remember on that from past, I doubt we could do anything about that. You could change default character encoding per folder basis. Just right click on folder select property and select Windows2151 instead of Koi8-R.
Whiteboard: dupeme
(Reporter)

Comment 6

8 years ago
Yes, change on coding Windows-1251 has helped, the coding means for the given letters is defined incorrectly.
Probably dupe of Bug 425945
Adminnu@mail.ru do you agree with comment 7 ?

Updated

8 years ago
Whiteboard: dupeme → [dupeme][closeme 2009-12-01]
(Reporter)

Comment 9

8 years ago
No, there https://bugzilla.mozilla.org/show_bug.cgi? id=425945#c14 there is a problem with a part of heading of the message, and at me at заголовока messages and the name of the sender is incorrectly defined the coding. The comment https://bugzilla.mozilla.org/show_bug.cgi? id=524287#c5 has helped. 
That says that headings:
Content-Type: text/plain; charset = "koi8-r"
Content-Type: text/html; charset = "koi8-r"
He does not see.
(Reporter)

Comment 10

8 years ago
As a bit other letter with a similar problem, but here at all does not help council https://bugzilla.mozilla.org/show_bug.cgi? id=524287#c5 most likely, the heading was in the coding windows-1251 about what speaks Content-Type: text/plain; charset=windows-1251 and the letter on the server, but was visible wrongly a server закодированно in base64 with addition =? koi8-r? Q?

X-Virus-Scanned: by cgpav Uf39PSi9pFi9oFi9
X-Real-To: <...................>
Return-Path: <...................>
X-ListServer: CommuniGate Pro LIST 5.1.14
List-Unsubscribe: <...................>
List-ID: <...................>
Precedence: list
Message-ID: <...................>
Reply-To: <...................>
Sender: <...................>
To: ...................
From: <...................>
MIME-Version: 1.0
Content-Type: text/plain; charset=windows-1251
Content-Transfer-Encoding: 8bit
X-Original-Message-ID: <20091009125832.9CD3010061@...................>
Date: Fri, 9 Oct 2009 16:58:32 +0400 (MSD)
Subject: [pg_staff] [HOMENET-179340] =? koi8-r? Q?= C2=EE=EF=F0=EE=F1? =
 =? koi8-r? Q? _ =F1 _ = F1=E0=E9=F2=E0? = Corbina. TV [14]
 =? koi8-r? Q? =C7=E0=E4=E0=F2=FC _ = E2=EE=EF=F0=EE=F1? =

-------------------------------------
(Reporter)

Comment 11

8 years ago
As a bit other letter with a similar problem, but here at all does not help council https://bugzilla.mozilla.org/show_bug.cgi? id=524287#c5 most likely, the heading was in the coding windows-1251 about what speaks Content-Type: text/plain; charset=windows-1251 and the letter on the server, but was visible wrongly a server закодированно in base64 with addition =? koi8-r? Q?

X-Virus-Scanned: by cgpav Uf39PSi9pFi9oFi9
X-Real-To: <...................>
Return-Path: <...................>
X-ListServer: CommuniGate Pro LIST 5.1.14
List-Unsubscribe: <...................>
List-ID: <...................>
Precedence: list
Message-ID: <...................>
Reply-To: <...................>
Sender: <...................>
To: ...................
From: <...................>
MIME-Version: 1.0
Content-Type: text/plain; charset=windows-1251
Content-Transfer-Encoding: 8bit
X-Original-Message-ID: <20091009125832.9CD3010061@...................>
Date: Fri, 9 Oct 2009 16:58:32 +0400 (MSD)
Subject: [pg_staff] [HOMENET-179340] =? koi8-r? Q?= C2=EE=EF=F0=EE=F1? =
 =? koi8-r? Q? _ =F1 _ = F1=E0=E9=F2=E0? = Corbina. TV [14]
 =? koi8-r? Q? =C7=E0=E4=E0=F2=FC _ = E2=EE=EF=F0=EE=F1? =

-------------------------------------

Updated

8 years ago
Summary: Rus bag list messages → Russian bad list messages, incorrect display/coding of subject characters
Whiteboard: [dupeme][closeme 2009-12-01] → [dupeme]

Comment 12

8 years ago
p.s. please attach comment 0 screen shots to the bug
(Reporter)

Comment 13

8 years ago
In the same place sreens are applied.

List: http://s40.radikal.ru/i090/0910/09/8a5af932c45c.jpg
To: http://s61.radikal.ru/i174/0910/37/d4c5e11b187b.jpg

Comment 14

8 years ago
Attach screenshots to bug do not use external services.
(Reporter)

Comment 15

6 years ago
At the moment, the problem is not watching. Sources of screenshots can not be found. If the problem persists, open a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 16

5 years ago
Bug respawns.

Eng:
Message headers:
From: уМХЦВБ РПДДЕТЦЛЙ БЧФПТПЧ Subscribe.Ru <list@subscribe.ru>
To: "бМЕЛУЕК" <***@mail.ru>
Subject: йОЖПТНБГЙС П ТБУУЩМЛБИ Й МЙУФБИ БЧФПТБ 9953 ОБ 12-11-2012
MIME-Version: 1.0
Content-Type: text/html; charset="koi8-r"

it`s in koi8-r encoding. In message list - words in incorrect encoding. 
In message view - words in correct encoding.

Samples of message file and screenshot:
https://sites.google.com/site/praw2003/thunderbird-bug

Thunderbird version: 16.0.2

Rus:

Пример заголовка сообщения:
From: уМХЦВБ РПДДЕТЦЛЙ БЧФПТПЧ Subscribe.Ru <list@subscribe.ru>
To: "бМЕЛУЕК" <***@mail.ru>
Subject: йОЖПТНБГЙС П ТБУУЩМЛБИ Й МЙУФБИ БЧФПТБ 9953 ОБ 12-11-2012
MIME-Version: 1.0
Content-Type: text/html; charset="koi8-r"

Заголовок в кодировке кои-8, в списке сообщений (верхняя панель) - кодировка сбита у полей темы, отправителя и получателя. В просмотре сообщения (нижняя панель) всё отображается корректно.

Пример файла сообщения и скриншот:
https://sites.google.com/site/praw2003/thunderbird-bug

Comment 17

5 years ago
Created attachment 680501 [details]
Sample of bug message in koi8-r

Comment 18

5 years ago
Created attachment 680502 [details]
screenshot of bug with koi8-r in message list and message view

In message list encoding is bug. In message view - encoding good.
in message file koi8-r encoding
(Reporter)

Updated

5 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

5 years ago
Component: General → Folder and Message Lists
OS: Windows XP → All
Hardware: x86 → All
Version: 3.0 → Trunk
(Reporter)

Updated

5 years ago
Component: Folder and Message Lists → General

Comment 19

4 years ago
still seeing this in version 24?
Flags: needinfo?(mail)
Keywords: testcase

Comment 20

4 years ago
Created attachment 8354968 [details]
thunderbird.png

Bug in 24.2.0
Attachment #680502 - Attachment is obsolete: true

Comment 21

3 years ago
Nikolay, can you offer any advice?
Component: General → Folder and Message Lists
Flags: needinfo?(mail) → needinfo?(shopik)

Comment 22

3 years ago
Wayne, there is only advice can help here which I gave on comment#5 (fallback character encoding) since these emails headers doesn't contain proper encoding.
Flags: needinfo?(shopik)

Updated

2 years ago
Summary: Russian bad list messages, incorrect display/coding of subject characters → Russian bad list messages, incorrect display/coding of subject characters, when emails headers doesn't contain proper encoding.
You need to log in before you can comment on or make changes to this bug.