Aborting a spell check on send can cause compose window to disappear

RESOLVED INVALID

Status

--
minor
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: allan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: version 2.0.0.23 (20090812)

When using the "Check spelling before sending" option, if you abort a spell check invoked on Send to do more editing of your email message, the compose window will disappear the next time you attempt to save the message. As far as I can tell any changes made to the message before attempting the save are saved so you can resume your work re-opening the message, but it's quite annoying and a bit shocking the first few times it happens.

Reproducible: Always

Steps to Reproduce:
1. Make sure the "Check spelling before sending" option is enabled.
2. Create a new email message with spelling mistakes.
3. Press "Send this message now" button or select File->Send. 
4. When the spelling checker runs and highlights an error cancel it using the Stop button or by closing the spelling checker window.
5. Save the message (press the "Save this message" button, hit Ctrl+S, or select File->Save) and watch your "Compose:..." window disappear.

Actual Results:  
The "Compose:..." window disappears every time.

Expected Results:  
The contents of the email message should be saved in the Drafts folder and the "Compose:..." window should stay around so further editing could be performed. 

I'm not completely sure, but I think this problem has been around for quite a while.

If you use Ctrl+Enter to send the message instead of pressing the "Send this message now" button or selecting File->Send to problem doesn't appear to exist.

I only use POP Mail Servers so I do not know if this problem exist with IMAP.
WFM using

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091024 Lightning/1.0pre Shredder/3.0pre ID:20091024031730

Allan could try if beahaves the same in safe-mode?
see http://kb.mozillazine.org/Safe_mode
(Reporter)

Comment 2

9 years ago
I should have run safe-mode before opening the bug report. The problem goes away with safe-mode and I've since narrowed the problem down to a single add-on. The problem is due to Stationery 0.4.10 (Extension to mimic Outlook Express Stationary). I guess this bug report needs to be forwarded the developer for the Stationery add-on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Allan can you email yourself the developer of this extension for submit this bug?

Comment 4

9 years ago
Allan send me mail already.
Today I make fixes, and I send him bug-fixed version of Stationery for test.
You need to log in before you can comment on or make changes to this bug.