Closed Bug 524443 Opened 12 years ago Closed 12 years ago

Windows XP theme inconsistencies

Categories

(Thunderbird :: Mail Window Front End, defect, P3)

All
Windows XP
defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: Aureliano, Assigned: andreasn)

Details

(Keywords: polish, Whiteboard: [no l10n impact])

Attachments

(2 files)

Attached image screenshot
Reading today pushlog, I suppose that landed of bug #516384 not has effect to Windows XP theme (expecially to maintoolbar) because changes are related to binary file mail/themes/qute/mail/icons/mail-toolbar-aero.png.

I think (but probably this bug is Wontfix) that Windows XP theme has several inconsistencies as show in attached screenshot: in general several icons not are moved to tango style and still look as old TB 2.0. For example

1. in main toolbar "write" button is old and different to write button in "Address Book" window (in the past the buttons use the same icon);

2. on compose message window, address book button (now named contacts) is different to address book icon on mail toolbar;

3. on mail toolbar Junk icon is different from new junk icon on folder pane (and on header colum on message list);

4. on message header Junk icon is different from new junk icon on folder pane (and on header colum on message list);

5. on mail toolbar Delete icon is different from new delete icon on address book window and also different for other theme filosophy (e.g. in Linux theme) that use the same icon of Trash folder in message pane and not "X" icon;

6. same of point 5 for delete icon on message header button;

7. on main toolbar "reply to list" has a style very very different from old "reply", "reply all" and "forward" that are derived from old 2.0 theme.

This "issues" should be block TB 3 or are a wontfix issue?

I cannot find any dupe.
Flags: blocking-thunderbird3?
Status: UNCONFIRMED → NEW
Ever confirmed: true
This should fix the issue. What do you think Bryan?
Attachment #408370 - Flags: ui-review?(clarkbw)
Assignee: nobody → nisses.mail
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Priority: -- → P3
Hardware: x86 → All
Whiteboard: [no l10n impact]
Target Milestone: --- → Thunderbird 3.0rc1
Version: 3.0 → Trunk
Whiteboard: [no l10n impact] → [no l10n impact][needs review clarkbw]
Comment on attachment 408370 [details] [diff] [review]
patch to fix the issue

yeah, looks good to me.

i'm putting philor as the code reviewer
Attachment #408370 - Flags: ui-review?(clarkbw)
Attachment #408370 - Flags: ui-review+
Attachment #408370 - Flags: review?(philringnalda)
Whiteboard: [no l10n impact][needs review clarkbw] → [no l10n impact][needs review philor]
Comment on attachment 408370 [details] [diff] [review]
patch to fix the issue

Can't really argue with the code, since it's a couple of images :)
Attachment #408370 - Flags: review?(philringnalda) → review+
Keywords: checkin-needed
Whiteboard: [no l10n impact][needs review philor] → [no l10n impact]
Checked in:
http://hg.mozilla.org/comm-central/rev/f5a9c4adc8fc
http://hg.mozilla.org/releases/comm-1.9.1/rev/0dfa6a2768c4
Status: NEW → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Thanks Andreas: it is fantastic :-D
You need to log in before you can comment on or make changes to this bug.