Gmail Voice and video chat disabled in Firefox 3.6 betas

RESOLVED DUPLICATE of bug 536116

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 536116
8 years ago
8 years ago

People

(Reporter: channy, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I use Firefox 3.6 Beta 1. I cannot use Voice and video chat of Gmail although I already install this plug-in. 

I guess it's in new plug-in regulation of Firefox 3.6. It's not Firefox's problem, but you must survey whether Google's video chat plugin has problem or not.

Updated

8 years ago
Summary: Disable Voice and video chat of Gmail in Fierfox 3.6 → Disable Voice and video chat of Gmail in Firefox 3.6
Summary: Disable Voice and video chat of Gmail in Firefox 3.6 → Gmail Voice and video chat disabled in Firefox 3.6b1
I went back to Firefox 3.5 and I do see the video camera icon present in that build on the Mac. When I switch back to Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b1) Gecko/20091019 Firefox/3.6b1 I no longer see the video camera icon. I wasn't able to launch a video/voice chat though - but it might have been user error.

Channy - Did Voice and Video chat work in Firefox 3.5.3?
Juan I and both looked at this and it appears 3.6 is not recognizing the Google plugin. cc'ing Kev and Chris Blizzard since the Google video chat page does not indicate specifically which browser version should work (it just says 3.x)
I forgot to add that I did get the video chat to work using Firefox 3.5 on the Mac, so it did work in 3.5.

Comment 4

8 years ago
I'm assuming this is a compatibility bug more than anything? I'll ping the folks there and ask if they can do a compat check and update.
Duplicate of this bug: 526009

Comment 6

8 years ago
I am having the same problem with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091105 Minefield/3.7a1pre Firefox/3.5 GTB5 ID:20091105045542.  I have tried installing the plugin with the result of it not working.  At this point I am not sure what needs to be done to test or make it work.

Comment 7

8 years ago
Is bug still exists in Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091218 Minefield/3.7a1pre ID:20091218043634

Any ETA for a fix?
This affects Firefox 3.6b5 for Mac OS Snow Leopard, too.

In this forum...
http://www.google.com/support/forum/p/gmail/thread?tid=7c82d0619f322ec1
...someone suggests that this has to do with component blocking.  That strikes me as a highly-likely explanation for this.  Marking dependency.

Assuming that's the explanation, the solution would be for Google to modify their "Voice and Video" software so that it doesn't depend on modifying the Firefox installation's "components" directory.  (Instead, it should register as a standard extension/plugin.)

Kev -- any word back from your contacts, from comment 4?  I imagine Google would already have noticed this and would be working on it, but if not, you can refer them to Johnath's blog post for more info:
http://blog.mozilla.com/security/2009/11/16/component-directory-lockdown-new-in-firefox-3-6/
Blocks: 519357
OS: Windows XP → All
Hardware: x86 → All
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Version: 3.6 Branch → unspecified
Summary: Gmail Voice and video chat disabled in Firefox 3.6b1 → Gmail Voice and video chat disabled in Firefox 3.6 betas
No, that's not related to the component folder lockdown. This feature went in for 3.6b4 but the original report states this problem already with beta 1. I suspect that a change of the NPAPI has been caused this. We would need a clear regression range.
No longer blocks: 519357
Keywords: regression, regressionwindow-wanted
D'oh, ok -- thanks Henrik, guess I called it too soon. Changing component to Core | Plugins.
Assignee: english-us → nobody
Component: English US → Plug-ins
Product: Tech Evangelism → Core
QA Contact: english-us → plugins
Version: unspecified → Trunk
Flags: blocking1.9.2?
FWIW, on my dad's mac running Firefox 3.6b5, the Google Voice plugin does show up in the Plugin pane of Addons manager.  It's called "Google Talk NPAPI Plugin", version 1.0.19.1554, and it says it's enabled.
Right. Same here. I'm already sitting on a regression range check. Please stay tuned. As what I can say for now it regressed after 09/03/15.
Regressed between the builds 09070603 and 09070703:

PASS: http://hg.mozilla.org/mozilla-central/rev/b4fee3813956
FAIL: http://hg.mozilla.org/mozilla-central/rev/2f6cb9dc1f13

Check-ins: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b4fee3813956&tochange=2f6cb9dc1f13

Nothing points out that this should be plugin related. I assume it has been regressed by a spidermonkey fix from that day.
Mmh, i have missed bug 502137 in the above list. Probably related to its checkin?
Tested with changesets 457417981271 and 0161c74dc486 around the assumed check-in and as what I can see I was right. Without the patch on bug 502137 the Google talk plugin is working fine.

(In reply to comment #11)
> FWIW, on my dad's mac running Firefox 3.6b5, the Google Voice plugin does show
> up in the Plugin pane of Addons manager.  It's called "Google Talk NPAPI
> Plugin", version 1.0.19.1554, and it says it's enabled.

The plugin has 'NPAPI' in its version string. So this is suspicious.

Johnny, can you please check that?
Blocks: 502137
Keywords: regressionwindow-wanted
Was this fixed by bug 536116 (which landed yesterday on mozilla-central and today on 1.9.2, and reverted part of bug 502137)?
Thanks David! I checked the latest Minefield build and also a Tinderbox build of Namokoka doesn't fail anymore. Marking as fixed by bug 536116.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b6pre) Gecko/20091226 Namoroka/3.6b6pre ID:20091226144131
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: blocking1.9.2?
Resolution: --- → DUPLICATE
Duplicate of bug: 536116
You need to log in before you can comment on or make changes to this bug.