Missing title in first tab with personas extension installed

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: tchung, Assigned: erik)

Tracking

Trunk
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 408680 [details]
missing first tab name screenshot

I'm still trying to narrow down a repro steps for this.  but as you can see, the first tab will have a blank title to it.

Found on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b1) Gecko/20091019 Firefox/3.6b1

have lightweight themes and personas 1.3 addon installed.

Updated

9 years ago
Assignee: cbeard → erik

Comment 1

9 years ago
Hmmm... I tried for a while but I haven't been able to reproduce this.

Comment 2

9 years ago
Got it. I can confirm this occurs, only I cannot reproduce it consistently.

According to DOM Inspector, all tabs have exactly the same CSS style rules applied to them. The only difference is that the node for the first tab is named "xul:tab", whereas the rest of tab nodes are named "tab". Perhaps this causes a CSS rule not to be applied?
Does the tab with the missing title have a label attribute?

(In reply to comment #2)
> According to DOM Inspector, all tabs have exactly the same CSS style rules
> applied to them.

What about the label elements inside of the tabs? Still the same style rules?

> The only difference is that the node for the first tab is
> named "xul:tab", whereas the rest of tab nodes are named "tab". Perhaps this
> causes a CSS rule not to be applied?

Shouldn't make a difference.

Comment 4

9 years ago
(In reply to comment #3)
> Does the tab with the missing title have a label attribute?

Yes, the label attribute is set correctly.

> 
> (In reply to comment #2)
> > According to DOM Inspector, all tabs have exactly the same CSS style rules
> > applied to them.
> 
> What about the label elements inside of the tabs? Still the same style rules?

Same style too for the inner label element.

> 
> > The only difference is that the node for the first tab is
> > named "xul:tab", whereas the rest of tab nodes are named "tab". Perhaps this
> > causes a CSS rule not to be applied?
> 
> Shouldn't make a difference.
I took a look as well, and I see one difference in the set of rules being applied to the first tab. It matches a tab:first-of-type selector on line 43 of tabbox.css. But the style declaration for that selector just sets |-moz-padding-start: 2px|, so that's unlikely to be the culprit.

However, both the xul:tab element and the xul:label element it encloses have the computed style |color: rgb(255, 255, 255)| in my test of a dark persona that uses a white text color (http://www.getpersonas.com/en-US/persona/830), which makes me wonder if there's actually a Gecko bug here.

(Also, once while I was inspecting the browser window with the DOM inspector, the label of the first tab became white as I was clicking twisties in the DOM inspector's tree of elements, which was strange. I can't reproduce this behavior, however.)

Comment 6

9 years ago
In the latest check-in, we determined that this could be a platform issue. I've reached out to Damon, and cc'd him on this bug, to figure out if someone from the platform team can take a quick look.

Comment 7

9 years ago
According to our tests, this issue no longer occurs now that the patch for bug 530106 has landed, because the lightweight theme code is favored over the Personas add-on code. Will mark this as resolved so you can test as soon as we upload bug 530106's patch.
Status: NEW → ASSIGNED

Comment 8

9 years ago
Patch committed in changeset:
http://hg.mozilla.org/labs/personas/rev/9b88f78b0734
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

9 years ago
Reopening.  i just installed https://people.mozilla.com/~cbeard/personas/dist/personas-dev-1.5x0d200911232116.xpi with minefield nightly (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20091130 Minefield/3.7a1pre), and still get the missing text in the first tab.   Without personas extension, its fine.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Tony: we recently moved dev builds to a new server.  Can you test with the latest version available on that server and let us know if you still see the problem?  The latest version is now available at the following URL:

https://ftp.mozilla.org/pub/mozilla.org/labs/personas/personas-dev-latest.xpi
(Reporter)

Comment 11

9 years ago
oh okay, thats much better.   Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b5pre) Gecko/20091130 Namoroka/3.6b5pre and Personas 1.5x0d200911252231.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
Blocks: 521913
No longer depends on: 521913
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.