Lightweight theme is shown as enabled, despite personas extension changing the theme

VERIFIED FIXED in 1.5

Status

Mozilla Labs Graveyard
Personas Plus
--
minor
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: tchung, Assigned: Juan Manuel Rodriguez Alvardo)

Tracking

unspecified

Details

(Whiteboard: [l10nFxTestday])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 413638 [details]
Wrong used theme shown screenshot

Lightweight themes set as "used theme" will never get defaulted to what the personas extension theme is applied.  Is there a way to dynamically update this?

See screenshot

Repro:
1) install 192 nightly or b3.  
2) apply a lightweight theme, and verify theme manager has it set to "use theme" button
3) install personas extension 1.4
4) change themes using the extension
5) Verify theme manager still shows your first lightweight theme as "used theme", despite it differing from what the personas extension has overwritten.

Expected:
- some way to sync up the theme manager to know that personas extension is using its own theme.

Actual:
- lightweight theme gets "used" despite the persona extension overwriting it.
(Reporter)

Updated

9 years ago
Whiteboard: [l10nFxTestday]
Sounds like something the Personas addon should be handling.
Assignee: nobody → cbeard
Component: General → Personas
Product: Firefox → Mozilla Labs
QA Contact: general → personas
Target Milestone: --- → --
Agreed, it's the responsibility of the extension to keep the theme manager up-to-date with its changes to the lightweight theme.
(Reporter)

Updated

9 years ago
Depends on: 521913

Updated

9 years ago
Assignee: cbeard → jose
Target Milestone: -- → 1.5

Updated

9 years ago
Assignee: jose → juan
Status: NEW → ASSIGNED
(Assignee)

Comment 3

9 years ago
Created attachment 414405 [details] [diff] [review]
proposed patch

This patch makes personas addon work in sync with addons/themes dialog. 

Now, changes in themes made using personas are reflected properly in the addons/themes dialog and viceverza.

There is one case where the current persona menuitem is not being updated properly. Howerver, we realized this issue will be addressed when the fix for Bug 530146 is landed, because the issue is caused by the lightweight-theme-changed topic being notified too many times. These are the steps to reproduce the problem:

- go to a light weight theme page at getpersonas (e.g http://www.getpersonas.com/en-US/persona/49)
- click wear this button

Current behavior

the current persona menuitem is not updated accordingly

Expected behavior

the current persona menuitem is updated accordingly
Attachment #414405 - Flags: review?(myk)
Comment on attachment 414405 [details] [diff] [review]
proposed patch

>+  /**
>+   * Notifies the persona changes or uses the lightweight theme manager
>+   * functionality for this purpose (if available)
>+   * @param aPersona the persona to be set as current if the lighweight theme
>+   * manager is available
>+   */

Nit: lighweight -> lightweight

This looks good and works well in my tests. r=myk
Attachment #414405 - Flags: review?(myk) → review+

Comment 5

9 years ago
Patch committed in changeset:
http://hg.mozilla.org/labs/personas/rev/9b88f78b0734
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b5pre) Gecko/20091202 Namoroka/3.6b5pre and personas 1.5 nightly.
Status: RESOLVED → VERIFIED
Blocks: 521913
No longer depends on: 521913
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.