Closed Bug 524800 Opened 10 years ago Closed 10 years ago

Clicking the Website link in feed article message header does nothing (NS_ERROR_MALFORMED_URI)

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0rc1

People

(Reporter: wladow, Assigned: BenB)

References

Details

(Keywords: regression, Whiteboard: [no l10n impact])

Attachments

(1 file, 2 obsolete files)

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5pre) Gecko/20091027 Shredder/3.0pre

- open Shredder's feed reader and load any article
- click the Website link in message header
- it should be opened in a web browser, but nothing happens

Error console says:

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIMessenger.launchExternalURL]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: chrome://communicator/content/utilityOverlay.js :: openUILink :: line 296"  data: no]

Works fine in 20091026.
Flags: blocking-thunderbird3?
window:
20091026 works
20091027 does not
20091028 does not
it was just introduced that new multi line header text wrapping (or so), maybe related...



click on a website link in the msg header (nothing happens):

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIMessenger.launchExternalURL]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: chrome://communicator/content/utilityOverlay.js :: openUILink :: line 296"  data: no]

rclick and copy link (does not copy)

Error: uncaught exception: [Exception... "Could not convert JavaScript argument arg 0 [nsIObserverService.removeObserver]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: chrome://messenger/content/search.xml ::  :: line 294"  data: no]
Regression from bug 489609. Looks like the mail-headerfield binding changed where it stored the text, but the mail-urlfield didn't. This scares me in case there are other subtle locations where this has changed.
Blocks: subjectwrap
Flags: blocking-thunderbird3? → blocking-thunderbird3+
OS: Windows Vista → All
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0rc1
Fix is trivial. The binding mail-urlfield inherits from mail-headerfield, and directly accessed attributes/properties of the textbox. We just need to change it to use .headerValue instead of .value.

At least I think so. I'll attach a prototype patch. I can't test it at the moment, because I am not using the feed reader, so the patch may not work.

> This scares me in case there are other subtle locations where this has changed.

I looked for any other XBL widgets which inherit from mail-headerfield, and found none.
Assignee: nobody → ben.bucksch
Attached patch Fix, v1, untested (obsolete) — Splinter Review
As said, may not work, but if so, needs only minor adjustments.
Doesn't work, this.headerValue is undefined.
Attached patch Fix, v2 (obsolete) — Splinter Review
This works for me. It simply adapts .value -> .textContent (and <label> -> <description>, because we now set .textContent).

Better would be to:
- use .headerValue, but I don't know how to get to the XBL widget from the contained <description> object - .parentNode didn't work.
- maybe simply remove the inheritance, as only one line (the headerValue property) is inherited.
Attachment #408939 - Attachment is obsolete: true
Attachment #408969 - Flags: review?(bugzilla)
Whiteboard: [no l10n impact]
Attachment #408969 - Flags: review?(bugzilla) → review?(bwinton)
Attachment #408969 - Flags: review?(bwinton) → review+
Comment on attachment 408969 [details] [diff] [review]
Fix, v2

>+++ b/mail/base/content/mailWidgets.xml
>-      <xul:label onclick="if (event.button != 2) openUILink(event.target.value, event);"
>+      <xul:description onclick="if (event.button != 2) openUILink(event.target.textContent, event);"

You could split this on to two lines.  Or not.  Whatever.

Other than that, and I don't even really count that, it looks good to me.

Later,
Blake.
Attachment #408969 - Attachment is obsolete: true
Attachment #409111 - Flags: approval-thunderbird3?
Ok, this seems to be working fine.

The bug is marked as blocking‑thunderbird3+, you don't need another approval, I think.
Attachment #409111 - Flags: approval-thunderbird3?
FIXED
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This is not working on 20091029 nightly.  The "website" link on RSS feed messages does nothing when clicked, and right-click "Copy Link Location" leaves the clipboard empty.
WinXP SP3.
Yes? Because I just fixed it less than an hour before you commented, and the your build doesn't have the fix yet?
Duplicate of this bug: 525381
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1.5pre) Gecko/20091030 Shredder/3.0pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.