Form Fill jumps content to the top left on OkCupid

VERIFIED FIXED

Status

Fennec Graveyard
General
--
major
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

Fennec 1.1

Details

(Whiteboard: formfill)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b2pre) Gecko/20091027 Namoroka/3.6b2pre Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091027 Namoroka/3.7a1pre Fennec/1.0b5pre

Steps to Reproduce:
1. Go to www.okcupid.com
2. Fill out the form on the first page and click "Next"
3. Click on either the zip code or email address field
4. Type in one or more letters

Actual Results:
The content pane will pan to the top left

Expected Results:
The content pane shouldn't move
Whiteboard: formfill
I've seen this happen on other websites too (bugzilla as example). I think this is relate to scroll position or something like that because I can see a scroll event happening when typing a letter which cause the UI to redraw at position 0,0
also matchage.com when typing the age in the text field

Comment 3

8 years ago
Happens (at okcupid.com and matchage.com) with
both 1.9.2 and trunk nightlies 20091125 on linux-i686.

At matchage.com, it doesn't happen every time with the 1.9.2 nightly.
(Reporter)

Comment 4

8 years ago
I see this on bugzilla's frontpage when typing text into the "Quick Search" below the large button images. This probably needs to block.
tracking-fennec: --- → ?
(Reporter)

Updated

8 years ago
Severity: normal → major
(In reply to comment #4)
> I see this on bugzilla's frontpage when typing text into the "Quick Search"
> below the large button images. 

Seeing this too

> This probably needs to block.

agreed

In fact this bug should be resolved when bug 500700 will be resolved. 
I've kept this bug opened just to remenber it also affects the Form Assistant.
Depends on: 500700
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500700
(Reporter)

Comment 7

8 years ago
dupe v.
Status: RESOLVED → VERIFIED
Created attachment 416645 [details] [diff] [review]
dirty patch

Because there is a reflow when you enter a letter on the keyboard and because the real browser scrollbox position is at 0,0 we handle it thought handlePageScroll.

This patch fix that but it also means that we're going to handle page scroll events when while the form assistant is opened.
Assignee: nobody → 21
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 416653 [details] [diff] [review]
Patch

Ben, this bug is the real bug which correspond to 527187 which is a blocker (and a dup of this one)
Attachment #416645 - Attachment is obsolete: true
Attachment #416653 - Flags: review?(webapps)
Comment on attachment 416653 [details] [diff] [review]
Patch

>+  _ignorePageScroll: false,
>+  ignorePageScroll: function ignorePageScroll(aIgnoreScroll) {
>+    this._ignorePageScroll = aIgnoreScroll;
>+  },

Oh noes :( I'm pretty certain there is no other way to do this, so you get an r+.  Fixes the problem for me on okcupid.
Attachment #416653 - Flags: review?(webapps) → review+

Updated

8 years ago
Duplicate of this bug: 527187
Ben I have filled bug 533970 for the bug you found during the test for this patch
Pushed http://hg.mozilla.org/mobile-browser/rev/03cfe0e88a8d
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

8 years ago
Content window does not jump on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091214 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091214 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.