Unable to open .docx attachments directly from Penelope

RESOLVED DUPLICATE of bug 552773

Status

RESOLVED DUPLICATE of bug 552773
9 years ago
9 years ago

People

(Reporter: ctefft, Assigned: mdudziak)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: 

When a .docx file is received in Penelope and then you attempt to open it directly from the message, it opens as a garbled file, whether you attempt to open it in Word or Notepad.  In Word 2003 with the Office Compatibility Pack installed, you are prompted as to what kind of character encoding to use with the file, no options (western, plain text, etc.) give you a readable file.  The icon for the .docx file is a plain notepad, not a Word icon.   

If you save the .docx file to the machine (right click and Save) and then open it, it opens without a problem.  When the file is saved locally, the correct icon appears.  

Reproducible: Always

Steps to Reproduce:
1. Receive a message with a .docx document attached
2. Attempt to open the document from the email message (double click or right click and choose Open)

Actual Results:  
Word opens and you are prompted to choose character encoding.  No matter which selection you make, a garbled document opens.  

Expected Results:  
Word should open the document and read it as normal.  

I have not been able to try this on a machine that has Office 2007 installed, only Office 2003 with Compatibility Pack.   

I added mapping as per: http://eudorabb.qualcomm.com/showthread.php?t=12600 which did not resolve the issue.
(Reporter)

Comment 1

9 years ago
Build is Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090408 Eudora/3.0b2

Comment 2

9 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
> AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
> Build Identifier: 
> When a .docx file is received in Penelope and then you attempt to open it
> directly from the message, it opens as a garbled file, whether you attempt to
> open it in Word or Notepad.  In Word 2003 with the Office Compatibility Pack
> installed, you are prompted as to what kind of character encoding to use with
> the file, no options (western, plain text, etc.) give you a readable file.  The
> icon for the .docx file is a plain notepad, not a Word icon.   
> If you save the .docx file to the machine (right click and Save) and then open
> it, it opens without a problem.  When the file is saved locally, the correct
> icon appears.  
> Reproducible: Always
> Steps to Reproduce:
> 1. Receive a message with a .docx document attached
> 2. Attempt to open the document from the email message (double click or right
> click and choose Open)
> Actual Results:  
> Word opens and you are prompted to choose character encoding.  No matter which
> selection you make, a garbled document opens.  
> Expected Results:  
> Word should open the document and read it as normal.  
> I have not been able to try this on a machine that has Office 2007 installed,
> only Office 2003 with Compatibility Pack.   
> I added mapping as per: http://eudorabb.qualcomm.com/showthread.php?t=12600
> which did not resolve the issue.

I confirm this bug.  Also happens on a machine with Office 2007.  On my machine, a docx file opens in Powerpoint!  But pptx files open OK in powerpoint.

Now here's the key observation:  this is a Thunderbird bug.
(Assignee)

Comment 3

9 years ago
Odd. I am able to open DOCX files just fine.

You say that this is a Thunderbird bug. Is there a Thunderbird bug open for this? A simple search does not find one.

Comment 4

9 years ago
(In reply to comment #3)
> Odd. I am able to open DOCX files just fine.
> You say that this is a Thunderbird bug. Is there a Thunderbird bug open for
> this? A simple search does not find one.

I meant, "this should be reported as a Tbird bug".
**However** I too am now able to open DOCX files just fine.  Cannot reproduce the former errors.
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 5

9 years ago
I am having this error in Thunderbird, I have reported it 552773, I do not actually see a resolution here, just that a tester could no longer reproduce it.  Am I missing something?

Comment 6

9 years ago
This error seems to be intermittent.  I've not defined conditions that allow me to observe it reproducibly.  Sorry
(Assignee)

Comment 7

9 years ago
This looks to be a duplicate of the Thunderbird bug. Marking as such and adding '[penelope_wants]' to the Thunderbird bug.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 552773
You need to log in before you can comment on or make changes to this bug.