"save as draft" fails when compose window is opened from attached message window

RESOLVED DUPLICATE of bug 389650

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 389650
8 years ago
7 years ago

People

(Reporter: Daniel Kabs, reporting bugs since 2002, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

You can open an attached message in its own message window. This way you can
reply to the attached message.  Two problems occur:
- Wrong default "From:" address
- Can not save Draft.

This is about the *second* problem.


Reproducible: Always

Steps to Reproduce:
How to reproduce:
- Configure multiple mail accounts and identities and at least one news
account.
- Configure your accounts to save drafts to Local "draft" folder.
- Forward yourself a mail message as attachment (not inline!)
- Open this mail message
- In message pane at the bottom a list of attachments is shown.
- Open Attachment in new window (right click attachment and select "open") 
- In new window press button "Reply" or "Reply all". New compose window opens.
- Select menu File > Save as > Draft


Actual Results:  
Error message pops up.
> Unable to save your message draft.
> Please verify that your Mail&Newsgroups account settings are correct and try again.




Expected Results:  
Message should be saved to local "Draft" folder.


If I use any mail account to compose a new message, saving draft works.
The problem exists when I reply to attached messages.

See also bug #525032
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
Can be reproduced with latest nightly build.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091102 Shredder/3.0pre
Anything in tools ->Error console when this happens ?
Nothing appears in error console when I select "File -> Save as Draft" in the compose window (replying to the  forwared mail stored in attachment).

But before that - when opening attachment - the following text appears in Error Console:
| Error: msgHdr.folder is null
| Source File: chrome://messenger/content/mailWindowOverlay.js
| Line: 2715

Comment 4

8 years ago
Starting with the 20091107 nightly, I do also get this error message when simply replying to an email and trying to safe the draft.

Unable to save your message draft.
Please verify that your Mail&Newsgroups account settings are correct and try again.

This is an IMAP account and the draft is supposed to be saved in Local Folders.
Furthermore, the message also failed to send.
Reverting back to 20091106 nightly, everything works fine. No other changes were made in between the two versions.

The failure to save the draft is seen with both, Windows and Linux. The difference is that TB simply crashed on Windows. 
http://crash-stats.mozilla.com/report/index/60e31f95-90b7-4f29-8b07-ba9702091107
(In reply to comment #4)
> Starting with the 20091107 nightly, I do also get this error message when
> simply replying to an email and trying to safe the draft.
 Crhistian do you use enigmail ?

Comment 6

8 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Starting with the 20091107 nightly, I do also get this error message when
> > simply replying to an email and trying to safe the draft.
>  Crhistian do you use enigmail ?

I do have Enigmail installed in both, the Linux and Windows TB installation. However, when the problem was seen, the message was neither signed nor encrypted.
If you still see the problem disbale enigmail and tell us if the problem goes away ...

Comment 8

8 years ago
(In reply to comment #7)
> If you still see the problem disbale enigmail and tell us if the problem goes
> away ...

The problem is not seen when Enigmail is removed.
I don't have Enigmail add-on installed and I still see the problem.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6pre) Gecko/20091110 Shredder/3.0pre

Comment 10

8 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > If you still see the problem disbale enigmail and tell us if the problem goes
> > away ...
> 
> The problem is not seen when Enigmail is removed.

The above statement was for TB nightly 20091108 on Windows.

I checked again with TB and Enigmail nightly 20091110 on Linux, and no problem is seen anymore.
(In reply to comment #9)
> I don't have Enigmail add-on installed and I still see the problem.
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6pre) Gecko/20091110
> Shredder/3.0pre

Do you use any add-ons or themes ?
(In reply to comment #11)
> 
> Do you use any add-ons or themes ?

Currently:
- CustomButtonsĀ²
- nntpthreads

The remaining add-ons are disabled due to incompatibilities with Shredder.
Daniel can you disable bot of these and tell us if the issue is still present . I do believe this is a addons issue.
I tried with "thunderbird -safe-mode" and the problem still exists.
I disabled all add-ons and the problem still exists.

I don't know if this is of any help...this is the output of "Process Monitor" in case of "save as draft" succeeds.

> 	RegOpenKey	HKLM\Software\Microsoft\Windows\CurrentVersion	SUCCESS	Desired Access: Read
> 	RegOpenKey	HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Software\Microsoft\Windows\CurrentVersion	NAME NOT FOUND	Desired Access: Read
> 	RegQueryValue	HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\MediaPath	SUCCESS	Type: REG_SZ, Length: 34, Data: C:\WINDOWS\Media
> 	RegCloseKey	HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion	SUCCESS	
> 	QueryOpen	C:\WINDOWS\system32\msimtf.dll	SUCCESS	CreationTime: 31.12.1979 23:00:00, LastAccessTime: 12.11.2009 21:12:22, LastWriteTime: 14.04.2008 03:22:17, ChangeTime: 14.05.2009 21:51:55, AllocationSize: 159.744, EndOfFile: 159.232, FileAttributes: A
> 	CreateFile	C:\WINDOWS\system32\msimtf.dll	SUCCESS	Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a, OpenResult: Opened
>	QueryStandardInformationFile	C:\WINDOWS\system32\msimtf.dll	SUCCESS	AllocationSize: 159.744, EndOfFile: 159.232, NumberOfLinks: 1, DeletePending: False, Directory: False
>	CloseFile	C:\WINDOWS\system32\msimtf.dll	SUCCESS	
>	RegQueryValue	HKLM\System\CurrentControlSet\Control\Nls\Locale\00000407	SUCCESS	Type: REG_SZ, Length: 4, Data: 1
>	RegQueryValue	HKLM\System\CurrentControlSet\Control\Nls\Language Groups\1	SUCCESS	Type: REG_SZ, Length: 4, Data: 1
>	RegQueryValue	HKLM\System\CurrentControlSet\Control\Nls\Locale\00000407	SUCCESS	Type: REG_SZ, Length: 4, Data: 1
>	RegQueryValue	HKLM\System\CurrentControlSet\Control\Nls\Language Groups\1	SUCCESS	Type: REG_SZ, Length: 4, Data: 1
>	QueryOpen	C:\Programme\Mozilla Thunderbird 3\chrome\messenger.jar	SUCCESS	CreationTime: 27.10.2009 21:40:29, LastAccessTime: 12.11.2009 21:12:07, LastWriteTime: 10.11.2009 20:37:19, ChangeTime: 10.11.2009 20:37:19, AllocationSize: 3.997.696, EndOfFile: 3.994.848, FileAttributes: A
>	CreateFile	C:\Programme\Mozilla Thunderbird 3\chrome\messenger.jar	SUCCESS	Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened
>  ReadFile	C:\Programme\Mozilla Thunderbird 3\chrome\messenger.jar	SUCCESS	Offset: 1.127.127, Length: 3.176
>	CloseFile	C:\Programme\Mozilla Thunderbird 3\chrome\messenger.jar	SUCCESS	
>	QueryOpen	C:\Dokumente und Einstellungen\Daniel\Lokale Einstellungen\Temp\nsemail.eml	NAME NOT FOUND	

If "save as draft" does not succeed (as reported in this bug), the last line of the log does not appear. In this case TB does not try to write nsemail.eml
I can still reproduce this using 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100216 Thunderbird/3.0.2

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389650
You need to log in before you can comment on or make changes to this bug.