Last Comment Bug 525628 - [Windows XP classic theme] Mouse hovering on "Other actions" button, resize message header height in some cases
: [Windows XP classic theme] Mouse hovering on "Other actions" button, resize m...
Status: RESOLVED FIXED
[STR in comment #3]
: polish, pp
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: 3.0
: x86 Windows XP
: -- trivial with 3 votes (vote)
: Thunderbird 13.0
Assigned To: dagger.bugzilla
:
Mentors:
: 526646 528564 539652 542776 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-31 05:43 PDT by [:Aureliano Buendía]
Modified: 2012-02-21 05:31 PST (History)
15 users (show)
davida: blocking‑thunderbird3-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase email (2.89 KB, application/octet-stream)
2009-10-31 05:43 PDT, [:Aureliano Buendía]
no flags Details
screenshot1 (1.54 MB, image/jpeg)
2009-10-31 05:46 PDT, [:Aureliano Buendía]
no flags Details
screenshot2 (121.72 KB, image/jpeg)
2009-10-31 05:48 PDT, [:Aureliano Buendía]
no flags Details
Screenshot showing 3-line case (10.83 KB, image/png)
2009-11-05 06:56 PST, rsx11m
no flags Details
Use 2px border on Windows Classic (831 bytes, patch)
2011-08-22 19:08 PDT, dagger.bugzilla
no flags Details | Diff | Splinter Review
Use 2px border on Windows Classic v2 (1.64 KB, patch)
2012-01-23 22:16 PST, dagger.bugzilla
bugs: review+
Details | Diff | Splinter Review

Description [:Aureliano Buendía] 2009-10-31 05:43:49 PDT
Created attachment 409500 [details]
testcase email

It seems that happens when subject of the mail is wrap and in 2 line there is a "-".

I have my TB on Windows XP that use also lightning with today pane displayed.

In attached screenshot1 you can see as is the wrap statu of the mail testcase that I have attached: when mouse over the button, the message header pane is resize to minor height and the subject not is wrapped. When mouse over end the size is restored to original measure.

I can't provide a closely STR: but using email testcase attached in scenario descibed in screenshot1, you should reproduce (I hope) scenario descrived in screenshot2.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091031 Lightning/1.0pre Shredder/3.0pre ID:20091031032222

This bug should be block TB 3? Probably not but I set blocking? for more emphasys.
Comment 1 [:Aureliano Buendía] 2009-10-31 05:46:23 PDT
Created attachment 409501 [details]
screenshot1
Comment 2 [:Aureliano Buendía] 2009-10-31 05:48:21 PDT
Created attachment 409502 [details]
screenshot2

mumble: could be related to lightining?
Comment 3 [:Aureliano Buendía] 2009-10-31 08:18:39 PDT
Test also in safe-mode: not issue related to lightning.

I can provide a STR:

1. open TB in safe-mode and goto view "all folders";
2. open enail testcase attached here and edit as new as save it as draft;
3. goto in draft folder where the testcase is stored and enabled message pane view;
4. drag splitter between folders pane and other section until the subject ("[Bug 474701] gloda global search on toolbar, folder display refactoring mega-bug") of testcase is wrap in 2 lines: it is important that drag end immediately when subject is wrap.
5. now overing with the mouse on button and you can see screenshot2 scenario.
Comment 4 [:Aureliano Buendía] 2009-10-31 08:41:10 PDT
>It seems that happens when subject of the mail is wrap and in 2 
>line there is a "-".

This is false: the issue affect all long subject email.
Comment 5 Ben Bucksch (:BenB) 2009-10-31 09:16:47 PDT
Can't reproduce (Linux).
Comment 6 [:Aureliano Buendía] 2009-10-31 10:55:49 PDT
(In reply to comment #5)
> Can't reproduce (Linux).
Confirmed: can't reproduce on ubuntu 9.10... it seems only windows related!
Comment 7 Jim Porter (:squib) 2009-10-31 22:25:10 PDT
You're using the Classic theme, right? The size of the button border is slightly smaller in Classic than Luna/etc, and the CSS for the "other actions" button sets the border to 3px (the Luna size), and when you mouse over it, the border gets forced to be 2px by way of XUL. There's another bug that mentions this, but I can't find it.
Comment 8 [:Aureliano Buendía] 2009-11-01 01:03:41 PDT
Yes it is Jim: it seems to affect only windows xp classic theme and not luna theme.
Comment 9 Andreas Nilsson (:andreasn) 2009-11-03 01:30:33 PST
seems like my area
Comment 10 David Ascher (:davida) 2009-11-03 09:10:29 PST
Annoying, but not blocking.
Comment 11 rsx11m 2009-11-05 06:54:21 PST
*** Bug 526646 has been marked as a duplicate of this bug. ***
Comment 12 rsx11m 2009-11-05 06:56:51 PST
Created attachment 410498 [details]
Screenshot showing 3-line case

I'm reposting this from bug 526646 comment #1 to have all the cases in one place. As you can see, the splitter and message move up by 2px when hovering, and the "other actions" label moves up 1px and to the right 1px. The latter would support comment #7, meaning the button border is loosing 1px when the border is shown on hovering.

In contrast to the original description here and STR in comment #3, I do *not* see this in cases where the subject line wraps, hovering over the button retains the current header-pane height and wrapping status.

I can also confirm comment #6, no issue with the gnomestripe theme on KDE 3.5.
Comment 13 rsx11m 2009-11-05 09:25:28 PST
> In attached screenshot1 you can see as is the wrap statu of the mail testcase
> that I have attached: when mouse over the button, the message header pane is
> resize to minor height and the subject not is wrapped.

I think I have an explanation for the wrapping/no-wrapping case here. The width of the subject box is limited by the button box, thus the "mega-wrap" goes into the next line. When hovering over the "other actions" button, it shrinks by 2px in width, thus allowing the subject box to expand by 2px. Coincidentally, the subject now fits into a single line and is no longer wrapped.

Aureliano, if you increase or decrease the width of your window by more than 2px you should see the wrapping either disappear or present in both states.
Comment 14 [:Aureliano Buendía] 2009-11-05 09:31:37 PST
(In reply to comment #13)
> Aureliano, if you increase or decrease the width of your window by more than
> 2px you should see the wrapping either disappear or present in both states.

Yes it is: in comment #3 I says:
> it is important that drag end immediately when subject is wrap.
You have right this "immediately" is 2 px.
Comment 15 rsx11m 2009-11-05 10:12:18 PST
Ok, now I understand your steps to reproduce better. Thus, it's all indeed caused by the button shrinking when it gets a border with the Classic theme.

To avoid that, would it be possible to put a box around the menu button and force that box to have a specific height rather than the button itself?
Comment 16 Jim Porter (:squib) 2009-11-05 10:49:42 PST
Width is also an issue, which will be dependent on localization, etc. One solution would be to put the current button in a deck with an invisible duplicate button behind it (always using the moused-over style), and then just center the visible button. Then we don't have to worry about border size at all.
Comment 17 Ben Bucksch (:BenB) 2009-11-06 05:29:44 PST
Things should not change their size on hover. Reason is that it would exactly cause things like this - you have the same problem on the web.
Solution is to make sure that the hover state has the exact same size as the non-hover state, e.g. by not adding or removing borders.
Comment 18 rsx11m 2009-11-13 17:34:01 PST
*** Bug 528564 has been marked as a duplicate of this bug. ***
Comment 19 Markus Fischer 2009-12-15 11:05:40 PST
Experiencing the same issue here, classic theme. Can't find a relation to long subject lines.
Comment 20 [:Aureliano Buendía] 2010-01-14 11:35:49 PST
*** Bug 539652 has been marked as a duplicate of this bug. ***
Comment 21 Ludovic Hirlimann [:Usul] 2010-01-31 02:33:51 PST
*** Bug 542776 has been marked as a duplicate of this bug. ***
Comment 22 Ludovic Hirlimann [:Usul] 2010-01-31 02:34:32 PST
A solution is to install https://addons.mozilla.org/de/thunderbird/addon/13564 .
Comment 23 denis.barmenkov 2010-01-31 02:59:29 PST
(In reply to comment #22)
> A solution is to install https://addons.mozilla.org/de/thunderbird/addon/13564
> .

It is not true: solution is a good working TB.
Comment 24 Ben Bucksch (:BenB) 2010-01-31 05:20:00 PST
Tsk meant "workaround", not "solution". (He's not a native english speaker, so be easy with him.)
Comment 25 denis.barmenkov 2010-01-31 05:24:30 PST
(In reply to comment #24)
> Tsk meant "workaround", not "solution". (He's not a native english speaker, so
> be easy with him.)

Thank you for explanation.
I'm not English speaker too :).
Comment 26 Michael Venables 2010-02-03 13:02:11 PST
I've been battling this bug for awhile and have some additional info to contribute. The info already posted points to XP running with the classic UI -- which was the one element I couldn't pin down.

What I noticed doesn't have anything to do with the length of the message subject, but rather the number of addressees. If there's only one addressee, the message header panel shrinks when the "other actions" button is "painted in" on hover. If there is more than one addressee -- i.e. two or more addressee lines -- the problem does not occur.
Comment 27 rsx11m 2010-02-03 13:08:00 PST
(In reply to comment #22)
> A [workaround] is to install https://addons.mozilla.org/thunderbird/addon/13564

Apparently herb has solved the problem by moving the "other actions" into the header-pane toolbar with all the other buttons. While that's an idea, it would increase issues with narrow windows and the buttons running into the "from:" header filed (bug 520249). So that wouldn't work with its current position.
Comment 28 Ludovic Hirlimann [:Usul] 2010-11-25 22:16:29 PST
Mass move to the new theme component.
Comment 29 dagger.bugzilla 2011-08-22 19:08:03 PDT
Created attachment 555013 [details] [diff] [review]
Use 2px border on Windows Classic

I'd say the best way to fix this is to make the button look like a button, rather than try to give it a custom appearance and then be surprised when we stuff it up.

But failing that, here's a patch that sets the border to 2px instead of 3px, preventing the button size from changing on mouse-over under :-moz-system-metric(windows-classic).
Comment 30 Andreas Nilsson (:andreasn) 2012-01-17 08:28:43 PST
I could not get this patch to function properly on my Win7 box. Adding -moz-appearance: none; helped some, but I suspect there are some other properties interfering here.
Comment 31 dagger.bugzilla 2012-01-23 22:16:34 PST
Created attachment 590996 [details] [diff] [review]
Use 2px border on Windows Classic v2

Ah, it looks like Thunderbird uses messageHeader.css from skin/classic/aero/ on Windows 7, even when Aero is disabled. (It's possible to trick it into not doing that by running under compatibility mode: Right click the Thunderbird shortcut > Properties > Compatibility > Run in compatibility mode for Windows XP.)

This patch places the rule in the aero version of messageHeader.css too.
Comment 32 Andreas Nilsson (:andreasn) 2012-01-24 06:59:02 PST
Comment on attachment 590996 [details] [diff] [review]
Use 2px border on Windows Classic v2

Aha, that did the trick!
review+!
Comment 33 Mark Banner (:standard8) 2012-02-21 05:31:44 PST
Checked in: http://hg.mozilla.org/comm-central/rev/81005ca68455

Note You need to log in before you can comment on or make changes to this bug.