Status

task
--
major
VERIFIED FIXED
10 years ago
5 years ago

People

(Reporter: sheppy, Assigned: oremj)

Tracking

Details

()

We need a test install of MDC for us to pre-test new installs and updates for MindTouch before throwing them on the live MDC site. This needs to closely duplicate the real MDC in terms of configuration for accurate testing, especially since many of the problems we have are caused specifically by multi-hosting bugs we're trying to get quashed.
Assignee: server-ops → jeremy.orem+bugs
Worked on this today and then puppet hosed my vms, so I had to rebuild. I'm expecting good things this morning!
Finally done. Right now it is running the same version of dekiwiki as developer.mozilla.org. Once we verify the staging set doesn't have any bugs I'll update dekiwiki.

https://developer-stage.mozilla.org/En
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
OK, something's missing, since our custom toolbar ("MDC") is missing. Are we using a duplicate of the LocalSettings.php file, and do we have our custom plugins installed?
Search doesn't seem to be working at all, either.

https://developer.mozilla.org/Special:Search?search=add-on&type=fulltext&go=Search yields results on prod, but not staging:

https://developer-stage.mozilla.org/Special:Search?search=add-ons&type=fulltext&go=Search
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
That's because the search index isn't built yet. Be patient on that one. :)
oremj, can you check to see if the index rebuild is actually running?

I'm talking to MindTouch now about the toolbar thing.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
I forgot how to check, but I do see:
ls /mnt/netapp/developer-stage.mozilla.org-dekiwiki/lucene/developer-stage.mozilla.org/
_13.cfs  _1n.cfs  _27.cfs  _2r.cfs  _3b.cfs  _3v.cfs  _4f.cfs  _4z.cfs  _59.cfs  deletable  _j.cfs  segments
Roy borked the server while trying to figure out the problem. Please restart the Deki hosts.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Done.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
The toolbar still doesn't work; reports error "The toolbar set 'MDC' does not exist." So we're still missing something. Did our customized configuration files for FCKeditor get installed?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
hmm, maybe the symlink is bad... Checking.
Fixed now?
Nope.

Does our LocalSettings.php file match the one from the old server exactly?
Hm, I see the toolbar set is correctly set to "MDC" in there... and the editor settings show the "MDC" toolbar set. I'm confused. Roy?
Still looking into it - passed by it last night but couldn't see anything obv.
On the server, can you ensure the /skins/common/cache/ directory can be writeable by Apache? (You can also wipe out all cache-* files).
It was:
drwxr-xr-x  2 dekiwiki apache  4096 Nov  5 07:44 cache


Changed to:

drwxrwxr-x  2 dekiwiki apache  4096 Nov  5 07:44 cache
The directory didn't have any files in it before. NOw it seems to be populating.
Thanks a bunch, Jeremy. Looks like the editor is loading the MDC toolbar now.
Yes, with this, it looks like we're ready to test the upgrade to 9.08.1.

Jeremy, do you think we should do the reCAPTCHA plugin install at the same time, or separately? See bug 521793.
Let's do 9.08.1 first. I'll be back in a little more than 1 hour to do that.
Closing this out and continuing in bug 525241.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Blocks: 525241
Blocks: 521793
Verified FIXED on https://developer-stage.mozilla.org/En; we'll be testing this next week, over in bug 525241.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.