Closed Bug 526473 Opened 12 years ago Closed 12 years ago

Global Search Results: Can't filter using people/accounts/folders etc

Categories

(Thunderbird :: Search, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: Usul, Assigned: bwinton)

References

Details

(Keywords: regression, Whiteboard: [no l10n impact])

Attachments

(1 file)

1) Search
2) Select a person from the people's list
3) Use must involve

Results
No filtering is being done. Nothing in Error console.

Expected results
A filter is applied on the results
Flags: blocking-thunderbird3?
Assignee: nobody → bwinton
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0rc1
I see this for accounts, folders as well.
Summary: Can't filter using people → Global Search Results: Can't filter using people/accounts/folders etc
So, it looks like the onclick isn't firing for some reason…
I can't wait to find out what that reason is.
Status: NEW → ASSIGNED
I still don't really know why the onclick wasn't working, but the onmouseup seems to work, so let's go with it.
Attachment #410260 - Flags: review?(bugzilla)
Whiteboard: [patch up, needs r standard8]
Whiteboard: [patch up, needs r standard8] → [no l10n impact][patch up, needs r standard8]
Attachment #410260 - Flags: review?(bugzilla) → review+
Whiteboard: [no l10n impact][patch up, needs r standard8] → [no l10n impact][ready to land]
Landed as:
http://hg.mozilla.org/releases/comm-1.9.1/rev/4d55d21ba930
http://hg.mozilla.org/comm-central/rev/71838bfcdc81

Thanks,
Blake.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][ready to land] → [no l10n impact]
Flags: in-testsuite-
Actually, mozmill can simulate mouse clicks, so in theory we could test this.
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.