a MAPI problem with sending emails with (through) Irfanview after SM 2.0 upgrade

NEW
Unassigned

Status

SeaMonkey
MailNews: General
9 years ago
7 years ago

People

(Reporter: zetka, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

In the known program Irfanview there is a email plugin, which can use by use of MAPI send directly pictures to the SM mail client, it worked with SM 1.1.18. After upgrading to SM 2.0 this does not work any more, there is an error message (from XP), that there is NO default email client, although it is in SM preferences stated, that SM is default for mail. In the forum:
http://en.irfanview-forum.de/vb/showthread.php?t=4945
somebody had the similar problem with Thunderbird, but solved it by use of windows settings of default program configuration (see the pic there) to direct the emails to the Thunderbird. The problem is, that in the Windows settings there is no other entry for other mail client setting except "Microsoft Office Outlook" or "Outlook Express", the SM has not given its entry there. It is interesting, that for browsers there is Firefox (although I use Sea Monkey). I am not able to test it, what gave there the older SM.


Reproducible: Always

Steps to Reproduce:
1. try to use MAPI 
2. send something 
3. get Windows error that there is no default email client or client could not fulfill the request...
Actual Results:  
as above

Expected Results:  
to be able to sent through the  MAPI plugin something from external application (Irfanview) to SM. I have to stress again, that it worked without problem up to SM 1.1.18.
(Reporter)

Comment 1

9 years ago
Maybe it seems that it is common problem, that the Sea Monkey identifies itself as browser Firefox, but nothing for mail client and Windows XP are not able to send the things correctly?
SM doesn't itself identify as Firefox.
Please set SM as default via edit\preferences\Mail&newsgroups (main tab).
(Reporter)

Comment 3

9 years ago
It was done so in the SM , but it does not help. Maybe the entry of the firefox persisted from some old installation of the firefox. There must be something different done in comparsion to SM 1.1.18, because it worked before.
(Reporter)

Comment 4

9 years ago
Maybe this is interesting, that in the menu you pointed out the Mail and Feeds button could not be pressed, they are grey, the news button (which I do not use) is black and could be pressed. I suppose that if both buttons are grey, they are pressed and active. Am I right?
You run SM under an Account with admin privileges ?
Can you tyr to set IE and outlook as default and try it again in SM to switch back ?
(Reporter)

Comment 6

9 years ago
Yes, I run the SM with administrator privileges on XPs. I have tested your comment #5 on two different computers. After doing that a new entry in XP settings appeared for SeaMonkey entry. In case I choose it manually in the configuration, the Irfan email plugin can successfully use the SM email client, no errors after that.
Thanks for a usable solution. It is a question, but there must be something missing during the SM install, because on two different PCs the behavior was the same and SM install did not give its entry to this table automatically.

Concerning the Firefox mentioned, it was my fault, I have found old installation of the Firefox, after uninstall the entry disappeared.

But there is no entry for SM as a browser in this table.
By the way after proceeding the changes in the last procedures I have lost the possibility to use GoogleDesktop search integrated to SM, although I have successfully bring it to life few days ago for SM 2.0.  The GoogleDesktop  starts again IE, although the Mozilla files were correctly copied and it worked before and in the table the browser is set to default, not IE. I think that SM have to be more violent to the system to state itself as a default browser, otherwise the IE would not be started.
But maybe this is a theme for a new bug.
Regards,
Version: unspecified → SeaMonkey 2.0 Branch

Comment 7

8 years ago
I can confirm it with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3

-->> NEW
Status: UNCONFIRMED → NEW
Depends on: 26201
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.