Can't "send-to" (MAPI) using Seamonkey and Thunderbird X86_64

NEW
Unassigned

Status

MailNews Core
Simple MAPI
--
major
10 years ago
2 months ago

People

(Reporter: Michael Baffoni, Unassigned)

Tracking

(Blocks: 2 bugs, {64bit})

Trunk
x86_64
All
64bit
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
I installed Windows XP 64-bit, and I've lost the ability to use MAPI hand-off to Seamonkey (SeaMonkey 1.1.4 Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4) and Thunderbird version 2.0.0.6 (20070728).

Steps to recreate:
1)Install Thunderbird or Seamonkey on a Windows XP 64bit machine:
2) Set either application as the default mail client (e.g. within the client, or control panels/Internet Options/programs/default mail client).
3) right-click on a file, select send-to->mail recipient
or
Open an office application, open a new file, attempt to find "Send-to->mail recipient".

Actual results: In the first case, there is no action - no email client comes up, nor does a compose window; in the second case, there is no option to do the send-to because it can't find a MAPI client.

Expected results: a new compose window should come up with the file attached.
Component: General → MailNews: Simple MAPI
Product: Thunderbird → Core
QA Contact: general → simple-mapi
Version: 2.0 → 1.8 Branch

Comment 1

10 years ago
Xref bug 390331.

Comment 2

9 years ago
Any chance anyone could have a quick look at this one? I've a client who is seeing this exact behaviour with Windows XP 64-bit and Thunderbird 2.0.0.16 (32-bit). I'll try an unoffical 64-bit Thunderbird in the meantime, and see if that fixes the problem.
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
(Reporter)

Comment 3

9 years ago
BTW, I'm still having this problem with thunderbird 3b2Pre.
per sid0 "the problem is probably that the xp64 explorer can't load our 32-bit proxy. the Vista explorer handles it by doing it out of proc (IIRC)"

sid0, who was the other person recently working integration issues - Dossy?
Hardware: x86 → x86_64
cc some XP users

does this still exist in current thunderbird versions?
and, what is/should be the precise relationship of bug 390331?
(Reporter)

Comment 6

5 years ago
I don't use seamonkey any more.  We started putting this into the registry to fix other MAPI issues, it may have fixed this as well:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem]
"MAPI"="1"
"CMC"="1"
"CMCDLLNAME"="Mapi.dll"
"CMCDLLNAME32"="Mapi32.dll"
"MAPIX"="1"
"MAPI"="1"
"MAPIXVER"="1.0.0.1"
"OLEMessaging"="1"

If no one else is seeing this problem, this is a WFM issue.
I can confirm this issue on Windows XP 32-bit version.

Updated

4 years ago
Duplicate of this bug: 809504

Comment 9

4 years ago
Confirming Windows 7 X64  So updating os and branch as it is extant on trunk.  TB21a

Note Michael Baffanis suggested registry mods made the crash take longer, but that is all.

Crash reporter does not appear. Confirming Weasley Hardmans observations in bug 809504
OS: Windows XP → All
Version: 1.8 Branch → Trunk

Updated

4 years ago
Summary: Can't "send-to" (MAPI) using Seamonkey 1.1.4 and Thunderbird 2.0.0.6 → Can't "send-to" (MAPI) using Seamonkey and Thunderbird X86_64

Updated

4 years ago
Blocks: 471090
Blocks: 482756

Updated

2 years ago
See Also: → bug 1175598
Blocks: 634233
No longer blocks: 471090
Duplicate of this bug: 835087

Updated

a year ago
See Also: bug 1175598

Updated

a year ago
Duplicate of this bug: 1175598

Comment 12

8 months ago
We learned in bug 1308813 comment #0 that
  HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird\DLLPath
needs to be set to
  C:\mozilla-source\comm-central\obj-x86_64-pc-mingw32\mailnews\mapi\mapiDLL\mozMapi32.dll
to debug this.

So I did that. "Send to > Mail recipient" worked immediately. However, not the home-compiled version was started, but the my Daily which I have installed in C:\Program Files\Mozilla Thunderbird 52.

I changed the registry key back to C:\Program Files\Mozilla Thunderbird 52\mozMapi32_InUse.dll and lo and behold, the "send to" still works.

Next, I set the registry value to
C:\Program Files (x86)\Mozilla Thunderbird 50\mozMapi32_InUse.dll
That DLL is from the x86 TB 50 beta I have installed. "Send to" still works and TB 50 beta was started.

So back to:
C:\Program Files\Mozilla Thunderbird 52\mozMapi32_InUse.dll
and it still works starting x64 TB 52 Daily.

In short: The crash I had initially has gone away.

My wild guess would be: I have x86 and x64 versions on the machine. Fiddling with the registry value seemed to wake up Windows and now I simply can't make it fail any more.

Richard, can you check this:
Set HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird\DLLPath to whatever it was but without the "_InUse", so in my case:
C:\Program Files\Mozilla Thunderbird 52\mozMapi32.dll
That DLL also exists. Try the "Send to". Then change it back, try again.
Or append an "x", so:
C:\Program Files\Mozilla Thunderbird 52\mozMapi32_InUse.dllx.
Try "Send to", you get an error, then remove the "x" again.

I think there is a very subtle problem. I'd be interested to know what happens if you install an x64 TB on a fresh install of Windows.
Flags: needinfo?(richard.marti)

Comment 13

8 months ago
Rainer, you can try this too.
Flags: needinfo?(RainerBielefeldNG)
Still crashes here. I also tried to use the path to my self-built 64 bit TB and started this build, and it crashed. Restoring the path let also crash my 64 bit Daily. Here your proposal didn't help.
Flags: needinfo?(richard.marti)

Comment 15

8 months ago
I've come to the conclusion that this is a Windows problem. I started my Windows 10 laptop. "Send to" did nothing. I checked the default programs, Daily was the default program. I chose it again. Suddenly "Send to" started working. It starts the x64 version installed on the laptop. No crash.

This bug here shouldn't stop us shipping TB as 64bit version. If we get more reports, we may be able to dig deeper into it. I can't reproduce the crash, so I don't know what else to try. Richard, you just have to reinstall Windows ;-)

Comment 16

8 months ago
(In reply to Jorg K (GMT+2) from comment #13)
This Bug had a strange metamorphosis from "does not work" to "Crashes" 
Keyword is 64bit, Comment 7 confirms something with 32-bit ...

I already did all tests I can do easily in "Bug 1175598 - 64Bit: Impossible to make Mail/News default application for "send from WIN Explorer", "Send document (as PDF)" ...": g1) 64Bit build problem  --   h2) Send to email recipient from WIN Files Explorer: will crash Thunderbird.
I will try to reproduce your registry results, later.
Flags: needinfo?(RainerBielefeldNG)

Comment 17

6 months ago
It happened to me again. I did:
  Right-click -> Send to > Mail recipient
and it crashed. I changed
  HKLM\SOFTWARE\Clients\Mail\Mozilla Thunderbird\DLLPath
to
  C:\mozilla-source\comm-central\obj-x86_64-pc-mingw32\mailnews\mapi\mapiDLL\mozMapi32.dll
to debug this and it became good, however, not my debug build started but instead my 64bit Daily.

I'll have to look into how to get the local debug build started.

Comment 18

6 months ago
OK, for the record, this registry file will do it:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{29F458BE-8866-11D5-A3DD-00B0D0F3BAA7}\LocalServer32]
""="\"C:\\mozilla-source\\comm-central\\obj-x86_64-pc-mingw32\\dist\\bin\\thunderbird.exe\" /MAPIStartup"
(or course you need to change the path to your build)

Information can be found here:
https://dxr.mozilla.org/comm-central/rev/b020cffa188fac078bff74c9e19c98b044ea4173/mail/installer/windows/nsis/shared.nsh#307

Comment 19

6 months ago
Created attachment 8822226 [details]
Send-to--Mail-recipient-crash.txt

With these two registry keys set:

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
@="Mozilla Thunderbird"
"DLLPath"="C:\\mozilla-source\\comm-central\\obj-x86_64-pc-mingw32\\mailnews\\mapi\\mapiDLL\\mozMapi32.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{29F458BE-8866-11D5-A3DD-00B0D0F3BAA7}\LocalServer32]
""="\"C:\\mozilla-source\\comm-central\\obj-x86_64-pc-mingw32\\dist\\bin\\thunderbird.exe\" /MAPIStartup"

I get |Sent to > Mail recipient| to start my debug build and at times it crashes. Attached a stack.

So it crashes in nsAppShell::ProcessNextNativeEvent() inside ::DispatchMessageW(&msg):
https://dxr.mozilla.org/mozilla-central/rev/d7b6af32811bddcec10a47d24bd455a1ec1836fc/widget/windows/nsAppShell.cpp#375

I have no idea how to debug this further, so let's see who can help.

I'll try Jim and Aaron.
Flags: needinfo?(jmathies)
Flags: needinfo?(aklotz)
I'm to busy firefighting right now to look at this, sorry.
Flags: needinfo?(aklotz)

Comment 21

5 months ago
(In reply to Jorg K (GMT+1) from comment #19)
> Created attachment 8822226 [details]
> Send-to--Mail-recipient-crash.txt
> 
> With these two registry keys set:
> 
> [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
> @="Mozilla Thunderbird"
> "DLLPath"="C:\\mozilla-source\\comm-central\\obj-x86_64-pc-
> mingw32\\mailnews\\mapi\\mapiDLL\\mozMapi32.dll"
> 
> [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{29F458BE-8866-11D5-A3DD-
> 00B0D0F3BAA7}\LocalServer32]
> ""="\"C:\\mozilla-source\\comm-central\\obj-x86_64-pc-
> mingw32\\dist\\bin\\thunderbird.exe\" /MAPIStartup"
> 
> I get |Sent to > Mail recipient| to start my debug build and at times it
> crashes. Attached a stack.
> 
> So it crashes in nsAppShell::ProcessNextNativeEvent() inside
> ::DispatchMessageW(&msg):
> https://dxr.mozilla.org/mozilla-central/rev/
> d7b6af32811bddcec10a47d24bd455a1ec1836fc/widget/windows/nsAppShell.cpp#375
> 
> I have no idea how to debug this further, so let's see who can help.

There should be more to that stack unless the main thread is off servicing something in com.. and even then there should be something on the stack above dispatch.

Generally I know nothing about this mapi dll stuff. You want to track down someone who has worked with it. I haven't.
Flags: needinfo?(jmathies)
You need to log in before you can comment on or make changes to this bug.