Events with the same start time are not displayed in 1/2 proportion

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
9 years ago
9 years ago

People

(Reporter: damian.publicemail, Assigned: mmecca)

Tracking

({regression})

unspecified
regression
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [not needed beta][no l10n impact])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1.5pre) Gecko/20091025 Calendar/1.0pre

If two events start with the same start time then both should be visible.

Reproducible: Always

Steps to Reproduce:
1. Create event with short title and start date =10AM.
2. Create second event (as copied below) with the same start time.
Actual Results:  
Events are not dispalyed in 1:1 ratio but rather 1:9

Expected Results:  
Events are displayed in the same proportion.

event:

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Belgrade
X-LIC-LOCATION:Europe/Belgrade
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20091105T231346Z
LAST-MODIFIED:20091105T231458Z
DTSTAMP:20091105T231458Z
UID:dfaa142d-4260-4dac-9596-283facd2119f
SUMMARY:bug https://bugzilla.mozilla.org/show_bug.cgi?id=1
DTSTART;TZID=Europe/Belgrade:20090224T171500
DTEND;TZID=Europe/Belgrade:20090224T181500
SEQUENCE:4
X-MOZ-GENERATION:5
END:VEVENT
END:VCALENDAR
(Reporter)

Comment 1

9 years ago
Created attachment 410648 [details]
screenshot
Confirmed Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4.
Flags: blocking-calendar1.0?
OS: Windows XP → All
Hardware: x86 → All
I suspect this is a regression, but can't check right now.
Keywords: regression, regressionwindow-wanted
Sounds like a blocker to me. It would be good to find a regression window on this one. Its unfortunate, but I think we should live with this for the beta.
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact]
(Assignee)

Comment 5

9 years ago
This may be due to the column widths not being set explicitly when used with flex, causing a difference in column widths proportional to the title lengths with long, unbroken text. This seems to be fixed by the proposed patch to bug 460030.
(Assignee)

Updated

9 years ago
Depends on: 460030
(Assignee)

Updated

9 years ago
Assignee: nobody → matthew.mecca
Marking WFM, based on previous comment and the fact that that bug has been checked in.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.