Closed Bug 526919 Opened 11 years ago Closed 11 years ago

Lightweight theme notification bar hides when loading new page

Categories

(Firefox :: General, defect)

3.6 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3.7a1
Tracking Status
status1.9.2 --- beta4-fixed

People

(Reporter: rdoherty, Assigned: dao)

References

Details

Attachments

(1 file)

STR:
Discovered in nightlies.

1) Add sm-personas01.mozilla.org to the add-ons whitelist
2) Visit http://sm-personas01.mozilla.org/en-US/external/mozilla/firstrun.php
3) Click on any persona thumbnail
4) Persona is applied, the notification bar pops up, but then immediately hides because a link was clicked.

Expected behaviour:
The notification bar stays visible for 5-10 seconds, then hides, regardless of user behavior.
Blocks: 511104
I agree that an instantly appearing-and-disappearing notification bar is not the desired effect. It's happening because we fire the install event and then immediately navigate off-page, which dismisses the notification bar.

I wouldn't want the notification bar to be on a straight 5-10s timer, because it's generally bad a11y practice to have UI on timers, but one possible solution could be to have a *minimum* time before auto-dismissal on navigation can happen. I don't know if we do that on any existing notification bars, would like to get Dao's sense of how ugly that would be.

A simpler option would just be to bump the persistence of the notification one notch, right?

The other way to approach this, of course, is just to change the behaviour of iframe/getpersonas so that:

- on hover: everything works as before
- on click: instead of apply-then-navigate, we just do navigate, but we navigate to something like http://www.getpersonas.com/en-US/persona/48888?autoInstall=true which then immediately fires the install event.

The net experience there would be similar for users - clicking does take them to the page and apply the persona, but now the notification bar is present to support undo. On the downside, it probably takes longer to actually apply, since we need to wait for another page load, and it also has us changing the web experience. It also feels a little... odd.
I agree that 'fixing' this by changing the website would probably be faster/easier, but it is a roundabout method of avoiding this bug.
I think the password manager uses both persistence and a timer. We can do the same here.
Assignee: nobody → dao
OS: Mac OS X → All
Hardware: x86 → All
Attached patch patchSplinter Review
This allows one location change each for the pre- and post-install confirmation bars and makes sure the latter stays for at least 20 seconds.
Attachment #412206 - Flags: review?(dtownsend)
Attachment #412206 - Flags: review?(dtownsend) → review+
http://hg.mozilla.org/mozilla-central/rev/43a29d8d9a97
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Version: Trunk → 3.6 Branch
Attachment #412206 - Flags: approval1.9.2?
Attachment #412206 - Flags: approval1.9.2? → approval1.9.2+
You need to log in before you can comment on or make changes to this bug.