Closed Bug 526935 Opened 12 years ago Closed 6 years ago

crash deleting, archiving or junking a message [@ nsMsgDBView::NoteChange(unsigned int, int, int)] [@ nsMsgDBView::NoteChange]

Categories

(MailNews Core :: Backend, defect)

x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wsmwk, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

crash [@ nsMsgDBView::NoteChange(unsigned int, int, int)]  from crash-stats
ranking ~#82 for 3.0b4

First, and only, found in 3.0b4. So possible regression. Interestingly, all OS.
gloda search related?

bp-dd2d5700-dd3c-4ee3-8a62-31efa2090922
Crashed while delete email in search result

bp-b905d303-08d0-41e0-af26-301d12091024
Thunderbird is synchronizing some folders... I moved to mails into folder.. crash
0	thunderbird-bin	nsMsgDBView::NoteChange	 mailnews/base/src/nsMsgDBView.cpp:5739
1	thunderbird-bin	nsMsgXFViewThread::RemoveChildHdr	mailnews/base/src/nsMsgXFViewThread.cpp:346
2	thunderbird-bin	nsMsgSearchDBView::OnHdrDeleted	mailnews/base/src/nsMsgSearchDBView.cpp:257
3	thunderbird-bin	nsMsgDatabase::NotifyHdrDeletedAll	mailnews/db/msgdb/src/nsMsgDatabase.cpp:718
4	thunderbird-bin	nsMsgDatabase::DeleteHeader	mailnews/db/msgdb/src/nsMsgDatabase.cpp:1803
5	thunderbird-bin	nsMsgDatabase::DeleteMessages	mailnews/db/msgdb/src/nsMsgDatabase.cpp:1749
6	thunderbird-bin	nsImapMailFolder::CopyMessagesOffline	mailnews/imap/src/nsImapMailFolder.cpp:6976
7	thunderbird-bin	nsImapMailFolder::CopyMessages	mailnews/imap/src/nsImapMailFolder.cpp:7134
8	thunderbird-bin	nsMsgCopyService::DoNextCopy	mailnews/base/src/nsMsgCopyService.cpp:321
9	thunderbird-bin	nsMsgCopyService::DoCopy	mailnews/base/src/nsMsgCopyService.cpp:263
10	thunderbird-bin	nsMsgCopyService::CopyMessages	mailnews/base/src/nsMsgCopyService.cpp:524
still occurs, rank #98
bp-0bce7542-02a8-49c9-ae05-02d3e2110114  v3.1.7
comments all refer to deleting, archiving or junking a message

most often seen in virtual folders if this spot check is true in general - of 12 crashes, all but on 1 have nsMsgXFViewThread::RemoveChildHdr as frame 1. 

That exception is bp-f0d6898a-cdcb-4061-a617-29ae72110315  with nsMsgSearchDBView::OnHdrDeleted as frame 1 and comment of "i wanted to delete a mail as it was being displayed."

there is also a Mac signature of nsMsgDBView::NoteChange, in bp-e3ff6f94-7bff-430d-9053-15f9b2110303
EXC_BAD_ACCESS / 0x0000000d
0x0
0	XUL	nsMsgDBView::NoteChange	mailnews/base/src/nsMsgDBView.cpp:5790
1	XUL	nsMsgXFViewThread::RemoveChildHdr	mailnews/base/src/nsMsgXFViewThread.cpp:348
2	XUL	nsMsgSearchDBView::OnHdrDeleted	mailnews/base/src/nsMsgSearchDBView.cpp:268
3	XUL	nsMsgDatabase::NotifyHdrDeletedAll	mailnews/db/msgdb/src/nsMsgDatabase.cpp:839
4	XUL	nsMsgDatabase::DeleteHeader	mailnews/db/msgdb/src/nsMsgDatabase.cpp:1942
5	XUL	nsMsgDatabase::DeleteMessages	mailnews/db/msgdb/src/nsMsgDatabase.cpp:1885
Summary: crash [@ nsMsgDBView::NoteChange(unsigned int, int, int)] → crash deleting, archiving or junking a message [@ nsMsgDBView::NoteChange(unsigned int, int, int)] [@ nsMsgDBView::NoteChange]
per reporter of bp-9313cbce-00f8-44c2-b21a-35ef02110301 ...
was junking a message in virtual folder in v3.1.7. no crash if junking in a ral folder. And no crash in v3.1.9.  

if this is really a 3.0b4 regression, then fault should be with one of these bugs http://www.rumblingedge.com/2009/09/23/thunderbird-3-beta-4-released/
cherry picking from the list without thorough analysis:
- Bug 383584 - crashed while getting message (after rename a virtual folder) [@ VirtualFolderChangeListener::OnHdrAdded(nsIMsgDBHdr*, unsigned int, int, nsIDBChangeListener*)]
- Bug 510645 - File/Compact Folders tries to EXPUNGE IMAP folder of \Noselect and Virtual Folder
Depends on: 646168
Crash Signature: [@ nsMsgDBView::NoteChange(unsigned int, int, int)] [@ nsMsgDBView::NoteChange]
Crash Signature: [@ nsMsgDBView::NoteChange(unsigned int, int, int)] [@ nsMsgDBView::NoteChange] → [@ nsMsgDBView::NoteChange(unsigned int, int, int)] [@ nsMsgDBView::NoteChange]
Makota Kato, see bug 646168 comment 1

#36 crash if v7
Keywords: topcrash
Crash happened for me with v 8.0 and 9.01 when archiving from unified inbox:

bp-ecc8a977-695e-46e8-86f4-6ac3b2111129
bp-76caea42-fd5e-4921-b67e-284172120126
bp-5c0a3fb6-fc28-4b08-b1e3-991ea2120130
only #67 in version 11
Keywords: topcrash
bienvenu, here's another report related to unified view from the user of  bp-8e2b1932-5144-408c-888d-9ad932120327 

"Place replies in the folder of the message being replied to" turned on and often I see way too many copies of the message I replied to in the unified inbox (I reply to messages from the unified folder). They are "ghosts", in the sense that if I switch away from unified inbox and back again, the extra copies are gone. If for mistake I operate (delete, move, flag) on a "ghost message", then the crash is very likely to happen. I cannot say this for sure, but I think there is some kind of corruption happening because of my setup and the usage of unified folders. ... For example, just after I replied to you I could see my reply twice in the unified inbox, but after I switched to another folder and back in to unified inbox, the extra copy was gone. I think the crash relates to this behavior because it is very likely to happen when I see that duplication happening, even though the crash does not happen all the times I see a duplication (which by the way is very often)"
bp-36a003cf-644b-4f39-94fc-d970c2121221
related to bug 646168?
Flags: needinfo?(m_kato)
Hiro...

(In reply to Wayne Mery (:wsmwk) from comment #8)
> bp-36a003cf-644b-4f39-94fc-d970c2121221
> related to bug 646168 ??

#126 crash for version 17
Flags: needinfo?(hiikezoe)
No crashes with this signature after version 17.0.8
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(m_kato)
Flags: needinfo?(hiikezoe)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.