Last Comment Bug 526977 - Fonts are not readable if remote display to a machine with different endian
: Fonts are not readable if remote display to a machine with different endian
Status: RESOLVED DUPLICATE of bug 562746
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 OpenSolaris
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 562746
Blocks: 515192
  Show dependency treegraph
 
Reported: 2009-11-06 03:18 PST by Ginn Chen
Modified: 2010-08-18 03:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (221.87 KB, image/png)
2009-11-06 03:20 PST, Ginn Chen
no flags Details
patch for cairo (408 bytes, patch)
2009-11-10 03:09 PST, Ginn Chen
no flags Details | Diff | Splinter Review
patch for cairo (394 bytes, patch)
2009-11-10 03:11 PST, Ginn Chen
no flags Details | Diff | Splinter Review

Description Ginn Chen 2009-11-06 03:18:38 PST
This bug is reproducible with DISPLAY on Sun Ray client, XVR-600, XVR-1200.
xdpyinfo shows red, green, blue masks: 0xff, 0xff00, 0xff0000

It doesn't matter which machine Firefox is running on.
You can use "ssh -X" to start Firefox from another Solaris machine.
Comment 1 Ginn Chen 2009-11-06 03:20:48 PST
Created attachment 410755 [details]
screenshot
Comment 2 Ginn Chen 2009-11-06 04:49:37 PST
Caused by Bug 515192
Comment 3 Ginn Chen 2009-11-10 03:08:22 PST
git bisect shows the bad commit is

commit b5799e073e4e404aea277b7640eeee2120318823
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Jun 2 18:07:31 2009 +0100

    [xlib] Use bswap_32
    
    Byteswap the ARGB32 glyphs using bswap_32 instead of open-coding.


I think you should not use d++ in macro.
Comment 4 Ginn Chen 2009-11-10 03:09:10 PST
Created attachment 411388 [details] [diff] [review]
patch for cairo
Comment 5 Ginn Chen 2009-11-10 03:11:38 PST
Created attachment 411389 [details] [diff] [review]
patch for cairo
Comment 6 Ginn Chen 2009-11-19 08:06:56 PST
Actually, it happens if I remote display Firefox from SPARC to x86 machine, or from x86 to SPARC machine.
Nothing to do with xBGR.
Comment 7 Ginn Chen 2009-11-19 08:08:30 PST
Comment on attachment 411389 [details] [diff] [review]
patch for cairo

Vladimir, can you help commit it to cairo?
The patch is obvious.
Comment 8 Vladimir Vukicevic [:vlad] [:vladv] 2009-11-19 11:24:30 PST
Comment on attachment 411389 [details] [diff] [review]
patch for cairo

Redirecting to jeff
Comment 9 Jeff Muizelaar [:jrmuizel] 2009-11-23 08:47:26 PST
Comment on attachment 411389 [details] [diff] [review]
patch for cairo

Redirecting to Chris Wilson as he's the one that broke it.
Comment 10 Ginn Chen 2010-03-31 01:34:35 PDT
Comment on attachment 411389 [details] [diff] [review]
patch for cairo

This is now on cairo HEAD, can we commit it to mozilla-central now?
Comment 11 Jeff Muizelaar [:jrmuizel] 2010-03-31 15:05:55 PDT
Can this wait till the next cairo update? I'd rather not churn unless there's a good reason to.
Comment 12 Ginn Chen 2010-03-31 23:30:12 PDT
ok, I can wait.
Comment 13 Jeff Muizelaar [:jrmuizel] 2010-08-02 12:15:44 PDT
This was fixed in the last cairo merge.
Comment 14 Ginn Chen 2010-08-18 03:58:51 PDT
Apparently it was unfixed.

*** This bug has been marked as a duplicate of bug 562746 ***

Note You need to log in before you can comment on or make changes to this bug.