Listed add-on not mentioned in collection details page

VERIFIED FIXED in 5.3

Status

addons.mozilla.org Graveyard
Public Pages
P1
major
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

unspecified
x86
All

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
Created attachment 411064 [details]
screenshot-statistics in developer dashboard

steps to reproduce:
1.Log into your AMO account
2.Navigate to the details page of a listed add-on (https://preview.addons.mozilla.org/en-US/firefox/addon/43605)
3.From here,publish the listed add-on to an existing collection
4.Notice the publish_success message
5.navigate to the details page of the collection to which the listed add-on was published.

expected result:
listed add-on is one of the add-ons mentioned in the collection.


actual result:
collection details page does not mention the newly published listed add-on.

additional info:
Collections details page mentions that it contains 5 add-ons but lists only 4(5th one being the listed add-on)
Statistics in the developer hub mentions publishing of the listed add-on

screencast:http://screencast.com/t/2XW3sYzH7WKc
(Reporter)

Comment 1

9 years ago
Created attachment 411066 [details]
screenshot-addons in collection page
(Reporter)

Comment 2

9 years ago
Listed add-on is missing from the collection page even when creating a new collection.

STR:
Log in to AMO
Click on "create a collection"
Provide all relevant info
Add a listed add-on and submit the new collection

observed behavior:
In the newly created collection,number of add-ons is mentioned as "1" but no add-on is listed.

Updating the bug summary....
Severity: normal → major
Summary: Listed add-on not listed under Collections when published from add-on details page → Listed add-on not mentioned in collection details page
(Reporter)

Comment 3

9 years ago
Created attachment 411067 [details]
screenshot 3
(Reporter)

Comment 4

9 years ago
screencast: http://screencast.com/t/22n0zEFqK1p
(Assignee)

Comment 5

9 years ago
This is probably because listed add-ons aren't associated with any files.  Fixing this could possibly allow for personas in collections as well.
Being able to add these add-ons to collections was part of the original spec.
Priority: -- → P1
(Assignee)

Updated

9 years ago
Assignee: nobody → jbalogh
(Assignee)

Comment 7

9 years ago
Created attachment 411275 [details] [diff] [review]
adding another query for listed add-ons
Attachment #411275 - Flags: review?(clouserw)
Attachment #411275 - Flags: review?(clouserw) → review+
(Assignee)

Comment 8

9 years ago
r55732
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
Collection created after the fix do show the listed addons (https://preview.addons.mozilla.org/en-US/firefox/collection/68f2ef73-4e1b-4a21-ab6d-3c69cd7a47b2)
but older collections still do not show listed-addons , for e.g.
https://preview.addons.mozilla.org/en-US/firefox/collection/23a58c8d-bb4b-ccde-86c5-152e9130f922
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

9 years ago
Vish: The "he-he,ha-ha" add-on is in the sandbox, so it's not showing up on purpose.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Jeff: I made the addon 'Public', waited few minutes, still not showing up on the collections page. Reopening this bug...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

9 years ago
(In reply to comment #11)
> Jeff: I made the addon 'Public', waited few minutes, still not showing up on
> the collections page. Reopening this bug...

You made it Public, but it wasn't a Listed add-on anymore.  It didn't have any files or versions, so was rightly not shown.  I made it listed; it's there now.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Verified, FIXED.
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.