Sporadic CSS Rendering Error With a:hover Containing Formatted DIV Tags

RESOLVED DUPLICATE of bug 324875

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 324875
9 years ago
7 years ago

People

(Reporter: Achim, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Hi there,

i was unable to find a category like "rendering" or "gecko engine" so i am forced to report this bug under "general". the error is not clearly reproducible so it is hard for me to describe it. nevertheless, i will try to give an example:

CSS:
a.test div
{
    width:40px;
    height:30px;
    background:url(<img>) 0px 0px;
}

a.test:hover div
{
    width:40px;
    height:30px;
    background:url(<img>) 0px -30px;
}

HTML:
<a href="<url>" class="test"><div></div></a>

The rendering error occurs obviously for some "visited" links after reloading a page. It seems that especially div elements using the background-position to simulate a "hover"-effect nested within visited links cause the problem.

Reproducible: Sometimes

Steps to Reproduce:
1. set up a page with a scenario like the one above, make sure to use the same background image for the normal and the hovered state just changing the background-position
2. set up a large number of those <a>/<div> combinations
3. follow one of the links
4. navigate back to the page
5. if necessary, repeat the steps, the error is not always reproducible

Actual Results:  
sometimes only the text formatting fails, in some cases the whole element is not displayed at all. i am not sure if adding a "a.test:visited div" statement within the css- section is able to fix the problem, anyway i think it should not happen at all.

Expected Results:  
a statement like "a.classname div" without a pseudo-class should affect all matching elements regardless of an additional possible pseudo-class "hover" statement.

this bug seems to be platform independent, at least it led to problems on win xp & vista on 4 different clients with the current release of firefox (3.5.1).
(In reply to comment #0)
> i was unable to find a category like "rendering" or "gecko engine" so i am
> forced to report this bug under "general". the error is not clearly
> reproducible so it is hard for me to describe it. nevertheless, i will try to
> give an example:

They're in Core, not in Firefox.  And bugs filed in Firefox::General tend to get lost.



Do you have a URL showing the problem?  It doesn't seem like something we're going to see by just constructing a testcase based on that description.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout

Comment 2

7 years ago
(In reply to comment #1)
> Do you have a URL showing the problem?  It doesn't seem like something we're
> going to see by just constructing a testcase based on that description.

Actually it's just bug 324875.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324875
You need to log in before you can comment on or make changes to this bug.