Manual filters no longer are allowed on deferred-from servers

RESOLVED FIXED in Thunderbird 3.0rc1

Status

MailNews Core
Filters
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: rkent, Assigned: rkent)

Tracking

({fixed-seamonkey2.0.1, regression})

Trunk
Thunderbird 3.0rc1
fixed-seamonkey2.0.1, regression
Dependency tree / graph
Bug Flags:
in-moztrap ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
A critical piece of code was removed in bug 435804 that was needed to enable manual message filters to be run on filters defined on deferred-from POP3 servers. I believe this is an easy fix, and the problem is quite serious for someone who upgrades from TB2, and has a lot of manual filters defined.

STR:

1) Create a local POP3 account deferring to the Local Folders inbox.
2) In Message filters list dialog, select that filter.

Expected (and TB2) behavior: "Run Selected Filters on" is unhidden at bottom of dialog.

Actual behavior: "Run Selected Filters on" is disabled, and only appears when the user selects "Local Folders" (which is the workaround).

I've seen hints of something amiss here, but I only recently realized that this used to work in TB2, which got me looking for the regression. Still I could not find a dup, but I would not be surprised if there is one.

I will be trying to push this into TB3 final release somehow. Patch to follow very soon, after I test for possible ramifications.
(Assignee)

Updated

8 years ago
Assignee: nobody → kent
(Assignee)

Comment 1

8 years ago
Created attachment 411378 [details] [diff] [review]
Restore correction of msgFolder for deferred-from servers

This patch simply adds back the line of code that was in TB2, and was removed in the patch for bug 435804. I've tested it briefly and it works, but I want to think over a little whether anything might have changed that affects this. The code still exists in SeaMonkey and was only removed from Thunderbird during de-rdf, probably believing it was related to setting of uris.
I've seen this issue mentioned in several venues. And people do seem to love their manual filters. I agree we should try to take this for 3.0.

xref regressions since bug 435804 - https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=MailNews+Core&product=Thunderbird&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=regression&resolution=---&emailreporter1=1&emailtype1=substring&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=++2008-05-26&chfieldto=Now&chfield=[Bug+creation]&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=short_desc&type0-0-0=substring&value0-0-0=filter&field0-0-1=component&type0-0-1=substring&value0-0-1=filter&field1-0-0=short_desc&type1-0-0=nowordssubstr&value1-0-0=search

Comment 3

8 years ago
this looks like the right thing to do...
(Assignee)

Comment 4

8 years ago
Comment on attachment 411378 [details] [diff] [review]
Restore correction of msgFolder for deferred-from servers

I could not think of any new issues with this during my personal review, so I'm going for r+a. From a risk perspective, this is a tiny patch that simply adds back code that was inadvertently removed, so I think it is pretty low risk. The effects are also fairly localized. If we don't add this, then people who had used manual filters on POP3 accounts that are deferred (which I think was the default) will see them stop working, and there is no easy way to migrate them to Local Folders.
Attachment #411378 - Flags: review?(bienvenu)
Attachment #411378 - Flags: approval-thunderbird3?
Comment on attachment 411378 [details] [diff] [review]
Restore correction of msgFolder for deferred-from servers

r+a=dmose; thanks Kent!
Attachment #411378 - Flags: review?(bienvenu)
Attachment #411378 - Flags: review+
Attachment #411378 - Flags: approval-thunderbird3?
Attachment #411378 - Flags: approval-thunderbird3+

Updated

8 years ago
Whiteboard: [needs landing on trunk & 1.9.1]
comm-1.9.1 - changeset - 4336:713153647423 
comm-central - changeset - 4358:60be35e6f4cc 

Any reasons to keep this bug open ?

Comment 7

8 years ago
I don't think so - resolving fixed with target milestone of 3.0 rc1 - if I've done so in error, rkent can correct me.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> I don't think so - resolving fixed with target milestone of 3.0 rc1 - if I've
> done so in error, rkent can correct me.

Sorry, I started having troubles with my internet connection right after I landed the fix. Even had to drive to an internet cafe to make sure it landed without problems.

So yes this is now fixed.
Whiteboard: [needs landing on trunk & 1.9.1]
(Assignee)

Comment 9

8 years ago
Comment on attachment 411378 [details] [diff] [review]
Restore correction of msgFolder for deferred-from servers

Landed on trunk http://hg.mozilla.org/comm-central/rev/60be35e6f4cc

Landed on branch http://hg.mozilla.org/releases/comm-1.9.1/rev/713153647423
Flags: in-testsuite?
(Assignee)

Updated

8 years ago
Depends on: 527950

Updated

8 years ago
Keywords: fixed-seamonkey2.0.1
Flags: in-testsuite?
Flags: in-moztrap?
You need to log in before you can comment on or make changes to this bug.