Live Bookmarks do not load and reload/update

VERIFIED FIXED in Firefox 3.7a1

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: Antti Tervasmäki, Assigned: mak)

Tracking

({regression})

Trunk
Firefox 3.7a1
regression
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091109 Minefield/3.7a1pre Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091109 Minefield/3.7a1pre Firefox/3.5.5

Since 20091107 nighly live bookmarks do not load or update at all. 
They work by manually reloading but other that that nothing happens.

Reproducible: Always

Steps to Reproduce:
1.Start browser
2.
3.
Actual Results:  
See live bookmarks, they have not loaded, and do not update.

Expected Results:  
Updated live bookmarks.

Trunk nightly 20091106 works nightly 20091107 and after that fails.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
From hourly archives:

1257510448-20091106042728-f37a407b787a-firefox-3.7a1pre.en-US.win32 is OK

1257526697-20091106085817-84125ff8a317-firefox-3.7a1pre.en-US.win32 fails
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

8 years ago
based on the regrange, looks like it's me.
Assignee: nobody → mak77
Blocks: 526777
(Assignee)

Comment 4

8 years ago
Created attachment 411401 [details] [diff] [review]
patch v1.0

my bad for not having double tested this.
Unfortunatly we don't have a unit test for this, and making one is hard because we force a minimum re-check time of 1.5 minutes to avoid perf problems and servers overloads. So the test would take 2 minutes to run, providing a way to bypass this would get rid of our safe limits.
Attachment #411401 - Flags: review?(dietrich)
(Assignee)

Updated

8 years ago
Flags: in-testsuite-
Flags: in-litmus?
(Assignee)

Updated

8 years ago
Severity: normal → major
OS: Windows 7 → All
Hardware: x86_64 → All
Attachment #411401 - Flags: review?(dietrich) → review+
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/d6ad93f972f9
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
(Reporter)

Comment 6

8 years ago
Works Ok again! Thanks for quick fix!

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091112 Minefield/3.7a1pre Firefox/3.5.5 - Build ID: 20091112045818
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.