Annoying delay listing empty IMAP folders

RESOLVED DUPLICATE of bug 499069

Status

Thunderbird
Folder and Message Lists
--
trivial
RESOLVED DUPLICATE of bug 499069
9 years ago
9 years ago

People

(Reporter: Dennis Verspuij, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; GTB6; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.21022; .NET CLR 3.0.30729; .NET CLR 3.5.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Build Identifier: 3.0b4 (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2 Mnenhy/0.7.5.666)

When opening an empty IMAP folder the message list, together with the message pane when enabled, for just a split second shows the "home" page of the account (you know, the page when you click the root account folder in the folder pane with options: Read messages, Write a new message, etc.). This is an annoying flickering effect. Besides that it even seems to slow down the UI, opening a folder with messages is faster than one without.

The same happens when I open an IMAP folder I haven't opened before (no msf files present yet or something like that), so it might have something to do with it.

I do not see the effect when opening an empty POP/news account folder.

Reproducible: Always

Steps to Reproduce:
1. Open an IMAP folder without messages

Actual Results:  
- first the account "home" page is shown for a split second
- then the empty messages list is shown

Expected Results:  
Skip showing the account "home" page
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499069
You need to log in before you can comment on or make changes to this bug.