box-shadow causes artifacts on corners with border-radius

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
25 days ago

People

(Reporter: stream, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {testcase})

Trunk
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

10.62 KB, image/png
Details
1.84 KB, image/png
Details
958 bytes, text/html
Details
(Reporter)

Description

9 years ago
Created attachment 411428 [details]
testcase

When -moz-box-shadow is applied to element, there are artifacts from the background color on the rounded corners.

Without -moz-box-shadow everything looks fine.

I have used -moz-linear-gradient with the new syntax on trunk. The same result is visible with simple background-color, but with gradient the problem is more visible. The artifacts on all corners are with the first defined color, even when the gradient finishes with different color.
(Reporter)

Comment 1

9 years ago
Created attachment 411429 [details]
screenshot
(Reporter)

Updated

9 years ago
Blocks: 212633
You're talking about the faint red dots at the corners?

Almost certainly some kind of "seams" issue.
(Reporter)

Comment 3

9 years ago
Created attachment 411551 [details]
testcase2

Testcase with plain background-color and increased border-width. Artifacts are even more here.
(Reporter)

Comment 4

9 years ago
Created attachment 411553 [details]
screenshot2

The corners are compared with high zoom level, so you can see the exact difference. The inner and outer part of the radius is different.

Updated

9 years ago
Depends on: 466572

Updated

9 years ago
Blocks: 431176

Updated

8 years ago
Duplicate of this bug: 594868

Comment 6

7 years ago
Sounds like a duplicate of bug 466572. Though this issue was the first one I stumbled over searching for this problem, so probably 466572 should be marked as duplicate of this one.
(Reporter)

Comment 7

7 years ago
Created attachment 541312 [details]
updated testcase
Attachment #411428 - Attachment is obsolete: true
Attachment #411551 - Attachment is obsolete: true
(Reporter)

Updated

7 years ago
OS: Windows XP → All
Hardware: x86 → All
Attachment 541312 [details] is WFM using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 ID:20130116073211 with HWA on and off.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Duplicate of this bug: 538383
(Assignee)

Updated

25 days ago
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.