Experimental add-ons can be installed without checking checkbox

VERIFIED FIXED in 5.3

Status

defect
P2
blocker
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: jorgev, Assigned: rdoherty)

Tracking

unspecified
Bug Flags:
in-testsuite -
in-litmus -

Details

()

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

10 years ago
1) Log out of AMO.
2) Go to a page with experimental add-ons (https://addons.mozilla.org/en-US/firefox/addon/45725)
3) Click on the Add to Firefox button without clicking on the 'Allow me' checkbox.

The install dialog appears, when it shouldn't.
Yeah... we need to fix this ASAP
Severity: normal → blocker
Target Milestone: --- → 5.3
Assignee

Updated

10 years ago
Assignee: nobody → rdoherty
Assignee

Comment 2

10 years ago
Posted patch v1 (obsolete) — Splinter Review
Fix.
Attachment #411828 - Flags: review?(clouserw)
Assignee

Comment 3

10 years ago
Posted patch v2Splinter Review
v2 with less changes.
Attachment #411828 - Attachment is obsolete: true
Attachment #411832 - Flags: review?(clouserw)
Attachment #411828 - Flags: review?(clouserw)
Attachment #411832 - Flags: review?(clouserw) → review+
Comment on attachment 411832 [details] [diff] [review]
v2

Yes, ship it.
Does it work in Safari 3?
(In reply to comment #5)
> Does it work in Safari 3?

It didn't work for me in Opera 7 either. plsfix
Assignee

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 488406

Comment 10

9 years ago
Search unreviewed add-ons button states are changed with zamboni and there is no "allow me" options seen anymore. SO moving in-litmus: and in-testuite: to "-"

There is a test case for verifying unreviewed add-on:
https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=9435 - Button_states:Verify add-on button status for a Not Reviewed add-on for anonymous users
Flags: in-litmus? → in-litmus+

Updated

9 years ago
Flags: in-testsuite-
Flags: in-litmus-
Flags: in-litmus+
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.