Closed Bug 528583 Opened 10 years ago Closed 10 years ago

Version number not placed in Windows Add/Remove system (non-en-US builds)

Categories

(Thunderbird :: Installer, defect)

x86
Windows XP
defect
Not set

Tracking

(thunderbird3.0 .1-fixed)

VERIFIED FIXED
Thunderbird 3
Tracking Status
thunderbird3.0 --- .1-fixed

People

(Reporter: john, Assigned: standard8)

References

Details

(Keywords: polish, regression, Whiteboard: [tb3ride-along][fixed RC1 build 2])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0

Installed a fresh copy of Tb3 RC1 and came to uninstall it.

Add or Remove Programs shows

Mozilla Thunderbird ()

i.e. no version number.

Screenshot to come.


Reproducible: Always

Steps to Reproduce:
1.Install Tb3 RC1

Actual Results:  
Mozilla Thunderbird ()

shown in Add/Remove programs


Expected Results:  
Mozilla Thunderbird (3.0)
Blocks: qa-tb3.0rc1
Attached image Screenshot
Shows Add/Remove programs problem
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0
I can confirm this does fail on en-GB however.

Can anyone see if this happens on other locales?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Summary: Version number not placed in Windows Add/Remove system → Version number not placed in Windows Add/Remove system (en-GB and maybe other locales?)
Also reproducible with the en-GB build on Vista, FWIW.
(In reply to comment #3)
> Can anyone see if this happens on other locales?

I can confirm this behavior in .de
yeah, looks fine in vista and XP en-us
Version: unspecified → 3.0
Fr_fr exhibits the same issue.
Keywords: qawanted
I'm pretty sure I know what this is, but I need to test it before I can do a patch with confidence.
Assignee: nobody → bugzilla
This is a regression from bug 481374 and affects all locales. I'll attach a patch in a moment that will fix this.
Blocks: 481374
Flags: blocking-thunderbird3?
Keywords: polish, regression
Attached patch The fixSplinter Review
This fixes the issue by switching the mail/installer/windows files to use MOZ_APP_VERSION instead of a generated APP_VERSION

AFAICT the issue was caused by the fact that APP_VERSION was being generated in mail/installer/windows/Makefile from cat on the version.txt file. However, mail/locales/Makefile calls into the windows installer makefile when repackaging the installer files but doesn't re-run the cat, so APP_VERSION is undefined there (alternately something is actually undefined there causing APP_VERSION not to get set).

It appears Firefox doesn't have this issue because they define APP_VERSION in browser/locales/Makefile.in so the call across makefiles work (I'm not sure if this was on purpose or by accident, however for them it works).

As APP_VERSION is a shell call to cat, which ends up with exactly the same version string as obtained from MOZ_APP_VERSION (in confvars.sh), I'm proposing that we save ourselves the issues of needing a define and cat in two different makefiles, and just use MOZ_APP_VERSION.

I've tested this manually by following the buildbot steps using the repack log from the RC build and it worked fine from the installer perspective, all the current repacks (trunk + branch) have this bug so we can easily land and retest at each stage.

Doing a test upgrade from fr 3b3 to fr rc1 also switched the registry entries to the incorrect version, so I expect automatic upgrades will work fine and restore the correct value once we apply this patch.
Attachment #412557 - Flags: review?(gozer)
Whiteboard: [has patch][needs review gozer]
Attachment #412557 - Flags: review?(gozer) → review+
i installed shredder in jan or feb this year.

using
  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5pre) Gecko/20091026 Shredder/3.0pre

i see "Shredder (3.0pre)" with Windows Vista Business German in my "Programme and Funktionen" Control Panel.

Cheers,
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Whiteboard: [has patch][needs review gozer] → [has patch][read to land][tb3ride-along]
Summary: Version number not placed in Windows Add/Remove system (en-GB and maybe other locales?) → Version number not placed in Windows Add/Remove system (non-en-US builds)
Comment on attachment 412557 [details] [diff] [review]
The fix

a=Standard8 for my own low risk patch that does some polish to l10n installers.
Attachment #412557 - Flags: approval-thunderbird3+
Checked in:
http://hg.mozilla.org/comm-central/rev/e998e4a048b1
http://hg.mozilla.org/releases/comm-1.9.1/rev/de14f654ebce

I'll be landing this on the appropriate relbranch within the next 12 hours.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][read to land][tb3ride-along] → [tb3ride-along][fixed3.0.1pre]
Target Milestone: --- → Thunderbird 3.1a1
Duplicate of this bug: 529204
Checked into relbranch for build 2 of RC1:
http://hg.mozilla.org/releases/comm-1.9.1/rev/3f0b5a0455d9
Whiteboard: [tb3ride-along][fixed3.0.1pre] → [tb3ride-along][fixed RC1 build 2]
Target Milestone: Thunderbird 3.1a1 → Thunderbird 3
Status: RESOLVED → VERIFIED
Whiteboard: [tb3ride-along][fixed RC1 build 2] → [tb3ride-along][fixed RC1 build 2][fixedtb301]
Whiteboard: [tb3ride-along][fixed RC1 build 2][fixedtb301] → [tb3ride-along][fixed RC1 build 2]
You need to log in before you can comment on or make changes to this bug.