Closed Bug 528669 Opened 10 years ago Closed 10 years ago

Saving template/draft in unsynced folder when offline makes template disappear

Categories

(Thunderbird :: Message Compose Window, defect, critical)

x86
Windows Vista
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 397910

People

(Reporter: tuggyne, Unassigned)

References

Details

(Keywords: dataloss)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0

When I'm in offline mode and I save a template to a IMAP template folder that is not selected for offline synchronization, the template permanently disappears when I go online again. This destroys the contents of the template, obviously, and with no warning.

Reproducible: Always

Steps to Reproduce:
1. Unselect a template folder for offline use by context-clicking it, selecting Properties | Synchronization and clearing 'Select this folder for offline use'
2. Go offline
3. Create and save a message in that template folder, verifying that it is there
4. Go online again, and check the folder again
Actual Results:  
Newly saved template is gone.

Expected Results:  
Newly saved template should have been uploaded to server when Thunderbird went online.

(Alternatively, the template should never have successfully saved at all, but instead displayed a warning.)

I'm not sure how many of these repro steps and prerequisites (e.g. IMAP) are essential, but the ones I have repro the problem at any rate.
Blocks: qa-tb3.0rc1
Version: unspecified → 3.0
Keywords: dataloss
Problem is reproduced with next build, using Gmail IMAP.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091112 Shredder/3.0pre

1. Template has mail of UID=1 and UID=2. No offline use.
2. Work offline
3. Save 3 new templates while offline mode.
  "Subject"  "Order Received" column value(sorted by ascending order)
   mail-1    1
   mail-2    2
   mail-3    4294967168  (== 2**32 - 128)
   mail-4    4294967167  (== 2**32 - 129)
   mail-5    4294967166  (== 2**32 - 130)
4. Go back to online mode => mail-3/mail-4/mail-5 disappears.
Same problem occurs on Drafts.

Worong UID handling is involved?
2**32-128 and reversed order is "Order Received" column display only issue?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Saving template in unsynced folder when offline makes template disappear → Saving template/draft in unsynced folder when offline makes template disappear
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397910
You need to log in before you can comment on or make changes to this bug.