Browser tabs appear as separate pages in Windows 7 taskbar preview

RESOLVED DUPLICATE of bug 527974

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 527974
8 years ago
8 years ago

People

(Reporter: Viktor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b2) Gecko/20091108 Firefox/3.6b2

Just installed beta version. It seems like each tab shows up as a separate page in Win 7 taskbar preview. When you hoover your mouse cursor over FF in taskbar, a preview shows up that lets you choose which window you want to open. Well, that preview should only show one firefox window, but it shows tabs as separate windows. Very annoying when you have more than 5 tabs open at the same time. Didn't happen in FF 3.5, just this beta version. 

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 412443 [details]
screenshot of what happens

Updated

8 years ago
Blocks: 474056
Component: Tabbed Browser → Shell Integration
QA Contact: tabbed.browser → shell.integration
Duplicate of bug 524742 ?

Comment 3

8 years ago
Viktor, this is a intended feature and something new with Windows 7.  It doesn't happen in Firefox 3.5 and only shows one preview because Firefox 3.5 came out before Windows 7 and didn't use the api for the taskbar previews.  Firefox 3.6 does for the moment.  The next beta or the RC will have this feature disabled by default (due to some bugs) and will be on by default for Firefox 3.7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527974
You need to log in before you can comment on or make changes to this bug.